Android on the Asus Tinker Board

Android 6.0.1 Released for Asus Tinker Board

Android 6.0.1

Asus has now made available their first release of the Android operating system on the Asus Tinker Board. Asus has labelled the release as TinkerOS_Android V13.11.0.2 (Beta version). It’s a release of Android 6.0.1 running on kernel 3.10.0.

To install the operating system, users just need to use a disk tool to write the Android image to a micro SD card. This is included with the zip file (from Asus’s website – www.asus.com/Single-Board-Computer/Tinker-Board/HelpDesk_Download/).

Upgrade Disk Tool

There’s no progress bar to show how the image writing is proceeding. But when it’s completed and successful, you’ll receive the notification below.

SD Firmware Tool

My initial observation:

  • The first boot up takes a while – it seems an age before even an Android logo is displayed. Don’t reboot the Tinker Board.

Here’s a few screenshots of the apps. The 4K Video icon looks very interesting. More on that later.

Android on the Asus Tinker Board

Android 4K Video

Some technical information.

Technical Information

18 Comments

  • Francesco says:

    Hi, i have done a test but i have some problem, i correctly flashed the image with the given tool, then i linked hdmi, power and keyboard, it start with a black screen and the only red led on the board, then after a while all three led (red, yellow, green) on but no hdmi signl… it’s normal? what i have to do? Thank you

    • Steve Emms says:

      Hi Francesco

      The first boot takes an age before anything is displayed. Eventually the Android logo is displayed. If you pulled the plug before it’s booted, you might need to reflash the image. But try booting a few times first.

      • Johan says:

        I have the same problem, all the lamps light up first time and black screen, after awhile the TB shuts off and nothing happens? Are u suppose to wait for it to reboot by iitself?

        • Steve Emms says:

          The first boot takes a few minutes. If you don’t see the Android logo appear, I suggest trying with a different microsd card. If the logo doesn’t appear after say 10 minutes, you don’t have much choice other than pulling the power supply. Of course, this might corrupt the operating system.

    • Martin says:

      Hi Francesco
      Try to use different power supply and USB cable. I had same problem and better charger (5v 2A) and cable fix it. Thinker OS worked on your setup? I think that Thinker board is a bit picky on accessories.

      Martin

  • Hey Steve,

    Have you managed to install Google Play Services? Alternatively, do you have a link where it could be directly downloaded from?

    I’ll check this image out when I get home this evening. 🙂

    • Steve Emms says:

      Hi

      I’ve tried dozens of APKs from apkmirror.com, none have worked so far. If you get any success, please do let us know.

      • Same results here. Every package I tried in the line of Google packages to get Google Play services online and working –all failed. The results were services that crashed over and over, ad infinitum.

        I finally got sick of messing with it that night… I figure I’ll keep an eye on their releases over the next couple of weeks and try again, or else try my hand at making my own Android distro for it… once I have time to sit down at home and build out a dev environment for it… been really busy with work lately.

        “apkmirror.com” is a great site –one and the same that I used during my testing. I like how their site allows for browsing-by-vendor. That helped me to find what I was looking for in short order.

        Anyways, thanks Steve. 🙂

  • Eyekayu says:

    Instead of using apk mirror i would first install airdroid onto an actual android phone or tablet. Using web.airdroid.com from a computer, connect fo your device. Go to the apps tab’ select all apps and then press the download button. Unzip and save the apps to a sd card, plug it into your tinkerboard and side load the apps. Doing it this way i did not have any issues installing all the apps and games onto my tinkerboard. Kodi keeps crashing however. Some apps needs googleplay serviced to work and for some of my paid apps gplay services and gplay is needed

  • Steve Emms says:

    Hi Eyekayu. I was using apkmirror simply to try lots of different Google Play versions. I had already tried using the apk extracted from my android tablets and phones, all without success.

  • Jim T says:

    Just flashed Android Marshmallow with image file from Asus web site. Haven’t been able to locate any viable apk to install anything related to Google Play. Wifi works well and overall performance is better than android on any other sbc I’ve installed Android on, including Odroid xu4.

  • Sunny Jassal says:

    i have tried the instructions and when i load the IOS file on to Disk Tool 1.4 it keeps giving me an error
    Opening firmware faileds

    i have also tried other tools i get success when i i put it on a Tinker Board its stuck

    has anyone else experienced this ??

  • BW says:

    I got Tinker OS to run from a USB pretty easily, it is similar for the Android version?

  • serboy says:

    Is there any touch screen for android os for tinker board?

    • yomo says:

      You can use raspberry pi touch screens on the Asus tinker board

      • serboy says:

        I did tried that but. There is a resolution problem. When I did clicked top of the screen it is not effect the top. Some times it effect other places which I did not clicked. What is default resolution of thinker board, or can it change from settings?

Leave a Reply