<!DOCTYPE html>
<html lang="en-US" prefix="og: http://ogp.me/ns#">
	<head>
		<meta http-equiv="content-type" content="text/html; charset=UTF-8" />
		<meta http-equiv="X-UA-Compatible" content="IE=edge">
		<meta name="viewport" content="width=device-width, initial-scale=1">
					<link rel="pingback" href="https://www.ossblog.org/xmlrpc.php">
				<title>Grasp Perl with Open-Source Books - OSS Blog</title>

<!-- This site is optimized with the Yoast SEO plugin v4.3 - https://yoast.com/wordpress/plugins/seo/ -->
<link rel="canonical" href="https://www.ossblog.org/grasp-perl-open-source-books/" />
<link rel="next" href="https://www.ossblog.org/grasp-perl-open-source-books/2/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Grasp Perl with Open-Source Books - OSS Blog" />
<meta property="og:description" content="Programming is about solving problems and good communication. But before code is written, you need to know how to solve&hellip;" />
<meta property="og:url" content="https://www.ossblog.org/grasp-perl-open-source-books/" />
<meta property="og:site_name" content="OSS Blog" />
<meta property="article:tag" content="books" />
<meta property="article:tag" content="Perl" />
<meta property="article:tag" content="programming" />
<meta property="article:section" content="Books" />
<meta property="article:published_time" content="2017-02-23T16:08:10+00:00" />
<meta property="og:image" content="https://www.ossblog.org/wp-content/uploads/2017/02/Perl-Montage.jpg" />
<meta property="og:image:width" content="579" />
<meta property="og:image:height" content="246" />
<meta name="twitter:card" content="summary" />
<meta name="twitter:description" content="Programming is about solving problems and good communication. But before code is written, you need to know how to solve&hellip;" />
<meta name="twitter:title" content="Grasp Perl with Open-Source Books - OSS Blog" />
<meta name="twitter:image" content="https://i1.wp.com/www.ossblog.org/wp-content/uploads/2017/02/Perl-Montage.jpg?fit=579%2C246&#038;ssl=1" />
<!-- / Yoast SEO plugin. -->

<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//secure.gravatar.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="OSS Blog &raquo; Feed" href="https://www.ossblog.org/feed/" />
<link rel="alternate" type="application/rss+xml" title="OSS Blog &raquo; Comments Feed" href="https://www.ossblog.org/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="OSS Blog &raquo; Grasp Perl with Open-Source Books Comments Feed" href="https://www.ossblog.org/grasp-perl-open-source-books/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.2.1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.2.1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.ossblog.org\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.7.2"}};
			!function(a,b,c){function d(a){var b,c,d,e,f=String.fromCharCode;if(!k||!k.fillText)return!1;switch(k.clearRect(0,0,j.width,j.height),k.textBaseline="top",k.font="600 32px Arial",a){case"flag":return k.fillText(f(55356,56826,55356,56819),0,0),!(j.toDataURL().length<3e3)&&(k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57331,65039,8205,55356,57096),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57331,55356,57096),0,0),c=j.toDataURL(),b!==c);case"emoji4":return k.fillText(f(55357,56425,55356,57341,8205,55357,56507),0,0),d=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55357,56425,55356,57341,55357,56507),0,0),e=j.toDataURL(),d!==e}return!1}function e(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var f,g,h,i,j=b.createElement("canvas"),k=j.getContext&&j.getContext("2d");for(i=Array("flag","emoji4"),c.supports={everything:!0,everythingExceptFlag:!0},h=0;h<i.length;h++)c.supports[i[h]]=d(i[h]),c.supports.everything=c.supports.everything&&c.supports[i[h]],"flag"!==i[h]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[i[h]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(g=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",g,!1),a.addEventListener("load",g,!1)):(a.attachEvent("onload",g),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),f=c.source||{},f.concatemoji?e(f.concatemoji):f.wpemoji&&f.twemoji&&(e(f.twemoji),e(f.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='wp-pagenavi-css'  href='https://www.ossblog.org/wp-content/plugins/wp-pagenavi/pagenavi-css.css?ver=2.70' type='text/css' media='all' />
<link rel='stylesheet' id='quads-styles-css'  href='https://www.ossblog.org/wp-content/plugins/quick-adsense-reloaded/assets/css/quads.css?ver=1.4.7' type='text/css' media='all' />
<link rel='stylesheet' id='bootstrap-css-css'  href='https://www.ossblog.org/wp-content/themes/first-mag/css/bootstrap.css?ver=1' type='text/css' media='all' />
<link rel='stylesheet' id='first-mag-stylesheet-css'  href='https://www.ossblog.org/wp-content/themes/responsive-magazine/style.css?ver=1' type='text/css' media='all' />
<link rel='stylesheet' id='font-awesome-css'  href='https://www.ossblog.org/wp-content/themes/first-mag/css/font-awesome.min.css?ver=4.7.2' type='text/css' media='all' />
<link rel='stylesheet' id='flexslider-css'  href='https://www.ossblog.org/wp-content/themes/first-mag/css/flexslider.css?ver=4.7.2' type='text/css' media='all' />
<link rel='stylesheet' id='tablepress-default-css'  href='https://www.ossblog.org/wp-content/plugins/tablepress/css/default.min.css?ver=1.7' type='text/css' media='all' />
<link rel='stylesheet' id='responsive-magazine-style-css'  href='https://www.ossblog.org/wp-content/themes/first-mag/style.css?ver=4.7.2' type='text/css' media='all' />
<link rel='stylesheet' id='kirki-styles-first_mag_settings-css'  href='https://www.ossblog.org/wp-content/plugins/kirki/assets/css/kirki-styles.css' type='text/css' media='all' />
<style id='kirki-styles-first_mag_settings-inline-css' type='text/css'>
.rsrc-header-img{margin-top:0px;margin-bottom:0px;margin-left:0px;margin-right:0px;}.rsrc-header-text a{color:#222 !important;}.rsrc-header-text h4{color:#B6B6B6;}body{background-color:rgba(244,244,244,1);background-repeat:no-repeat;background-attachment:fixed;background-position:center center;-webkit-background-size:cover;-moz-background-size:cover;-ms-background-size:cover;-o-background-size:cover;background-size:cover;}
</style>
<!--[if lte IE 8]>
<link rel='stylesheet' id='jetpack-carousel-ie8fix-css'  href='https://www.ossblog.org/wp-content/plugins/jetpack/modules/carousel/jetpack-carousel-ie8fix.css?ver=20121024' type='text/css' media='all' />
<![endif]-->
<link rel='stylesheet' id='social-logos-css'  href='https://www.ossblog.org/wp-content/plugins/jetpack/_inc/social-logos/social-logos.min.css?ver=1' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='https://www.ossblog.org/wp-content/plugins/jetpack/css/jetpack.css?ver=4.6' type='text/css' media='all' />
<!-- This site uses the Google Analytics by MonsterInsights plugin v6.0.4 - Using Analytics tracking - https://www.monsterinsights.com/ -->
<script type="text/javascript" data-cfasync="false">
		(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
			(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
			m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
		})(window,document,'script','//www.google-analytics.com/analytics.js','__gaTracker');

	  __gaTracker('create', 'UA-1447713-3', 'auto');
  __gaTracker('set', 'forceSSL', true);
  __gaTracker('send','pageview');

</script>
<!-- / Google Analytics by MonsterInsights -->
<script type='text/javascript' src='https://www.ossblog.org/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='https://www.ossblog.org/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var related_posts_js_options = {"post_heading":"h4"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.ossblog.org/wp-content/plugins/jetpack/modules/related-posts/related-posts.js?ver=20150408'></script>
<script type='text/javascript' src='https://www.ossblog.org/wp-content/themes/first-mag/js/bootstrap.min.js?ver=4.7.2'></script>
<script type='text/javascript' src='https://www.ossblog.org/wp-content/themes/first-mag/js/customscript.js?ver=4.7.2'></script>
<script type='text/javascript' src='https://www.ossblog.org/wp-content/themes/first-mag/js/jquery.flexslider-min.js?ver=4.7.2'></script>
<script type='text/javascript' src='https://www.ossblog.org/wp-content/themes/responsive-magazine/js/customscript-responsive-magazine.js?ver=1'></script>
<script type='text/javascript' src='https://www.ossblog.org/wp-content/plugins/jetpack/_inc/spin.js?ver=1.3'></script>
<script type='text/javascript' src='https://www.ossblog.org/wp-content/plugins/jetpack/_inc/jquery.spin.js?ver=1.3'></script>
<link rel='https://api.w.org/' href='https://www.ossblog.org/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.ossblog.org/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.ossblog.org/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 4.7.2" />
<link rel='shortlink' href='https://wp.me/p8gHzV-iK' />
<link rel="alternate" type="application/json+oembed" href="https://www.ossblog.org/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.ossblog.org%2Fgrasp-perl-open-source-books%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.ossblog.org/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.ossblog.org%2Fgrasp-perl-open-source-books%2F&#038;format=xml" />

<link rel='dns-prefetch' href='//v0.wordpress.com'>
<link rel='dns-prefetch' href='//i0.wp.com'>
<link rel='dns-prefetch' href='//i1.wp.com'>
<link rel='dns-prefetch' href='//i2.wp.com'>
<link rel='dns-prefetch' href='//jetpack.wordpress.com'>
<link rel='dns-prefetch' href='//s0.wp.com'>
<link rel='dns-prefetch' href='//s1.wp.com'>
<link rel='dns-prefetch' href='//s2.wp.com'>
<link rel='dns-prefetch' href='//public-api.wordpress.com'>
<link rel='dns-prefetch' href='//0.gravatar.com'>
<link rel='dns-prefetch' href='//1.gravatar.com'>
<link rel='dns-prefetch' href='//2.gravatar.com'>
<link rel='dns-prefetch' href='//widgets.wp.com'>
<style type='text/css'>img#wpstats{display:none}</style><meta name="title" content="Grasp Perl with Open-Source Books | OSS Blog" />
<meta name="description" content="Programming is about solving problems and good communication. But before code is written, you need to know how to solve the problem. Breaking the problem into component parts assists in the process. And being able to model the problem so that it&#039;s easy to implement and test also helps. Combine this with a solid understanding of&hellip;" />
	</head>
	<body id="blog" class="post-template-default single single-post postid-1162 single-format-standard">


<div class="container rsrc-container" role="main">
	 
    <header id="site-header" class="row rsrc-header" role="banner">  
					<div class="rsrc-header-img col-md-4">
				<a href="https://www.ossblog.org/"><img src="https://www.ossblog.org/wp-content/uploads/2017/01/OSSBlog-header.png" title="OSS Blog" /></a>
			</div>
				<div class="header-ad col-md-8">
							<div id="header-ad-section" class="clearfix">
					<div id="search-5" class="widget widget_search"><form role="search" method="get" id="searchform" class="searchform" action="https://www.ossblog.org/">
				<div>
					<label class="screen-reader-text" for="s">Search for:</label>
					<input type="text" value="" name="s" id="s" />
					<input type="submit" id="searchsubmit" value="Search" />
				</div>
			</form></div><div id="text-4" class="widget widget_text">			<div class="textwidget"><A HREF="https://www.ossblog.org/top-software/">Top Software</A> - <A HREF="https://www.ossblog.org/books/">Books</A> - <A HREF="https://www.ossblog.org/about/">About</A></div>
		</div>				</div>
					</div>
    </header> 




<!-- start content container -->
<!-- start content container -->
                                
	<div class="single-thumbnail row"><img width="579" height="246" src="https://i1.wp.com/www.ossblog.org/wp-content/uploads/2017/02/Perl-Montage.jpg?resize=579%2C246&amp;ssl=1" class="attachment-first-mag-single size-first-mag-single wp-post-image" alt="Perl banner" srcset="https://i1.wp.com/www.ossblog.org/wp-content/uploads/2017/02/Perl-Montage.jpg?w=579&amp;ssl=1 579w, https://i1.wp.com/www.ossblog.org/wp-content/uploads/2017/02/Perl-Montage.jpg?resize=300%2C127&amp;ssl=1 300w" sizes="(max-width: 579px) 100vw, 579px" data-attachment-id="1273" data-permalink="https://www.ossblog.org/perl-montage/" data-orig-file="https://i1.wp.com/www.ossblog.org/wp-content/uploads/2017/02/Perl-Montage.jpg?fit=579%2C246&amp;ssl=1" data-orig-size="579,246" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Perl-Montage" data-image-description="" data-medium-file="https://i1.wp.com/www.ossblog.org/wp-content/uploads/2017/02/Perl-Montage.jpg?fit=300%2C127&amp;ssl=1" data-large-file="https://i1.wp.com/www.ossblog.org/wp-content/uploads/2017/02/Perl-Montage.jpg?fit=579%2C246&amp;ssl=1" /></div>                                     
	<div class="clear"></div>                            
 
<div class="row rsrc-content">    
	    
	    
	<article class="col-md-9 rsrc-main">        
		         
				<div id="breadcrumbs" ><div class="breadcrumbs-inner text-right"><span><a href="https://www.ossblog.org"><i class="fa fa-home"></i><span>Home</span></a></span> &raquo;  <span><a href="https://www.ossblog.org/category/books/"><span>Books</span></a></span> &raquo;  <span><a href="https://www.ossblog.org/category/programming/"><span>Programming</span></a></span> &raquo;  Grasp Perl with Open-Source Books</div></div>                
				<div class="rsrc-post-content post-1162 post type-post status-publish format-standard has-post-thumbnail hentry category-books category-programming tag-books tag-perl tag-programming">                            
					<header>                              
						<h1 class="entry-title page-header">
							Grasp Perl with Open-Source Books						</h1>                              
						<p class="post-meta text-left"> 
	<span class="fa fa-clock-o"></span> <time class="posted-on published" datetime="2017-02-23">February 23, 2017</time>
	<span class="fa fa-user"></span> <span class="author-link"><a href="https://www.ossblog.org/author/steve/" title="Posts by Steve Emms" rel="author">Steve Emms</a></span>
	<span class="fa fa-comment"></span> <span class="comments-meta"><a href="https://www.ossblog.org/grasp-perl-open-source-books/#respond" class="comments-link" >0</a></span>
	<span class="fa fa-folder-open meta-cat-icon"></span>
	<span class="meta-cat"><a href="https://www.ossblog.org/category/books/" title="View all posts in Books">Books</a>, </span><span class="meta-cat"><a href="https://www.ossblog.org/category/programming/" title="View all posts in Programming">Programming</a>, </span>	</p>                            
					</header>                                                                                     
					<div class="entry-content" >
						<p>Programming is about solving problems and good communication. But before code is written, you need to know how to solve the problem. Breaking the problem into component parts assists in the process. And being able to model the problem so that it&#8217;s easy to implement and test also helps. Combine this with a solid understanding of the programming language itself &#8211; a good programming book contributes to all aspects of problem solving. Perl has the virtue it can solve a problems in a few lines of code. Perl programmers solve problems and get things done.</p>
<p>The popularity of a book is influenced by personal feelings, tastes, and opinions. Programming books accord to this general rule. There is a wide range of Perl books. As Perl is an open source programming language, with an eclectic heritage written by Larry Wall with thousands of contributors, it is welcome some authors have released their Perl books under a freely distributable license. I select 16 excellent Perl books (divided into 2 pages) which help master this language. All of the books are released under an open source license.</p>
<p>By way of background, Perl is a high-level, general-purpose, interpreted, scripting, dynamic programming language released under the GPL or Artistic license. Perl&#8217;s syntax has its roots in shell scripting tools, borrowing features from other languages including C, shell script (sh), AWK, and sed. It is available for most operating systems. Perl is implemented as an interpreted (not compiled) language. It is procedural, with variables, expressions, assignment statements, control structures, blocks and subroutines.</p>
<p>Perl is a versatile language. It is often used to write (CGI) scripts, manipulate text, general web programming, networking, system administration, prototyping, database access, and graphical programming. One of the most powerful features of Perl is its extensive library of modules. Many of these modules are available from the Comprehensive Perl Archive Network, which mirrors over 178,000 Perl modules.</p>
<p>Books 1-8 are listed below. Books 9-16 are on the next page.</p>
<table cellpadding="5">
<tbody>
<tr>
<td style="width: 200px;"><img data-attachment-id="1169" data-permalink="https://www.ossblog.org/modernperl/" data-orig-file="https://i2.wp.com/www.ossblog.org/wp-content/uploads/2017/02/ModernPerl.jpg?fit=200%2C246&amp;ssl=1" data-orig-size="200,246" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="ModernPerl" data-image-description="" data-medium-file="https://i2.wp.com/www.ossblog.org/wp-content/uploads/2017/02/ModernPerl.jpg?fit=200%2C246&amp;ssl=1" data-large-file="https://i2.wp.com/www.ossblog.org/wp-content/uploads/2017/02/ModernPerl.jpg?fit=200%2C246&amp;ssl=1" class="alignnone wp-image-1169 size-full" src="https://i2.wp.com/www.ossblog.org/wp-content/uploads/2017/02/ModernPerl.jpg?resize=200%2C246&#038;ssl=1" alt="Modern Perl" data-recalc-dims="1" /></td>
<td style="width: 545px;">
<h3><a href="http://modernperlbooks.com/books/modern_perl_2016/index.html"><span style="color: #000080;">Modern Perl</span></a></h3>
<p>By <span class="a-size-medium">Chromatic</span> (290 pages)</p>
<p>Modern Perl is designed to help programmers of all levels of proficiency. The book is not just a Perl tutorial. It explains how and why the language works, so that the full power of Perl can be unleashed. The book is updated for Perl 5.22, to demonstrate the latest and most effective time-saving features.</p>
<p>Modern Perl is one way to describe the way the world&#8217;s most effective Perl 5 programmers work. They use language idioms. They take advantage of the CPAN. They show good taste and craft to write powerful, maintainable, scalable, concise, and effective code.</p>
<p>This book providing a wealth of information on:</p>
<ul>
<li>The Perl philosophy</li>
<li>Perl and its community focusing on CPAN, community and development sites</li>
<li>The Perl language introducing names, variables, values, control flow, scalars, arrays, hashes, coercion, packages, references, and nested data structures</li>
<li>Operators &#8211; a series of one or more symbols used as part of the syntax</li>
<li>Functions &#8211; a discrete, encapsulated unit of behaviour</li>
<li>Regular Expressions and Matching &#8211; this chapter overviews the important regex features</li>
<li>Objects &#8211; discrete, unique entities with their own identities</li>
<li>Advanced OO Perl</li>
<li>Style and Efficacy explaining the importance of writing maintainable, idiomatic, and effective Perl</li>
<li>Managing Real Problems covering testing, handling warnings, files, modules, distributions, and more</li>
<li>Perl Beyond Syntax</li>
<li>What to Avoid</li>
</ul>
<p>The electronic versions of this book are released under the Creative Commons Attribution-NonCommercial-NoDerivs 3.0 Unported License.</td>
</tr>
<tr>
<td style="width: 200px;"><img data-attachment-id="1193" data-permalink="https://www.ossblog.org/perllanguagereferencemanual/" data-orig-file="https://i1.wp.com/www.ossblog.org/wp-content/uploads/2017/02/PerlLanguageReferenceManual.png?fit=200%2C301&amp;ssl=1" data-orig-size="200,301" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="PerlLanguageReferenceManual" data-image-description="" data-medium-file="https://i1.wp.com/www.ossblog.org/wp-content/uploads/2017/02/PerlLanguageReferenceManual.png?fit=199%2C300&amp;ssl=1" data-large-file="https://i1.wp.com/www.ossblog.org/wp-content/uploads/2017/02/PerlLanguageReferenceManual.png?fit=200%2C301&amp;ssl=1" class="alignnone wp-image-1193 size-full" src="https://i1.wp.com/www.ossblog.org/wp-content/uploads/2017/02/PerlLanguageReferenceManual.png?resize=200%2C301&#038;ssl=1" alt="Perl Language Reference Manual" srcset="https://i1.wp.com/www.ossblog.org/wp-content/uploads/2017/02/PerlLanguageReferenceManual.png?w=200&amp;ssl=1 200w, https://i1.wp.com/www.ossblog.org/wp-content/uploads/2017/02/PerlLanguageReferenceManual.png?resize=199%2C300&amp;ssl=1 199w" sizes="(max-width: 200px) 100vw, 200px" data-recalc-dims="1" /></td>
<td style="width: 545px;">
<h3><span style="color: #000080;"><a href="http://www.network-theory.co.uk/perl/language/">The Perl Language Reference Manual</a></span></h3>
<p>By Larry Wall and others (724 pages)</p>
<p>This book describes the syntax of Perl and its built-in datatypes, operators, functions, variables, regular expressions and diagnostic messages. There is a complete copy of the book in HTML format.</p>
<p>Topics cover:</p>
<ul>
<li>Introduction &#8211; a quick overview of Perl along with pointers to further documentation</li>
<li>How to execute the Perl interpreter</li>
<li>Perl syntax including declarations, comments, simple statements, compound statements, loop control, for loops, switch statements, and more</li>
<li>Perl data types such as variable names, scalar values, scalar value constructors (version strings, special literals, barewords, and array joining delimiter), list value constructors, subscripts, and slices</li>
<li>How Perl internally handles numeric values</li>
<li>Perl operators and precedence</li>
<li>Perl subroutines</li>
<li>Perl built-in functions</li>
<li>Pre-defined variables</li>
<li>Regular expressions &#8211; describes the syntax of regular expressions in Perl</li>
<li>Regular expression backslash sequences &#8211; describes all backslash and escape sequences</li>
<li>Regular expression character classes &#8211; discusses the syntax and use of character classes in Perl regular expressions</li>
<li>Quick reference to Perl&#8217;s regular expressions</li>
<li>Perl references and nested data structures</li>
<li>Perl objects</li>
</ul>
<p>and much more&#8230;</p>
<p>This book is published under the GNU General Public License, version 3.</td>
</tr>
<tr>
<td style="width: 200px;"><img data-attachment-id="1217" data-permalink="https://www.ossblog.org/grasp-perl-open-source-books/beginningperl/" data-orig-file="https://i0.wp.com/www.ossblog.org/wp-content/uploads/2017/02/BeginningPerl.jpg?fit=200%2C258&amp;ssl=1" data-orig-size="200,258" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="BeginningPerl" data-image-description="" data-medium-file="https://i0.wp.com/www.ossblog.org/wp-content/uploads/2017/02/BeginningPerl.jpg?fit=200%2C258&amp;ssl=1" data-large-file="https://i0.wp.com/www.ossblog.org/wp-content/uploads/2017/02/BeginningPerl.jpg?fit=200%2C258&amp;ssl=1" class="alignnone wp-image-1217 size-full" src="https://i0.wp.com/www.ossblog.org/wp-content/uploads/2017/02/BeginningPerl.jpg?resize=200%2C258&#038;ssl=1" alt="Beginning Perl" data-recalc-dims="1" /></td>
<td style="width: 545px;">
<h3><a href="https://www.perl.org/books/beginning-perl/"><span style="color: #000080;">Beginning Perl </span></a></h3>
<p>By Simon Cozens (1029 pages)</p>
<p>Beginning Perl is a book which as its name suggests is written for beginners. It starts with the absolute basics of Perl, guiding the reader carefully through to complex operations such as using Perl as a CGI language. It covers the whole of the core Perl language.</p>
<p>The book covers the following topics:</p>
<ul>
<li>Installing Perl on Windows and UNIX</li>
<li>Working with simple values</li>
<li>Lists and Hashes &#8211; looks at some control structures, and learn how to process data more than once without reproducing code</li>
<li>Loops and Decisions</li>
<li>Regular Expressions &#8211; one of the most powerful features of Perl</li>
<li>Files and Data &#8211; shows you how to read and write to files, and techniques for handling files, directories, and data</li>
<li>References</li>
<li>Subroutines &#8211; define, order of declaration, parameters and arguments, return values</li>
<li>Running and Debugging Perl &#8211; covers error messages, diagnostic modules, Perl command line switches, and debugging techniques / Perl debugger</li>
<li>Modules &#8211; examines how Perl works with DataBase Manager modules and DataBase Interface module</li>
<li>Using Perl as an object-oriented language</li>
<li>Introduction to CGI &#8211; looks at how CGI works by writing some simple CGI scripts and using the CGI.pm module</li>
<li>Perl and Databases</li>
<li>The World of Perl &#8211; tempts the programmer on what they can do with Perl</li>
</ul>
<p>The book is licensed under the Creative Commons Attribution-NoDerivs-NonCommercial License.</td>
</tr>
<tr>
<td style="width: 200px;"><img data-attachment-id="1182" data-permalink="https://www.ossblog.org/praticalmodperl/" data-orig-file="https://i2.wp.com/www.ossblog.org/wp-content/uploads/2017/02/PraticalmodPerl.jpg?fit=200%2C262&amp;ssl=1" data-orig-size="200,262" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;1&quot;}" data-image-title="PraticalmodPerl" data-image-description="" data-medium-file="https://i2.wp.com/www.ossblog.org/wp-content/uploads/2017/02/PraticalmodPerl.jpg?fit=200%2C262&amp;ssl=1" data-large-file="https://i2.wp.com/www.ossblog.org/wp-content/uploads/2017/02/PraticalmodPerl.jpg?fit=200%2C262&amp;ssl=1" class="alignnone wp-image-1182 size-full" src="https://i2.wp.com/www.ossblog.org/wp-content/uploads/2017/02/PraticalmodPerl.jpg?resize=200%2C262&#038;ssl=1" alt="Pratical mod_perl" data-recalc-dims="1" /></td>
<td style="width: 545px;">
<h3><a href="http://web.archive.org/web/20161006214712/http://modperlbook.org/"><span style="color: #000080;">Practical mod_perl</span></a></h3>
<p>By Eric Cholet, Stas Bekman (924 pages)</p>
<p>Practical mod_perl is regarded as the definitive book on how to use, optimize, and troubleshoot mod_perl. It&#8217;s an extensive guide to the nuts and bolts of the powerful and popular combination of Apache and mod_perl. From writing and debugging scripts to keeping your server running without failures, the techniques in this book will help you squeeze every ounce of power out of your server.</p>
<p>mod_perl is an Apache module that builds the power of the Perl programming language directly into the Apache web server, giving rise to a fast and powerful web programming environment.</p>
<p>The book covers the following topics, and more:</p>
<ul>
<li>Configuring mod_perl optimally for your web site</li>
<li>Porting and optimizing programs for a mod_perl environment</li>
<li>Performance tuning: getting the very fastest performance from your site</li>
<li>Controlling and monitoring the server to circumvent crashes and clogs</li>
<li>Integrating with databases efficiently and painlessly</li>
<li>Debugging tips and tricks</li>
<li>Maximizing security</li>
</ul>
<p>The site&#8217;s website has been down since October 2016, but there is a copy of the book available at archive.org.</p>
<p>The complete book is available online under the terms of the CreativeCommons Attribution Share-Alike License.</td>
</tr>
<tr>
<td style="width: 200px;"><img data-attachment-id="1224" data-permalink="https://www.ossblog.org/extremeprogramminginperl/" data-orig-file="https://i2.wp.com/www.ossblog.org/wp-content/uploads/2017/02/ExtremeProgramminginPerl.png?fit=200%2C262&amp;ssl=1" data-orig-size="200,262" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="ExtremeProgramminginPerl" data-image-description="" data-medium-file="https://i2.wp.com/www.ossblog.org/wp-content/uploads/2017/02/ExtremeProgramminginPerl.png?fit=200%2C262&amp;ssl=1" data-large-file="https://i2.wp.com/www.ossblog.org/wp-content/uploads/2017/02/ExtremeProgramminginPerl.png?fit=200%2C262&amp;ssl=1" class="alignnone wp-image-1224 size-full" src="https://i2.wp.com/www.ossblog.org/wp-content/uploads/2017/02/ExtremeProgramminginPerl.png?resize=200%2C262&#038;ssl=1" alt="Extreme Programming in Perl" data-recalc-dims="1" /></td>
<td style="width: 545px;">
<h3><a href="http://www.extremeperl.org/"><span style="color: #000080;">Extreme Programming in Perl</span></a></h3>
<p>By Robert Nagler (182 pages)</p>
<p>Extreme Perl is a book about Extreme Programming, a software development methodology that enables users, business people, programmers, and computers to communicate effectively, using the programming language Perl.</p>
<p>This book invites Perl programmers and their customers to take a fresh look at software development. Customers, and business people in general, will learn how Extreme Programming enables customer-programmer communication for efficient and flexible requirements gathering. Programmers will see how the methodology&#8217;s focus on teamwork, incremental testing, and continuous design allows them to take pride in their craft.</p>
<p>Areas covered include:</p>
<ul>
<li>Release Planning &#8211; a list of stories (requirements) prioritized by business value</li>
<li>Iteration Planning &#8211; a prioritized list of development tasks estimated by the people who will be implementing them</li>
<li>Pair Programming &#8211; the output is one or more unit tests and the software that passes those tests</li>
<li>Tracking &#8211; explains how tracking works, what&#8217;s tracked, ways to keep everybody informed, and most importantly, how to get back on track</li>
<li>Acceptance Testing &#8211; demonstrates how the customer can create automated acceptance tests. Acceptance tests are explained in general and with example test scripts</li>
<li>Coding Style &#8211; explains the need for a coding style in XP and discusses how to go about creating one</li>
<li>Test Driven Design &#8211; introduces test-driven design through the implementation of an exponential moving average (EMA), a simple but useful mathematical function. This chapter also explains how to use the CPAN modules Test::More and Test::Exception</li>
<li>Continuous Design &#8211; evolves the design we started in Test-Driven Design</li>
<li>Unit Testing &#8211; test a post office protocol (POP3) client available from CPAN</li>
<li>Refactoring &#8211; demonstrates several refactorings in the context of a single example, Mail::POP3Client.</li>
</ul>
<p>The book is licensed under a Creative Commons Attribution 4.0 International License.</td>
</tr>
<tr>
<td style="width: 200px;"><img data-attachment-id="1235" data-permalink="https://www.ossblog.org/impatientperl/" data-orig-file="https://i1.wp.com/www.ossblog.org/wp-content/uploads/2017/02/ImpatientPerl.png?fit=200%2C261&amp;ssl=1" data-orig-size="200,261" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="ImpatientPerl" data-image-description="" data-medium-file="https://i1.wp.com/www.ossblog.org/wp-content/uploads/2017/02/ImpatientPerl.png?fit=200%2C261&amp;ssl=1" data-large-file="https://i1.wp.com/www.ossblog.org/wp-content/uploads/2017/02/ImpatientPerl.png?fit=200%2C261&amp;ssl=1" class="alignnone wp-image-1235 size-full" src="https://i1.wp.com/www.ossblog.org/wp-content/uploads/2017/02/ImpatientPerl.png?resize=200%2C261&#038;ssl=1" alt="Impatient Perl" data-recalc-dims="1" /></td>
<td style="width: 545px;">
<h3><a href="https://www.perl.org/books/impatient-perl/"><span style="color: #000080;">Impatient Perl</span></a></h3>
<p>By Greg London (151 pages)</p>
<p>Impatient Perl is designed for individuals who wish to learn Perl or individuals that already program in Perl and do not have the patience to search for information to learn and use Perl. The book should be a useful desk reference for common Perl related questions.</p>
<p>Topics covered include:</p>
<ul>
<li>The three basic storage types:
<ul>
<li>Scalars &#8211; store strings, numbers (integers and floats), references, and filehandles</li>
</ul>
<ul>
<li>Arrays &#8211; stores a collection of scalars via an integer index</li>
</ul>
<ul>
<li>Hashes &#8211; stores scalars that are accessed via a string index</li>
</ul>
</li>
<li>List Context &#8211; a concept built into the grammar of Perl</li>
<li>References &#8211; points to something else</li>
<li>Control Flow &#8211; allow developers to alter the order of execution while the application is running</li>
<li>Packages and Namespaces and Lexical Scoping</li>
<li>Subroutines</li>
<li>Compiling and Interpreting &#8211; compiling translates the source test into machine usable internal format; interpreting &#8211; executing the machine usable, internal format</li>
<li>Code Reuse, Perl Modules &#8211; a discrete component of software for the Perl programming language</li>
<li>The use Statement &#8211; allows a Perl script to bring in a Perl module and what declarations that have been made available by the module</li>
<li>bless() &#8211; this function changes the string that would be returned when ref() is called</li>
<li>Method Calls</li>
<li>Procedural Perl</li>
<li>Object Oriented Perl</li>
<li>Object Oriented Review</li>
<li>CPAN &#8211; Comprehensive Perl Archive Network which contains a huge number of Perl modules to download</li>
<li>The Next Level</li>
<li>Command Line Arguments</li>
<li>File Input and Output &#8211; Perl has functions used for reading from and writing to files</li>
<li>Operating System Commands</li>
<li>Regular Expressions &#8211; the text processing workhouse of Perl. Regular expressions lets you search strings for patterns, find out what matched the patterns, and substitute the matched patterns with new strings</li>
<li>Modifiers &#8211; regular expressions can take optional modifiers that tell Perl additional information about how to interpret the regular expression</li>
<li>Parsing with Parse::RecDescent</li>
<li>Perl, GUI and Tk</li>
</ul>
<p>This book is made available under the GNU Free Documentation License, Version 1.3 or later. The author has kindly given permission for this article to include a copy of the front-cover.</td>
</tr>
<tr>
<td style="width: 200px;"><img data-attachment-id="1185" data-permalink="https://www.ossblog.org/perllwp/" data-orig-file="https://i1.wp.com/www.ossblog.org/wp-content/uploads/2017/02/PerlLWP.jpg?fit=200%2C262&amp;ssl=1" data-orig-size="200,262" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="PerlLWP" data-image-description="" data-medium-file="https://i1.wp.com/www.ossblog.org/wp-content/uploads/2017/02/PerlLWP.jpg?fit=200%2C262&amp;ssl=1" data-large-file="https://i1.wp.com/www.ossblog.org/wp-content/uploads/2017/02/PerlLWP.jpg?fit=200%2C262&amp;ssl=1" class="alignnone wp-image-1185 size-full" src="https://i1.wp.com/www.ossblog.org/wp-content/uploads/2017/02/PerlLWP.jpg?resize=200%2C262&#038;ssl=1" alt="Perl &amp; LWP" data-recalc-dims="1" /></td>
<td style="width: 545px;">
<h3><span style="color: #000080;"><a href="http://lwp.interglacial.com/">Perl &amp; LWP</a><br />
</span></h3>
<p>By Sean M. Burke (343 pages)</p>
<p>Perl &amp; LWP instructs how individuals can write web client applications with LWP and its related HTML modules. Library for WWW in Perl is a set of modules that allow requests to be sent to the web.</p>
<p>The book has chapters on:</p>
<ul>
<li>Web Basics &#8211; covers the construction of URLs and the concepts behind HTTP. You&#8217;ll learn how to automate the most basic web tasks with the LWP::Simple module</li>
<li>The LWP Class Model &#8211; introduces the classes that LWP uses to represent browser objects and response objects</li>
<li>URLs &#8211; parsing, constructors, output, comparison, components of a URL, and queries</li>
<li>Forms &#8211; shows you how to write programs to submit form data and get the resulting page</li>
<li>Simple HTML Processing with Regular Expressions</li>
<li>HTML Processing with Tokens &#8211; use a rudimentary approach to processing HTML source: Perl regular expressions</li>
<li>Tokenizing Walkthrough &#8211; walks though the implementation of a data extraction task</li>
<li>HTML Processing with Trees &#8211; teaches you how to use the HTML::TreeBuilder module to construct trees from HTML, and how to process those trees to extract information</li>
<li>Modifying HTML with Trees &#8211; four ways in which a tree can be altered: alter a node&#8217;s attributes; delete a node; detach a node and reattach it elsewhere; add a new node</li>
<li>Cookies, Authentication and Advanced Requests</li>
<li>Spiders &#8211; how to write recursive web user agents, spiders</li>
</ul>
<p>This book is aimed at someone who already knows Perl and HTML.</p>
<p>This &#8220;1.1&#8221; edition of Perl and LWP is available online under the terms of the Creative Commons Attribution Share-Alike License.</td>
</tr>
<tr>
<td style="width: 200px;"><img data-attachment-id="1190" data-permalink="https://www.ossblog.org/embeddingperlmason/" data-orig-file="https://i2.wp.com/www.ossblog.org/wp-content/uploads/2017/02/EmbeddingPerlMason.jpg?fit=200%2C262&amp;ssl=1" data-orig-size="200,262" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="EmbeddingPerlMason" data-image-description="" data-medium-file="https://i2.wp.com/www.ossblog.org/wp-content/uploads/2017/02/EmbeddingPerlMason.jpg?fit=200%2C262&amp;ssl=1" data-large-file="https://i2.wp.com/www.ossblog.org/wp-content/uploads/2017/02/EmbeddingPerlMason.jpg?fit=200%2C262&amp;ssl=1" class="alignnone wp-image-1190 size-full" src="https://i2.wp.com/www.ossblog.org/wp-content/uploads/2017/02/EmbeddingPerlMason.jpg?resize=200%2C262&#038;ssl=1" alt="Embedding Perl in HTML with Mason" data-recalc-dims="1" /></td>
<td style="width: 545px;">
<h3><span style="color: #000080;"><a href="http://masonbook.houseabsolute.com/">Embedding Perl in HTML with Mason</a></span></h3>
<p>By Dave Rolsky, Ken Williams (320 pages)</p>
<p>The Embedding Perl in HTML with Mason book documents the HTML::Mason framework in detail, including chapters on component syntax, Mason object APIs, a sample site walkthrough, recipes, and details on Mason&#8217;s advanced features and how to use them.</p>
<p>The book shows individuals how to create large, complex, dynamically driven web sites that look good and are a snap to maintain. You&#8217;ll learn how to visualize multiple Mason-based solutions to any given problem and select among them. The book covers the latest line of Mason development 1.1x, which has many new features, including line number reporting based on source files, sub-requests, and easier use as a CGI.</p>
<p>This book is published under the Open Publication License.</td>
</tr>
</tbody>
</table>
<hr />
<h3><a href="https://www.ossblog.org/?p=1162&amp;page=2">Proceed to Next Page</a></h3>
<div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon sd-sharing"><h3 class="sd-title">Share this article:</h3><div class="sd-content"><ul><li class="share-twitter"><a href="https://www.ossblog.org/grasp-perl-open-source-books/?share=twitter" onclick="__gaTracker('send', 'event', 'outbound-article', 'https://www.ossblog.org/grasp-perl-open-source-books/?share=twitter', 'Click to share on Twitter (Opens in new window)');" rel="nofollow" data-shared="sharing-twitter-1162" class="share-twitter sd-button share-icon no-text"  target="_blank" title="Click to share on Twitter"><span></span><span class="sharing-screen-reader-text">Click to share on Twitter (Opens in new window)</span></a></li><li class="share-facebook"><a href="https://www.ossblog.org/grasp-perl-open-source-books/?share=facebook" onclick="__gaTracker('send', 'event', 'outbound-article', 'https://www.ossblog.org/grasp-perl-open-source-books/?share=facebook', 'Click to share on Facebook (Opens in new window)');" rel="nofollow" data-shared="sharing-facebook-1162" class="share-facebook sd-button share-icon no-text"  target="_blank" title="Click to share on Facebook"><span></span><span class="sharing-screen-reader-text">Click to share on Facebook (Opens in new window)</span></a></li><li class="share-google-plus-1"><a href="https://www.ossblog.org/grasp-perl-open-source-books/?share=google-plus-1" onclick="__gaTracker('send', 'event', 'outbound-article', 'https://www.ossblog.org/grasp-perl-open-source-books/?share=google-plus-1', 'Click to share on Google+ (Opens in new window)');" rel="nofollow" data-shared="sharing-google-1162" class="share-google-plus-1 sd-button share-icon no-text"  target="_blank" title="Click to share on Google+"><span></span><span class="sharing-screen-reader-text">Click to share on Google+ (Opens in new window)</span></a></li><li class="share-reddit"><a href="https://www.ossblog.org/grasp-perl-open-source-books/?share=reddit" onclick="__gaTracker('send', 'event', 'outbound-article', 'https://www.ossblog.org/grasp-perl-open-source-books/?share=reddit', 'Click to share on Reddit (Opens in new window)');" rel="nofollow" data-shared="" class="share-reddit sd-button share-icon no-text"  target="_blank" title="Click to share on Reddit"><span></span><span class="sharing-screen-reader-text">Click to share on Reddit (Opens in new window)</span></a></li><li class="share-pocket"><a href="https://www.ossblog.org/grasp-perl-open-source-books/?share=pocket" onclick="__gaTracker('send', 'event', 'outbound-article', 'https://www.ossblog.org/grasp-perl-open-source-books/?share=pocket', 'Click to share on Pocket (Opens in new window)');" rel="nofollow" data-shared="" class="share-pocket sd-button share-icon no-text"  target="_blank" title="Click to share on Pocket"><span></span><span class="sharing-screen-reader-text">Click to share on Pocket (Opens in new window)</span></a></li><li class="share-pinterest"><a href="https://www.ossblog.org/grasp-perl-open-source-books/?share=pinterest" onclick="__gaTracker('send', 'event', 'outbound-article', 'https://www.ossblog.org/grasp-perl-open-source-books/?share=pinterest', 'Click to share on Pinterest (Opens in new window)');" rel="nofollow" data-shared="sharing-pinterest-1162" class="share-pinterest sd-button share-icon no-text"  target="_blank" title="Click to share on Pinterest"><span></span><span class="sharing-screen-reader-text">Click to share on Pinterest (Opens in new window)</span></a></li><li class="share-tumblr"><a href="https://www.ossblog.org/grasp-perl-open-source-books/?share=tumblr" onclick="__gaTracker('send', 'event', 'outbound-article', 'https://www.ossblog.org/grasp-perl-open-source-books/?share=tumblr', 'Click to share on Tumblr (Opens in new window)');" rel="nofollow" data-shared="" class="share-tumblr sd-button share-icon no-text"  target="_blank" title="Click to share on Tumblr"><span></span><span class="sharing-screen-reader-text">Click to share on Tumblr (Opens in new window)</span></a></li><li class="share-linkedin"><a href="https://www.ossblog.org/grasp-perl-open-source-books/?share=linkedin" onclick="__gaTracker('send', 'event', 'outbound-article', 'https://www.ossblog.org/grasp-perl-open-source-books/?share=linkedin', 'Click to share on LinkedIn (Opens in new window)');" rel="nofollow" data-shared="sharing-linkedin-1162" class="share-linkedin sd-button share-icon no-text"  target="_blank" title="Click to share on LinkedIn"><span></span><span class="sharing-screen-reader-text">Click to share on LinkedIn (Opens in new window)</span></a></li><li class="share-email"><a href="https://www.ossblog.org/grasp-perl-open-source-books/?share=email" onclick="__gaTracker('send', 'event', 'outbound-article', 'https://www.ossblog.org/grasp-perl-open-source-books/?share=email', 'Click to email this to a friend (Opens in new window)');" rel="nofollow" data-shared="" class="share-email sd-button share-icon no-text"  target="_blank" title="Click to email this to a friend"><span></span><span class="sharing-screen-reader-text">Click to email this to a friend (Opens in new window)</span></a></li><li class="share-jetpack-whatsapp"><a rel="nofollow" data-shared="" class="share-jetpack-whatsapp sd-button share-icon no-text" href="whatsapp://send?text=Grasp%20Perl%20with%20Open-Source%20Books https%3A%2F%2Fwww.ossblog.org%2Fgrasp-perl-open-source-books%2F" target="_blank" title="Click to share on WhatsApp"><span></span><span class="sharing-screen-reader-text">Click to share on WhatsApp (Opens in new window)</span></a></li><li class="share-end"></li></ul></div></div></div>
<div style="font-size:0px;height:0px;line-height:0px;margin:0;padding:0;clear:both"></div><div class='sharedaddy sd-block sd-like jetpack-likes-widget-wrapper jetpack-likes-widget-unloaded' id='like-post-wrapper-122191455-1162-58b016ac5951b' data-src='//widgets.wp.com/likes/#blog_id=122191455&amp;post_id=1162&amp;origin=www.ossblog.org&amp;obj_id=122191455-1162-58b016ac5951b' data-name='like-post-frame-122191455-1162-58b016ac5951b'><h3 class="sd-title">Like this:</h3><div class='likes-widget-placeholder post-likes-widget-placeholder' style='height: 55px;'><span class='button'><span>Like</span></span> <span class="loading">Loading...</span></div><span class='sd-text-color'></span><a class='sd-link-color'></a></div>
<div id='jp-relatedposts' class='jp-relatedposts' >
	<h3 class="jp-relatedposts-headline"><em>Related</em></h3>
</div>					</div>                        
					<p>Pages: 1 <a href="https://www.ossblog.org/grasp-perl-open-source-books/2/">2</a></p>                                                        
						<p class="post-tags text-left">
		<span class="fa fa-tags"></span>
		<span>
			Tags: <a href="https://www.ossblog.org/tag/books/" rel="tag">books</a>, <a href="https://www.ossblog.org/tag/perl/" rel="tag">Perl</a>, <a href="https://www.ossblog.org/tag/programming/" rel="tag">programming</a>		</span>
	</p>
					                            
						<div class="post-navigation row">
							<div class="post-previous col-md-6"><a href="https://www.ossblog.org/twtwtw-edition-1/" rel="prev"><span class="meta-nav">Previous:</span> That Was The Week That Was (TWTWTW): Edition 1</a></div>
							<div class="post-next col-md-6"></div>
						</div>                      
					                            
											<!-- Start Related Posts -->
<div class="related-posts row"><div class="related-posts-content col-md-12"><div class="related-posts-title"><h3>Related posts</h3></div><ul class="row"> 
			<li class="rpost col-sm-6 hover-style">
				                               
					<div class="featured-thumbnail"><img width="394" height="221" src="https://i0.wp.com/www.ossblog.org/wp-content/uploads/2017/02/C-Montage-2.jpg?resize=394%2C221&amp;ssl=1" class="attachment-first-mag-home size-first-mag-home wp-post-image" alt="C++ Books" data-attachment-id="1071" data-permalink="https://www.ossblog.org/c-montage-3/" data-orig-file="https://i0.wp.com/www.ossblog.org/wp-content/uploads/2017/02/C-Montage-2.jpg?fit=549%2C245&amp;ssl=1" data-orig-size="549,245" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="C++-Montage" data-image-description="" data-medium-file="https://i0.wp.com/www.ossblog.org/wp-content/uploads/2017/02/C-Montage-2.jpg?fit=300%2C134&amp;ssl=1" data-large-file="https://i0.wp.com/www.ossblog.org/wp-content/uploads/2017/02/C-Montage-2.jpg?fit=549%2C245&amp;ssl=1" /></div>                                                           
								<div class="home-header"> 
					<header>
						<h2 class="page-header">                                
			                <a href="https://www.ossblog.org/master-c-programming-with-open-source-books/" title="Master C++ Programming with Open-Source Books" rel="bookmark">
								Master C++ Programming with Open-Source Books			                </a>                            
						</h2> 
					</header>
					<div class="entry-summary hidden-xs">
						Books are very personal and subjective possessions. And programming books are no exception. But regardless of their style, focus, or pace, good C++ programming books... 
					</div><!-- .entry-summary -->                                                                                                                                                                                                                                          
				</div> 
			</li>
			 
			<li class="rpost col-sm-6 hover-style">
				                               
					<div class="featured-thumbnail"><img width="394" height="221" src="https://i0.wp.com/www.ossblog.org/wp-content/uploads/2017/02/C-Montage.jpg?resize=394%2C221&amp;ssl=1" class="attachment-first-mag-home size-first-mag-home wp-post-image" alt="" data-attachment-id="963" data-permalink="https://www.ossblog.org/c-montage/" data-orig-file="https://i0.wp.com/www.ossblog.org/wp-content/uploads/2017/02/C-Montage.jpg?fit=546%2C255&amp;ssl=1" data-orig-size="546,255" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="C-Montage" data-image-description="" data-medium-file="https://i0.wp.com/www.ossblog.org/wp-content/uploads/2017/02/C-Montage.jpg?fit=300%2C140&amp;ssl=1" data-large-file="https://i0.wp.com/www.ossblog.org/wp-content/uploads/2017/02/C-Montage.jpg?fit=546%2C255&amp;ssl=1" /></div>                                                           
								<div class="home-header"> 
					<header>
						<h2 class="page-header">                                
			                <a href="https://www.ossblog.org/learn-c-programming-with-9-excellent-open-source-books/" title="Learn C Programming With 9 Excellent Open Source Books" rel="bookmark">
								Learn C Programming With 9 Excellent Open Source Books			                </a>                            
						</h2> 
					</header>
					<div class="entry-summary hidden-xs">
						Books are very personal things. And programming books are no exception. We all form bonds with programming books that help master the rudiments of a... 
					</div><!-- .entry-summary -->                                                                                                                                                                                                                                          
				</div> 
			</li>
			</ul></div></div><!-- End Related Posts -->
										                               
						<div class="postauthor-container">
	<div class="postauthor-title">
		<h4>About The Author</h4>
	</div>
	<div class="postauthor-content">	
		<img alt='' src='https://secure.gravatar.com/avatar/0152d6eaa5447cfd8b2d57bab9ffff5f?s=100&#038;d=retro&#038;r=g' srcset='https://secure.gravatar.com/avatar/0152d6eaa5447cfd8b2d57bab9ffff5f?s=200&amp;d=retro&amp;r=g 2x' class='avatar avatar-100 photo' height='100' width='100' />		<h5 class="vcard"><span class="fn"><a href="https://www.ossblog.org/author/steve/" title="Posts by Steve Emms" rel="author">Steve Emms</a></span></h5>
		<p></p>
	</div>	
</div> 
					                              
						<div class="clear"></div>
	<div class="rsrc-comments">
		<a name="comments"></a>
						<div class="well">
		<div id="respond" class="comment-respond">
			<h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/grasp-perl-open-source-books/#respond" style="display:none;">Cancel reply</a></small></h3>
			<form id="commentform" class="comment-form">
				<iframe src="https://jetpack.wordpress.com/jetpack-comment/?blogid=122191455&#038;postid=1162&#038;comment_registration=0&#038;require_name_email=1&#038;stc_enabled=1&#038;stb_enabled=1&#038;show_avatars=1&#038;avatar_default=retro&#038;greeting=Leave+a+Reply&#038;greeting_reply=Leave+a+Reply+to+%25s&#038;color_scheme=light&#038;lang=en_US&#038;jetpack_version=4.6&#038;sig=2c7a61fa9742b7d34dd8bd5b15cd8aa56c791948#parent=https%3A%2F%2Fwww.ossblog.org%2Fgrasp-perl-open-source-books%2F" allowtransparency="false" style="width:100%; height: 430px;border:0;" frameBorder="0" scrolling="no" name="jetpack_remote_comment" id="jetpack_remote_comment"></iframe>
			</form>
		</div>

		
		<input type="hidden" name="comment_parent" id="comment_parent" value="" />

		</div>
					</div>
                         
				</div>        
			        
		    
	</article>      
	    
		<aside id="sidebar" class="col-md-3 rsrc-right" role="complementary">
		
<!-- Quick Adsense Reloaded -->
<div id="adswidget1-quick-adsense-reloaded-4" class="widget quads-ad1_widget"><div id="quads-ad1_widget"><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- Response -->
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-6097899789476875"
     data-ad-slot="1669640918"
     data-ad-format="auto"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></div></div>		<div id="recent-posts-4" class="widget widget_recent_entries">		<h3 class="widget-title"><div class="title-text">Recent Posts</div><div class="widget-line"></div></h3>		<ul>
					<li>
				<a href="https://www.ossblog.org/grasp-perl-open-source-books/">Grasp Perl with Open-Source Books</a>
						</li>
					<li>
				<a href="https://www.ossblog.org/twtwtw-edition-1/">That Was The Week That Was (TWTWTW): Edition 1</a>
						</li>
					<li>
				<a href="https://www.ossblog.org/master-c-programming-with-open-source-books/">Master C++ Programming with Open-Source Books</a>
						</li>
					<li>
				<a href="https://www.ossblog.org/markdown-editors/">Write Markdown with 8 Exceptional Open Source Editors</a>
						</li>
					<li>
				<a href="https://www.ossblog.org/learn-c-programming-with-9-excellent-open-source-books/">Learn C Programming With 9 Excellent Open Source Books</a>
						</li>
				</ul>
		</div>		<div id="categories-4" class="widget widget_categories"><h3 class="widget-title"><div class="title-text">Categories</div><div class="widget-line"></div></h3>		<ul>
	<li class="cat-item cat-item-52"><a href="https://www.ossblog.org/category/books/" >Books</a>
</li>
	<li class="cat-item cat-item-22"><a href="https://www.ossblog.org/category/distributions/" >Distributions</a>
</li>
	<li class="cat-item cat-item-6"><a href="https://www.ossblog.org/category/games/" >Games</a>
</li>
	<li class="cat-item cat-item-27"><a href="https://www.ossblog.org/category/internet/" >Internet</a>
</li>
	<li class="cat-item cat-item-26"><a href="https://www.ossblog.org/category/multimedia/" >Multimedia</a>
</li>
	<li class="cat-item cat-item-2"><a href="https://www.ossblog.org/category/programming/" >Programming</a>
</li>
	<li class="cat-item cat-item-62"><a href="https://www.ossblog.org/category/twtw/" >TWTW</a>
</li>
	<li class="cat-item cat-item-15"><a href="https://www.ossblog.org/category/utilities/" >Utilities</a>
</li>
		</ul>
</div><div id="meta-4" class="widget widget_meta"><h3 class="widget-title"><div class="title-text">Meta</div><div class="widget-line"></div></h3>			<ul>
						<li><a rel="nofollow" href="https://www.ossblog.org/wp-login.php">Log in</a></li>
			<li><a href="https://www.ossblog.org/feed/">Entries <abbr title="Really Simple Syndication">RSS</abbr></a></li>
			<li><a href="https://www.ossblog.org/comments/feed/">Comments <abbr title="Really Simple Syndication">RSS</abbr></a></li>
			<li><a href="https://wordpress.org/" title="Powered by WordPress, state-of-the-art semantic personal publishing platform.">WordPress.org</a></li>			</ul>
			</div>	</aside>
</div>
<!-- end content container --><!-- end content container -->

<footer id="colophon" class="rsrc-footer" role="contentinfo">
  <div class="row rsrc-author-credits">
    <p class="text-center">
			Proudly powered by <a href="https://wordpress.org/">WordPress</a>			<span class="sep"> | </span>
			Theme: <a href="http://themes4wp.com/theme/responsive-magazine">Responsive Magazine</a> by Themes4WP		</p>
  </div>
</footer> 
<p id="back-top">
  <a href="#top"><span></span></a>
</p>
<!-- end main container -->
</div>
	<div style="display:none">
	<div class="grofile-hash-map-0152d6eaa5447cfd8b2d57bab9ffff5f">
	</div>
	</div>

	<script type="text/javascript">
		window.WPCOM_sharing_counts = {"https:\/\/www.ossblog.org\/grasp-perl-open-source-books\/":1162};
	</script>
			<div id="sharing_email" style="display: none;">
		<form action="/grasp-perl-open-source-books/" method="post">
			<label for="target_email">Send to Email Address</label>
			<input type="email" name="target_email" id="target_email" value="" />

			
				<label for="source_name">Your Name</label>
				<input type="text" name="source_name" id="source_name" value="" />

				<label for="source_email">Your Email Address</label>
				<input type="email" name="source_email" id="source_email" value="" />

						<input type="text" id="jetpack-source_f_name" name="source_f_name" class="input" value="" size="25" autocomplete="off" />
			<script>jQuery( document ).ready( function(){ document.getElementById('jetpack-source_f_name').value = '' });</script>
			
			<img style="float: right; display: none" class="loading" src="https://www.ossblog.org/wp-content/plugins/jetpack/modules/sharedaddy/images/loading.gif" alt="loading" width="16" height="16" />
			<input type="submit" value="Send Email" class="sharing_send" />
			<a rel="nofollow" href="#cancel" class="sharing_cancel">Cancel</a>

			<div class="errors errors-1" style="display: none;">
				Post was not sent - check your email addresses!			</div>

			<div class="errors errors-2" style="display: none;">
				Email check failed, please try again			</div>

			<div class="errors errors-3" style="display: none;">
				Sorry, your blog cannot share posts by email.			</div>
		</form>
	</div>
<script type='text/javascript' src='https://www.ossblog.org/wp-content/plugins/akismet/_inc/form.js?ver=3.2'></script>
<script type='text/javascript' src='https://www.ossblog.org/wp-content/plugins/jetpack/modules/photon/photon.js?ver=20130122'></script>
<script type='text/javascript' src='https://s0.wp.com/wp-content/js/devicepx-jetpack.js?ver=201708'></script>
<script type='text/javascript' src='https://secure.gravatar.com/js/gprofiles.js?ver=2017Febaa'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var WPGroHo = {"my_hash":""};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.ossblog.org/wp-content/plugins/jetpack/modules/wpgroho.js?ver=4.7.2'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var jetpackCarouselStrings = {"widths":[370,700,1000,1200,1400,2000],"is_logged_in":"","lang":"en","ajaxurl":"https:\/\/www.ossblog.org\/wp-admin\/admin-ajax.php","nonce":"0d151c184a","display_exif":"1","display_geo":"1","single_image_gallery":"1","single_image_gallery_media_file":"","background_color":"black","comment":"Comment","post_comment":"Post Comment","write_comment":"Write a Comment...","loading_comments":"Loading Comments...","download_original":"View full size <span class=\"photo-size\">{0}<span class=\"photo-size-times\">\u00d7<\/span>{1}<\/span>","no_comment_text":"Please be sure to submit some text with your comment.","no_comment_email":"Please provide an email address to comment.","no_comment_author":"Please provide your name to comment.","comment_post_error":"Sorry, but there was an error posting your comment. Please try again later.","comment_approved":"Your comment was approved.","comment_unapproved":"Your comment is in moderation.","camera":"Camera","aperture":"Aperture","shutter_speed":"Shutter Speed","focal_length":"Focal Length","comment_registration":"0","require_name_email":"1","login_url":"https:\/\/www.ossblog.org\/wp-login.php?redirect_to=https%3A%2F%2Fwww.ossblog.org%2Fgrasp-perl-open-source-books%2F","blog_id":"1","local_comments_commenting_as":"<fieldset><label for=\"email\">Email (Required)<\/label> <input type=\"text\" name=\"email\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-email-field\" \/><\/fieldset><fieldset><label for=\"author\">Name (Required)<\/label> <input type=\"text\" name=\"author\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-author-field\" \/><\/fieldset><fieldset><label for=\"url\">Website<\/label> <input type=\"text\" name=\"url\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-url-field\" \/><\/fieldset>"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.ossblog.org/wp-content/plugins/jetpack/modules/carousel/jetpack-carousel.js?ver=20160325'></script>
<script type='text/javascript' src='https://www.ossblog.org/wp-includes/js/wp-embed.min.js?ver=4.7.2'></script>
<script type='text/javascript' src='https://www.ossblog.org/wp-content/plugins/jetpack/_inc/postmessage.js?ver=4.6'></script>
<script type='text/javascript' src='https://www.ossblog.org/wp-content/plugins/jetpack/_inc/jquery.jetpack-resize.js?ver=4.6'></script>
<script type='text/javascript' src='https://www.ossblog.org/wp-content/plugins/jetpack/_inc/jquery.inview.js?ver=4.6'></script>
<script type='text/javascript' src='https://www.ossblog.org/wp-content/plugins/jetpack/modules/likes/queuehandler.js?ver=4.6'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var sharing_js_options = {"lang":"en","counts":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.ossblog.org/wp-content/plugins/jetpack/modules/sharedaddy/sharing.js?ver=4.6'></script>
<script type='text/javascript'>
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-twitter', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomtwitter', 'menubar=1,resizable=1,width=600,height=350' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-facebook', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomfacebook', 'menubar=1,resizable=1,width=600,height=400' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-google-plus-1', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomgoogle-plus-1', 'menubar=1,resizable=1,width=480,height=550' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-pocket', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcompocket', 'menubar=1,resizable=1,width=450,height=450' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-tumblr', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomtumblr', 'menubar=1,resizable=1,width=450,height=450' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-linkedin', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomlinkedin', 'menubar=1,resizable=1,width=580,height=450' );
				return false;
			});
</script>
		<iframe src='https://widgets.wp.com/likes/master.html?ver=20160429#ver=20160429' scrolling='no' id='likes-master' name='likes-master' style='display:none;'></iframe>
		<div id='likes-other-gravatars'><div class="likes-text"><span>%d</span> bloggers like this:</div><ul class="wpl-avatars sd-like-gravatars"></ul></div>
		
		<!--[if IE]>
		<script type="text/javascript">
		if ( 0 === window.location.hash.indexOf( '#comment-' ) ) {
			// window.location.reload() doesn't respect the Hash in IE
			window.location.hash = window.location.hash;
		}
		</script>
		<![endif]-->
		<script type="text/javascript">
			var comm_par_el = document.getElementById( 'comment_parent' ),
			    comm_par = (comm_par_el && comm_par_el.value) ? comm_par_el.value : '',
			    frame = document.getElementById( 'jetpack_remote_comment' ),
			    tellFrameNewParent;

			tellFrameNewParent = function() {
				if ( comm_par ) {
					frame.src = "https://jetpack.wordpress.com/jetpack-comment/?blogid=122191455&postid=1162&comment_registration=0&require_name_email=1&stc_enabled=1&stb_enabled=1&show_avatars=1&avatar_default=retro&greeting=Leave+a+Reply&greeting_reply=Leave+a+Reply+to+%25s&color_scheme=light&lang=en_US&jetpack_version=4.6&sig=2c7a61fa9742b7d34dd8bd5b15cd8aa56c791948#parent=https%3A%2F%2Fwww.ossblog.org%2Fgrasp-perl-open-source-books%2F" + '&replytocom=' + parseInt( comm_par, 10 ).toString();
				} else {
					frame.src = "https://jetpack.wordpress.com/jetpack-comment/?blogid=122191455&postid=1162&comment_registration=0&require_name_email=1&stc_enabled=1&stb_enabled=1&show_avatars=1&avatar_default=retro&greeting=Leave+a+Reply&greeting_reply=Leave+a+Reply+to+%25s&color_scheme=light&lang=en_US&jetpack_version=4.6&sig=2c7a61fa9742b7d34dd8bd5b15cd8aa56c791948#parent=https%3A%2F%2Fwww.ossblog.org%2Fgrasp-perl-open-source-books%2F";
				}
			};

	
			if ( 'undefined' !== typeof addComment ) {
				addComment._Jetpack_moveForm = addComment.moveForm;

				addComment.moveForm = function( commId, parentId, respondId, postId ) {
					var returnValue = addComment._Jetpack_moveForm( commId, parentId, respondId, postId ), cancelClick, cancel;

					if ( false === returnValue ) {
						cancel = document.getElementById( 'cancel-comment-reply-link' );
						cancelClick = cancel.onclick;
						cancel.onclick = function() {
							var cancelReturn = cancelClick.call( this );
							if ( false !== cancelReturn ) {
								return cancelReturn;
							}

							if ( !comm_par ) {
								return cancelReturn;
							}

							comm_par = 0;

							tellFrameNewParent();

							return cancelReturn;
						};
					}

					if ( comm_par == parentId ) {
						return returnValue;
					}

					comm_par = parentId;

					tellFrameNewParent();

					return returnValue;
				};
			}

	
			if ( window.postMessage ) {
				if ( document.addEventListener ) {
					window.addEventListener( 'message', function( event ) {
						if ( "https:\/\/jetpack.wordpress.com" !== event.origin ) {
							return;
						}

						jQuery( frame ).height( event.data );
					} );
				} else if ( document.attachEvent ) {
					window.attachEvent( 'message', function( event ) {
						if ( "https:\/\/jetpack.wordpress.com" !== event.origin ) {
							return;
						}

						jQuery( frame ).height( event.data );
					} );
				}
			}
		</script>

	<script type='text/javascript' src='https://stats.wp.com/e-201708.js' async defer></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:4.6',blog:'122191455',post:'1162',tz:'0',srv:'www.ossblog.org'} ]);
	_stq.push([ 'clickTrackerInit', '122191455', '1162' ]);
</script>
</body>
</html>