<!DOCTYPE html>
<html lang="en-US" prefix="og: http://ogp.me/ns#">
	<head>
		<meta http-equiv="content-type" content="text/html; charset=UTF-8" />
		<meta http-equiv="X-UA-Compatible" content="IE=edge">
		<meta name="viewport" content="width=device-width, initial-scale=1">
					<link rel="pingback" href="https://www.ossblog.org/xmlrpc.php">
				<title>Grasp R Programming with Open-Source Books - OSS Blog</title>

<!-- This site is optimized with the Yoast SEO plugin v4.5 - https://yoast.com/wordpress/plugins/seo/ -->
<link rel="canonical" href="https://www.ossblog.org/grasp-r-programming-open-source-books/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Grasp R Programming with Open-Source Books - OSS Blog" />
<meta property="og:description" content="Open Source R Books The R language (and open-source software) is the de facto standard among statisticians for the development&hellip;" />
<meta property="og:url" content="https://www.ossblog.org/grasp-r-programming-open-source-books/" />
<meta property="og:site_name" content="OSS Blog" />
<meta property="article:tag" content="books" />
<meta property="article:tag" content="free" />
<meta property="article:tag" content="open source" />
<meta property="article:tag" content="programming" />
<meta property="article:tag" content="R" />
<meta property="article:section" content="Books" />
<meta property="article:published_time" content="2017-03-28T13:26:54+00:00" />
<meta property="og:image" content="https://www.ossblog.org/wp-content/uploads/2017/03/RBooks-Montage.png" />
<meta property="og:image:width" content="551" />
<meta property="og:image:height" content="262" />
<meta name="twitter:card" content="summary" />
<meta name="twitter:description" content="Open Source R Books The R language (and open-source software) is the de facto standard among statisticians for the development&hellip;" />
<meta name="twitter:title" content="Grasp R Programming with Open-Source Books - OSS Blog" />
<meta name="twitter:image" content="https://i0.wp.com/www.ossblog.org/wp-content/uploads/2017/03/RBooks-Montage.png?fit=551%2C262&#038;ssl=1" />
<!-- / Yoast SEO plugin. -->

<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//secure.gravatar.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="OSS Blog &raquo; Feed" href="https://www.ossblog.org/feed/" />
<link rel="alternate" type="application/rss+xml" title="OSS Blog &raquo; Comments Feed" href="https://www.ossblog.org/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="OSS Blog &raquo; Grasp R Programming with Open-Source Books Comments Feed" href="https://www.ossblog.org/grasp-r-programming-open-source-books/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.2.1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.2.1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.ossblog.org\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.7.3"}};
			!function(a,b,c){function d(a){var b,c,d,e,f=String.fromCharCode;if(!k||!k.fillText)return!1;switch(k.clearRect(0,0,j.width,j.height),k.textBaseline="top",k.font="600 32px Arial",a){case"flag":return k.fillText(f(55356,56826,55356,56819),0,0),!(j.toDataURL().length<3e3)&&(k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57331,65039,8205,55356,57096),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57331,55356,57096),0,0),c=j.toDataURL(),b!==c);case"emoji4":return k.fillText(f(55357,56425,55356,57341,8205,55357,56507),0,0),d=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55357,56425,55356,57341,55357,56507),0,0),e=j.toDataURL(),d!==e}return!1}function e(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var f,g,h,i,j=b.createElement("canvas"),k=j.getContext&&j.getContext("2d");for(i=Array("flag","emoji4"),c.supports={everything:!0,everythingExceptFlag:!0},h=0;h<i.length;h++)c.supports[i[h]]=d(i[h]),c.supports.everything=c.supports.everything&&c.supports[i[h]],"flag"!==i[h]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[i[h]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(g=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",g,!1),a.addEventListener("load",g,!1)):(a.attachEvent("onload",g),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),f=c.source||{},f.concatemoji?e(f.concatemoji):f.wpemoji&&f.twemoji&&(e(f.twemoji),e(f.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='wp-pagenavi-css'  href='https://www.ossblog.org/wp-content/plugins/wp-pagenavi/pagenavi-css.css?ver=2.70' type='text/css' media='all' />
<link rel='stylesheet' id='quads-styles-css'  href='https://www.ossblog.org/wp-content/plugins/quick-adsense-reloaded/assets/css/quads.css?ver=1.5.0' type='text/css' media='all' />
<link rel='stylesheet' id='bootstrap-css-css'  href='https://www.ossblog.org/wp-content/themes/first-mag/css/bootstrap.css?ver=1' type='text/css' media='all' />
<link rel='stylesheet' id='first-mag-stylesheet-css'  href='https://www.ossblog.org/wp-content/themes/responsive-magazine/style.css?ver=1' type='text/css' media='all' />
<link rel='stylesheet' id='font-awesome-css'  href='https://www.ossblog.org/wp-content/themes/first-mag/css/font-awesome.min.css?ver=4.7.3' type='text/css' media='all' />
<link rel='stylesheet' id='flexslider-css'  href='https://www.ossblog.org/wp-content/themes/first-mag/css/flexslider.css?ver=4.7.3' type='text/css' media='all' />
<link rel='stylesheet' id='tablepress-default-css'  href='https://www.ossblog.org/wp-content/plugins/tablepress/css/default.min.css?ver=1.8' type='text/css' media='all' />
<link rel='stylesheet' id='responsive-magazine-style-css'  href='https://www.ossblog.org/wp-content/themes/first-mag/style.css?ver=4.7.3' type='text/css' media='all' />
<link rel='stylesheet' id='kirki-styles-first_mag_settings-css'  href='https://www.ossblog.org/wp-content/plugins/kirki/assets/css/kirki-styles.css' type='text/css' media='all' />
<style id='kirki-styles-first_mag_settings-inline-css' type='text/css'>
.rsrc-header-img{margin-top:0px;margin-bottom:0px;margin-left:0px;margin-right:0px;}.rsrc-header-text a{color:#222 !important;}.rsrc-header-text h4{color:#B6B6B6;}body{background-color:rgba(244,244,244,1);background-repeat:no-repeat;background-attachment:fixed;background-position:center center;-webkit-background-size:cover;-moz-background-size:cover;-ms-background-size:cover;-o-background-size:cover;background-size:cover;}
</style>
<!--[if lte IE 8]>
<link rel='stylesheet' id='jetpack-carousel-ie8fix-css'  href='https://www.ossblog.org/wp-content/plugins/jetpack/modules/carousel/jetpack-carousel-ie8fix.css?ver=20121024' type='text/css' media='all' />
<![endif]-->
<link rel='stylesheet' id='social-logos-css'  href='https://www.ossblog.org/wp-content/plugins/jetpack/_inc/social-logos/social-logos.min.css?ver=1' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='https://www.ossblog.org/wp-content/plugins/jetpack/css/jetpack.css?ver=4.7.1' type='text/css' media='all' />
<!-- This site uses the Google Analytics by MonsterInsights plugin v6.1.3 - Using Analytics tracking - https://www.monsterinsights.com/ -->
<script type="text/javascript" data-cfasync="false">
	// Function to detect opted out users
	function __gaTrackerIsOptedOut() {
		return document.cookie.indexOf(disableStr + '=true') > -1;
	}

	// Disable tracking if the opt-out cookie exists.
	var disableStr = 'ga-disable-UA-1447713-3';
	if ( __gaTrackerIsOptedOut() ) {
		window[disableStr] = true;
	}

	// Opt-out function
	function __gaTrackerOptout() {
	  document.cookie = disableStr + '=true; expires=Thu, 31 Dec 2099 23:59:59 UTC; path=/';
	  window[disableStr] = true;
	}

	(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
		(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
		m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
	})(window,document,'script','//www.google-analytics.com/analytics.js','__gaTracker');

	__gaTracker('create', 'UA-1447713-3', 'auto');
	__gaTracker('set', 'forceSSL', true);
	__gaTracker('send','pageview');
</script>
<!-- / Google Analytics by MonsterInsights -->
<script type='text/javascript' src='https://www.ossblog.org/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='https://www.ossblog.org/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var related_posts_js_options = {"post_heading":"h4"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.ossblog.org/wp-content/plugins/jetpack/modules/related-posts/related-posts.js?ver=20150408'></script>
<script type='text/javascript' src='https://www.ossblog.org/wp-content/themes/first-mag/js/bootstrap.min.js?ver=4.7.3'></script>
<script type='text/javascript' src='https://www.ossblog.org/wp-content/themes/first-mag/js/customscript.js?ver=4.7.3'></script>
<script type='text/javascript' src='https://www.ossblog.org/wp-content/themes/first-mag/js/jquery.flexslider-min.js?ver=4.7.3'></script>
<script type='text/javascript' src='https://www.ossblog.org/wp-content/themes/responsive-magazine/js/customscript-responsive-magazine.js?ver=1'></script>
<script type='text/javascript' src='https://www.ossblog.org/wp-content/plugins/jetpack/_inc/spin.js?ver=1.3'></script>
<script type='text/javascript' src='https://www.ossblog.org/wp-content/plugins/jetpack/_inc/jquery.spin.js?ver=1.3'></script>
<link rel='https://api.w.org/' href='https://www.ossblog.org/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.ossblog.org/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.ossblog.org/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 4.7.3" />
<link rel='shortlink' href='https://wp.me/p8gHzV-wh' />
<link rel="alternate" type="application/json+oembed" href="https://www.ossblog.org/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.ossblog.org%2Fgrasp-r-programming-open-source-books%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.ossblog.org/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.ossblog.org%2Fgrasp-r-programming-open-source-books%2F&#038;format=xml" />

<link rel='dns-prefetch' href='//v0.wordpress.com'>
<link rel='dns-prefetch' href='//i0.wp.com'>
<link rel='dns-prefetch' href='//i1.wp.com'>
<link rel='dns-prefetch' href='//i2.wp.com'>
<link rel='dns-prefetch' href='//jetpack.wordpress.com'>
<link rel='dns-prefetch' href='//s0.wp.com'>
<link rel='dns-prefetch' href='//s1.wp.com'>
<link rel='dns-prefetch' href='//s2.wp.com'>
<link rel='dns-prefetch' href='//public-api.wordpress.com'>
<link rel='dns-prefetch' href='//0.gravatar.com'>
<link rel='dns-prefetch' href='//1.gravatar.com'>
<link rel='dns-prefetch' href='//2.gravatar.com'>
<link rel='dns-prefetch' href='//widgets.wp.com'>
<style type='text/css'>img#wpstats{display:none}</style><meta name="title" content="Grasp R Programming with Open-Source Books | OSS Blog" />
<meta name="description" content="Open Source R Books The R language (and open-source software) is the de facto standard among statisticians for the development of statistical software, and is widely used for statistical software development and data analysis. R is a modern implementation of S, one of several statistical programming languages designed at Bell Laboratories. R is much more&hellip;" />
			<style type="text/css" id="wp-custom-css">
				/*
You can add your own CSS here.

Click the help icon above to learn more.
*/

a { color: black; }

a:hover { color: blue; }

			</style>
			</head>
	<body id="blog" class="post-template-default single single-post postid-2001 single-format-standard">


<div class="container rsrc-container" role="main">
	 
    <header id="site-header" class="row rsrc-header" role="banner">  
					<div class="rsrc-header-img col-md-4">
				<a href="https://www.ossblog.org/"><img src="https://www.ossblog.org/wp-content/uploads/2017/01/OSSBlog-header.png" title="OSS Blog" /></a>
			</div>
				<div class="header-ad col-md-8">
							<div id="header-ad-section" class="clearfix">
					<div id="text-4" class="widget widget_text">			<div class="textwidget"><A HREF="https://www.ossblog.org/top-software/">Top Software</A> - <A HREF="https://www.ossblog.org/opensourcebooks/">Books</A> - <A HREF="https://www.ossblog.org/about/">About</A></div>
		</div>				</div>
					</div>
    </header> 




<!-- start content container -->
<!-- start content container -->
                                
	<div class="single-thumbnail row"><img width="551" height="262" src="https://i0.wp.com/www.ossblog.org/wp-content/uploads/2017/03/RBooks-Montage.png?resize=551%2C262&amp;ssl=1" class="attachment-first-mag-single size-first-mag-single wp-post-image" alt="Open-Source R Books" srcset="https://i0.wp.com/www.ossblog.org/wp-content/uploads/2017/03/RBooks-Montage.png?w=551&amp;ssl=1 551w, https://i0.wp.com/www.ossblog.org/wp-content/uploads/2017/03/RBooks-Montage.png?resize=300%2C143&amp;ssl=1 300w" sizes="(max-width: 551px) 100vw, 551px" data-attachment-id="2039" data-permalink="https://www.ossblog.org/rbooks-montage/" data-orig-file="https://i0.wp.com/www.ossblog.org/wp-content/uploads/2017/03/RBooks-Montage.png?fit=551%2C262&amp;ssl=1" data-orig-size="551,262" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="RBooks-Montage" data-image-description="" data-medium-file="https://i0.wp.com/www.ossblog.org/wp-content/uploads/2017/03/RBooks-Montage.png?fit=300%2C143&amp;ssl=1" data-large-file="https://i0.wp.com/www.ossblog.org/wp-content/uploads/2017/03/RBooks-Montage.png?fit=551%2C262&amp;ssl=1" /></div>                                     
	<div class="clear"></div>                            
 
<div class="row rsrc-content">    
	    
	    
	<article class="col-md-9 rsrc-main">        
		         
				<div id="breadcrumbs" ><div class="breadcrumbs-inner text-right"><span><a href="https://www.ossblog.org"><i class="fa fa-home"></i><span>Home</span></a></span> &raquo;  <span><a href="https://www.ossblog.org/category/books/"><span>Books</span></a></span> &raquo;  <span><a href="https://www.ossblog.org/category/programming/"><span>Programming</span></a></span> &raquo;  Grasp R Programming with Open-Source Books</div></div>                
				<div class="rsrc-post-content post-2001 post type-post status-publish format-standard has-post-thumbnail hentry category-books category-programming tag-books tag-free tag-open-source tag-programming tag-r">                            
					<header>                              
						<h1 class="entry-title page-header">
							Grasp R Programming with Open-Source Books						</h1>                              
						<p class="post-meta text-left"> 
	<span class="fa fa-clock-o"></span> <time class="posted-on published" datetime="2017-03-28">March 28, 2017</time>
	<span class="fa fa-user"></span> <span class="author-link"><a href="https://www.ossblog.org/author/steve/" title="Posts by Steve Emms" rel="author">Steve Emms</a></span>
	<span class="fa fa-comment"></span> <span class="comments-meta"><a href="https://www.ossblog.org/grasp-r-programming-open-source-books/#respond" class="comments-link" >0</a></span>
	<span class="fa fa-folder-open meta-cat-icon"></span>
	<span class="meta-cat"><a href="https://www.ossblog.org/category/books/" title="View all posts in Books">Books</a>, </span><span class="meta-cat"><a href="https://www.ossblog.org/category/programming/" title="View all posts in Programming">Programming</a>, </span>	</p>                            
					</header>                                                                                     
					<div class="entry-content" >
						<h2>Open Source R Books</h2>
<p>The R language (and open-source software) is the de facto standard among statisticians for the development of statistical software, and is widely used for statistical software development and data analysis. R is a modern implementation of S, one of several statistical programming languages designed at Bell Laboratories.</p>
<p>R is much more than a programming language. It&#8217;s an interactive environment for performing statistics. R offers a wide variety of statistical (linear and nonlinear modelling, classical statistical tests, time-series analysis, classification, clustering, &#8230;) and graphical techniques, and is highly extensible. The ability to download and install R packages is a key factor which makes R an excellent language to learn. Packages are the fundamental units of reproducible R code. They include reusable R functions, the documentation that describes how to use them, and sample data. The CRAN package repository hosts over 10,000 packages, and Bioconductor hosts nearly 1,300 packages.</p>
<p>R is available as Free Software under the terms of the Free Software Foundation’s GNU General Public License in source code form.</p>
<p>This article is part of <a href="https://www.ossblog.org/opensourcebooks/">OSSBlog’s series of open source programming books</a>.</p>
<table cellpadding="5">
<tbody>
<tr>
<td style="width: 200px;"><img data-attachment-id="2016" data-permalink="https://www.ossblog.org/introductionr/" data-orig-file="https://i0.wp.com/www.ossblog.org/wp-content/uploads/2017/03/IntroductionR.jpg?fit=200%2C298&amp;ssl=1" data-orig-size="200,298" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="IntroductionR" data-image-description="" data-medium-file="https://i0.wp.com/www.ossblog.org/wp-content/uploads/2017/03/IntroductionR.jpg?fit=200%2C298&amp;ssl=1" data-large-file="https://i0.wp.com/www.ossblog.org/wp-content/uploads/2017/03/IntroductionR.jpg?fit=200%2C298&amp;ssl=1" class="alignnone wp-image-2016 size-full" src="https://i0.wp.com/www.ossblog.org/wp-content/uploads/2017/03/IntroductionR.jpg?resize=200%2C298&#038;ssl=1" alt="An Introduction To R" data-recalc-dims="1" /></td>
<td>
<h3><span style="color: #000080;"><a href="https://cran.r-project.org/doc/manuals/R-intro.pdf">An Introduction To R: Notes on R: A Programming Environment for Data Analysis and Graphics</a></span></h3>
<p>By William N Venables, David M Smith, and the R Core Team (105 pages)</p>
<p>This tutorial manual provides a comprehensive introduction to R, a software package for statistical computing and graphics.</p>
<p>R supports a wide range of statistical techniques and is easily extensible via user-defined functions. One of R&#8217;s strengths is the ease with which publication-quality plots can be produced in a wide variety of formats.</p>
<p>Chapters explore:</p>
<ul>
<li>Simple manipulations; numbers and vectors</li>
<li>Objects, their modes and attributes</li>
<li>Ordered and unordered functions</li>
<li>Arrays and matrices</li>
<li>Lists and data frames</li>
<li>Reading data from files</li>
<li>Probability distributions</li>
<li>Grouping, loops and conditional execution</li>
<li>Writing your own functions</li>
<li>Statistical models in R</li>
<li>Graphical procedures</li>
<li>Packages</li>
</ul>
<p>The manual is released under an open source license.</p>
<p>An Introduction to R is one of the R Manuals. Visit the <a href="https://cran.r-project.org/">Comprehensive R Archive Network</a> to read the others.</td>
</tr>
<tr>
<td style="width: 200px;"><img data-attachment-id="2019" data-permalink="https://www.ossblog.org/rdatascience/" data-orig-file="https://i0.wp.com/www.ossblog.org/wp-content/uploads/2017/03/RDataScience.png?fit=200%2C300&amp;ssl=1" data-orig-size="200,300" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="RDataScience" data-image-description="" data-medium-file="https://i0.wp.com/www.ossblog.org/wp-content/uploads/2017/03/RDataScience.png?fit=200%2C300&amp;ssl=1" data-large-file="https://i0.wp.com/www.ossblog.org/wp-content/uploads/2017/03/RDataScience.png?fit=200%2C300&amp;ssl=1" class="alignnone wp-image-2019 size-full" src="https://i0.wp.com/www.ossblog.org/wp-content/uploads/2017/03/RDataScience.png?resize=200%2C300&#038;ssl=1" alt="R for Data Science" data-recalc-dims="1" /></td>
<td>
<h3><span style="color: #000080;"><a href="http://r4ds.had.co.nz/">R for Data Science: Import, Tidy, Transform, Visualize, and Model Data</a></span></h3>
<p>By Hadley Wickham and Garrett Grolemund (522 pages)</p>
<p>R for Data Science teaches you how to do data science with R. It introduces the reader to R, RStudio, and the tidyverse, a collection of R packages designed to work together to make data science fast, fluent, and fun. Suitable for readers with no previous programming experience, R for Data Science is designed to get you doing data science as quickly as possible.</p>
<p>Learn how to:</p>
<ul>
<li>Explore &#8211; examine your data, generate hypotheses, and quickly test them. Dive into visualisation, learning the basic structure of a ggplot2 plot, and powerful techniques for turning data into plots. Learn the key verbs that allow you to select important variables, filter out key observations, create new variables, and compute summaries. Combine visualisation and transformation with your curiosity and skepticism to ask and answer interesting questions about data</li>
<li>Wrangle &#8211; transform your datasets into a form convenient for visualisation and modelling</li>
<li>Program &#8211; learn powerful R tools for solving data problems with greater clarity and ease. Learn skills that allow you to both tackle new programs and to solve existing problems</li>
<li>Model &#8211; provide a low-dimensional summary that captures true &#8220;signals&#8221; in your dataset</li>
<li>Communicate &#8211; learn R Markdown for integrating prose, code, and results, learn how to take exploratory graphics and turn them into expository graphics. R Markdown formats and workflow are covered</li>
</ul>
<p>This book is licensed under the Creative Commons Attribution-NonCommercial-NoDerivs 3.0 United States License.</td>
</tr>
<tr>
<td style="width: 200px;"><img data-attachment-id="2022" data-permalink="https://www.ossblog.org/textminingr/" data-orig-file="https://i0.wp.com/www.ossblog.org/wp-content/uploads/2017/03/TextMiningR.png?fit=200%2C262&amp;ssl=1" data-orig-size="200,262" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="TextMiningR" data-image-description="" data-medium-file="https://i0.wp.com/www.ossblog.org/wp-content/uploads/2017/03/TextMiningR.png?fit=200%2C262&amp;ssl=1" data-large-file="https://i0.wp.com/www.ossblog.org/wp-content/uploads/2017/03/TextMiningR.png?fit=200%2C262&amp;ssl=1" class="alignnone wp-image-2022 size-full" src="https://i0.wp.com/www.ossblog.org/wp-content/uploads/2017/03/TextMiningR.png?resize=200%2C262&#038;ssl=1" alt="Text Mining with R" data-recalc-dims="1" /></td>
<td>
<h3><span style="color: #000080;"><a href="http://tidytextmining.com/">Text Mining with R</a></span></h3>
<p>By Julia Silge and David Robinson (HTML)</p>
<p>This book serves as an introduction to text mining using the tidytext package and other tidy tools in R. The authors of this book developed the tidytext package.</p>
<p>The functions provided by the tidytext package are relatively simple; what is important are the possible applications. This book provides compelling examples of real text mining problems. The chapters cover:</p>
<ul>
<li>Tidy text format and the unnest_tokens() function. It also introduces the gutenbergr and janeaustenr packages</li>
<li>Perform sentiment analysis on a tidy text dataset, using the sentiments dataset from tidytext and inner_join() from dplyr</li>
<li>Describes the tf-idf statistic (term frequency times inverse document frequency)</li>
<li>Introduces n-grams and how to analyze word networks in text using the widyr and ggraph packages</li>
<li>Methods for tidying document-term matrices and corpus objects from the tm and quanteda packages, as well as for casting tidy text datasets into those formats</li>
<li>Explores the concept of topic modeling, and uses the tidy() method to interpret and visualize the output of the topicmodels package</li>
<li>Case studies</li>
</ul>
<p>Text Mining with R is licensed under a Creative Commons Attribution-NonCommercial-ShareAlike 3.0 United States License.</td>
</tr>
<tr>
<td style="width: 200px;"><img data-attachment-id="2020" data-permalink="https://www.ossblog.org/rinferno/" data-orig-file="https://i2.wp.com/www.ossblog.org/wp-content/uploads/2017/03/RInferno.jpeg?fit=200%2C302&amp;ssl=1" data-orig-size="200,302" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="RInferno" data-image-description="" data-medium-file="https://i2.wp.com/www.ossblog.org/wp-content/uploads/2017/03/RInferno.jpeg?fit=199%2C300&amp;ssl=1" data-large-file="https://i2.wp.com/www.ossblog.org/wp-content/uploads/2017/03/RInferno.jpeg?fit=200%2C302&amp;ssl=1" class="alignnone wp-image-2020 size-full" src="https://i2.wp.com/www.ossblog.org/wp-content/uploads/2017/03/RInferno.jpeg?resize=200%2C302&#038;ssl=1" alt="The R Inferno" srcset="https://i2.wp.com/www.ossblog.org/wp-content/uploads/2017/03/RInferno.jpeg?w=200&amp;ssl=1 200w, https://i2.wp.com/www.ossblog.org/wp-content/uploads/2017/03/RInferno.jpeg?resize=199%2C300&amp;ssl=1 199w" sizes="(max-width: 200px) 100vw, 200px" data-recalc-dims="1" /></td>
<td>
<h3><span style="color: #000080;"><a href="http://www.burns-stat.com/documents/books/the-r-inferno/">The R Inferno</a></span></h3>
<p>By Patrick Burns (126 pages)</p>
<p>The R Inferno is an essential guide to the trouble spots and oddities of R. The book shares a lot of useful information and maintains the reader&#8217;s interest. The book provides many useful techniques and tips for reducing memory usage, improving performance, and avoiding errors in computational analysis.</p>
<p>R is regarded as an excellent computing environment for most data analysis tasks. R is free, released under an open-source license, and has thousands of contributed packages. It is used in such diverse fields as ecology, finance, genomics and music.</p>
<p>Chapters are headed:</p>
<ul>
<li>Falling into the Floating Trap</li>
<li>Growing Objects</li>
<li>Failing to Vectorize &#8211; includes coverage on subscripting (a key part of effective vectorization), vecorized if, and looks at when vectorization is not possible</li>
<li>Over-Vectorizing</li>
<li>Not Writing Functions &#8211; the power of language is abstraction. To make abstractions in R the programmer writes functions. This chapter also highlights the importance of making functions as simple as possible</li>
<li>Doing Global Assignment &#8211; which can be useful in memoization</li>
<li>Tripping on Object Orientation &#8211; S3 methods (including generic functions, the methods function, and inheritance) S4 methods (multiple dispatch, S4 structure), and Namespaces</li>
<li>Believing It Does as Intended &#8211; looks at ghosts, chimeras, and devils &#8211; exorcised using the browser function</li>
<li>Seeking Help</li>
</ul>
<p>The book is illuminated with famous Botticelli artwork: The Giants, The Sowers of Discord, and The Thieves.</p>
<p>Note: The book is not officially released under an open source license, but Patrick Burns seems fine about it being treated as open.</td>
</tr>
<tr>
<td style="width: 200px;"><img data-attachment-id="2015" data-permalink="https://www.ossblog.org/introductionprobabilitystatisticsr/" data-orig-file="https://i0.wp.com/www.ossblog.org/wp-content/uploads/2017/03/IntroductionProbabilityStatisticsR.png?fit=200%2C281&amp;ssl=1" data-orig-size="200,281" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="IntroductionProbabilityStatisticsR" data-image-description="" data-medium-file="https://i0.wp.com/www.ossblog.org/wp-content/uploads/2017/03/IntroductionProbabilityStatisticsR.png?fit=200%2C281&amp;ssl=1" data-large-file="https://i0.wp.com/www.ossblog.org/wp-content/uploads/2017/03/IntroductionProbabilityStatisticsR.png?fit=200%2C281&amp;ssl=1" class="alignnone wp-image-2015 size-full" src="https://i0.wp.com/www.ossblog.org/wp-content/uploads/2017/03/IntroductionProbabilityStatisticsR.png?resize=200%2C281&#038;ssl=1" alt="Introduction to Probability and Statistics Using R" data-recalc-dims="1" /></td>
<td>
<h3><span style="color: #000080;"><a href="http://ipsur.org/">Introduction to Probability and Statistics Using R</a></span></h3>
<p>By G. Jay Kerns (412 pages)</p>
<p>Introduction to Probability and Statistics Using R is a textbook for an undergraduate course in probability and statistics. The approximate prerequisites are two or three semesters of calculus and some linear algebra. Students attending the class include mathematics, engineering, and computer science majors.</p>
<p>Chapters cover:</p>
<ul>
<li>An Introduction to Probability and Statistics</li>
<li>An Introduction to R: Installation, Basic R Operations and Concepts, Assignment, Object names, and Data types, Vectors</li>
<li>Data Description: Introduces the different types of data that a statistician is likely to encounter</li>
<li>Probability: Defines the basic terminology associated with probability and derive some of its properties, discusses three interpretations of probability, conditional probability and independent events, along with Bayes’ Theorem. The chapter concludes with an introduction to random variables</li>
<li>Discrete Distributions: Introduces discrete random variables, discusses probability mass functions and some special expectations, namely, the mean, variance and standard deviation. Important discrete distributions are examined in detail, and attention is given to the concept of expectation and the empirical distribution</li>
<li>Continuous Distributions: Continuous random variables and the associated PDFs and CDFs. The continuous uniform distribution is highlighted, along with the Gaussian, or normal, distribution. Some mathematical details pave the way for a catalogue of models</li>
<li>Multivariate Distributions: Studies the notion of dependence between random variables in some detail</li>
<li>Sampling Distributions: The bridge from probability and descriptive statistics</li>
<li>Estimation: Discusses two branches of estimation procedures: point estimation and interval estimation</li>
<li>Hypothesis Testing: Tests for Proportions, One Sample Tests for Means and Variances, Two-Sample Tests for Means and Variances, Other Hypothesis Tests, Analysis of Variance, Sample Size and Power</li>
<li>Simple Linear Regression: Estimation, Model Utility and Inference, Residual Analysis, and Other Diagnostic Tools</li>
<li>Multiple Linear Regression: The Multiple Linear Regression Model, Estimation and Prediction, Model Utility and Inference, Polynomial Regression, Interaction, Qualitative Explanatory Variables, Partial F Statistic, Residual Analysis and Diagnostic Tools</li>
<li>Resampling Methods: Bootstrap Standard Errors, Bootstrap Confidence Intervals, Resampling in Hypothesis Tests</li>
<li>Categorical Data Analysis</li>
<li>Nonparametric Statistics</li>
<li>Time Series</li>
</ul>
<p>Introduction to Probability and Statistics Using R is licensed under the terms of the GNU Free Documentation License, Version 1.3 or any later version published by the Free Software Foundation.</td>
</tr>
<tr>
<td style="width: 200px;"><img data-attachment-id="2023" data-permalink="https://www.ossblog.org/undergraduateguider/" data-orig-file="https://i1.wp.com/www.ossblog.org/wp-content/uploads/2017/03/UndergraduateGuideR.png?fit=200%2C258&amp;ssl=1" data-orig-size="200,258" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="UndergraduateGuideR" data-image-description="" data-medium-file="https://i1.wp.com/www.ossblog.org/wp-content/uploads/2017/03/UndergraduateGuideR.png?fit=200%2C258&amp;ssl=1" data-large-file="https://i1.wp.com/www.ossblog.org/wp-content/uploads/2017/03/UndergraduateGuideR.png?fit=200%2C258&amp;ssl=1" class="alignnone wp-image-2023 size-full" src="https://i1.wp.com/www.ossblog.org/wp-content/uploads/2017/03/UndergraduateGuideR.png?resize=200%2C258&#038;ssl=1" alt="The Undergraduate Guide to R" data-recalc-dims="1" /></td>
<td>
<h3><span style="color: #000080;"><a href="https://sites.google.com/site/undergraduateguidetor/">The Undergraduate Guide to R</a></span></h3>
<p>By Trevor Martin (68 pages)</p>
<p>The Undergraduate Guide to R is a beginner&#8217;s introduction to the R programming language.</p>
<p>After reading this book, you&#8217;ll be able to perform most common data manipulating, analyzing, comparing and viewing tasks with R. The book also provides the necessary foundation blocks to enable the reader to progress to more advanced R techniques, and offers general tips and suggestions about how to code in R.</p>
<p>The Undergraduate Guide to R is written so that the reader needs no prior knowledge of programming (although basic knowledge of general computer skills and statistics is essential).</p>
<p>Sections cover:</p>
<ul>
<li>What is R?</li>
<li>How to Install R</li>
<li>The Basics: Algebra, Vectors, Matrices, Manipulation to arrange your data, and Loops/Statements (for-loop, if-statement, ifelse-statement)</li>
<li>Data Types: Types, Converting/Using</li>
<li>Reading in Data: Types of Data, How to Read In Data</li>
<li>Plotting Data: Dot Plots, Histograms, Box Plots, and Additions</li>
<li>Exporting Data: Types of Output, How to Export Data</li>
<li>Functions: Built In, Custom</li>
<li>Tips for Writing Good R Code: General, Matrix Multiplication, Plan, Debug, Help, Packages</li>
<li>R Editors: Besides the RGui built-in editor, this chapter gives links to other popular editors for R, including WinEDT, Tinn-R, and explains that other popular editors such as Eclipse and Emacs can be configured to use R syntax highlighting</li>
</ul>
<p>The book is freely available, licensed under Creative Commons Attribution-NonCommercial-NoDerivs 3.0 Unported (CC BY-NC-ND 3.0).</td>
</tr>
<tr>
<td style="width: 200px;"><img data-attachment-id="2021" data-permalink="https://www.ossblog.org/statisticalthinkingr/" data-orig-file="https://i0.wp.com/www.ossblog.org/wp-content/uploads/2017/03/StatisticalThinkingR.png?fit=200%2C291&amp;ssl=1" data-orig-size="200,291" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="StatisticalThinkingR" data-image-description="" data-medium-file="https://i0.wp.com/www.ossblog.org/wp-content/uploads/2017/03/StatisticalThinkingR.png?fit=200%2C291&amp;ssl=1" data-large-file="https://i0.wp.com/www.ossblog.org/wp-content/uploads/2017/03/StatisticalThinkingR.png?fit=200%2C291&amp;ssl=1" class="alignnone wp-image-2021 size-full" src="https://i0.wp.com/www.ossblog.org/wp-content/uploads/2017/03/StatisticalThinkingR.png?resize=200%2C291&#038;ssl=1" alt="Introduction to Statistical Thinking (With R, Without Calculus)" data-recalc-dims="1" /></td>
<td>
<h3><span style="color: #000080;"><a href="http://pluto.huji.ac.il/~msby/StatThink/index.html">Introduction to Statistical Thinking (With R, Without Calculus)</a></span></h3>
<p>By Benjamin Yakir (324 pages)</p>
<p>Introduction to Statistical Thinking is targeted at college students who need to learn statistics, students with little background in mathematics and often no motivation to learn more. This book uses the basic structure of generic introduction to statistics course.</p>
<p>Chapters cover:</p>
<ul>
<li>Short introduction to statistics and probability</li>
<li>Data structures and variation</li>
<li>Provides numerical and graphical tools for presenting and summarizing the distribution of data</li>
<li>Fundamentals of probability: Concept of a random variable, Examples of special types of random variables, Normal random variable, Sampling distribution and presents the Central Limit Theorem and the Law of Large Numbers</li>
<li>Discussion of statistical inference. It provides an overview of the topics that are presented in the subsequent chapter</li>
<li>Basic tools of statistical inference, namely point estimation, estimation with a confidence interval, and the testing of statistical hypothesis</li>
<li>Discusses inference that involve the comparison of two measurements</li>
<li>Analysis of two case studies. The case studies apply the tools presented in the book</li>
</ul>
<p>Much of the book is based on material from the online book &#8220;Collaborative Statistics&#8221; by Barbara Illowsky and Susan Dean.</p>
<p>The book is licensed under the conditions of the Creative Commons Attribution License (CC-BY 3.0).</td>
</tr>
<tr>
<td style="width: 200px;"><img data-attachment-id="2017" data-permalink="https://www.ossblog.org/moderndive/" data-orig-file="https://i1.wp.com/www.ossblog.org/wp-content/uploads/2017/03/ModernDive.png?fit=200%2C189&amp;ssl=1" data-orig-size="200,189" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="ModernDive" data-image-description="" data-medium-file="https://i1.wp.com/www.ossblog.org/wp-content/uploads/2017/03/ModernDive.png?fit=200%2C189&amp;ssl=1" data-large-file="https://i1.wp.com/www.ossblog.org/wp-content/uploads/2017/03/ModernDive.png?fit=200%2C189&amp;ssl=1" class="alignnone wp-image-2017 size-full" src="https://i1.wp.com/www.ossblog.org/wp-content/uploads/2017/03/ModernDive.png?resize=200%2C189&#038;ssl=1" alt="ModernDive: An Introduction to Statistical and Data Sciences via R" data-recalc-dims="1" /></td>
<td>
<h3><span style="color: #000080;"><a href="https://ismayc.github.io/moderndiver-book/">ModernDive: An Introduction to Statistical and Data Sciences via R</a></span></h3>
<p>By Chester Ismay and Albert Y. Kim (HTML)</p>
<p>ModernDive is a textbook that teaches students how to:</p>
<ol>
<li>use R to explore and visualize data</li>
<li>use randomization and simulation to build inferential ideas</li>
<li>effectively create stories using these ideas to convey information to a lay audience</li>
</ol>
<p>The book uses many R packages, and makes effective use real-world data sets to communicate key concepts. The book offers good treatment of the basics of data analysis (data wrangling and data exploration and data visualization, including the elegant roadmap for selecting a chart type shown below) and statistical concepts including simulation, regression and hypothesis testing.</p>
<p>The book also aims to give students an understanding of the overarching data analysis process, including concepts like reproducibility and telling stories with data.</p>
<p>This book is written using the CC0 1.0 Universal License.</td>
</tr>
<tr>
<td style="width: 200px;"><img data-attachment-id="2014" data-permalink="https://www.ossblog.org/alittlebookofr/" data-orig-file="https://i2.wp.com/www.ossblog.org/wp-content/uploads/2017/03/ALittleBookofR.png?fit=200%2C284&amp;ssl=1" data-orig-size="200,284" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="ALittleBookofR" data-image-description="" data-medium-file="https://i2.wp.com/www.ossblog.org/wp-content/uploads/2017/03/ALittleBookofR.png?fit=200%2C284&amp;ssl=1" data-large-file="https://i2.wp.com/www.ossblog.org/wp-content/uploads/2017/03/ALittleBookofR.png?fit=200%2C284&amp;ssl=1" class="alignnone wp-image-2014 size-full" src="https://i2.wp.com/www.ossblog.org/wp-content/uploads/2017/03/ALittleBookofR.png?resize=200%2C284&#038;ssl=1" alt="A Little Book of R for Biomedical Statistics" data-recalc-dims="1" /></td>
<td>
<h3><span style="color: #000080;"><a href="https://a-little-book-of-r-for-biomedical-statistics.readthedocs.io/en/latest/">A Little Book of R for Biomedical Statistics</a></span></h3>
<p>By Avril Coghlan (35 pages)</p>
<p>Little Book of R for Biomedical Statistics is a simple introduction to biomedical statistics using the R statistics software.</p>
<p>This booklet tells you how to use the R software to carry out some simple analyses that are common in biomedical statistics. In particular, the focus is on cohort and case-control studies that aim to test whether particular factors are associated with disease, randomised trials, and meta-analysis.</p>
<p>This booklet assumes the reader has some basic knowledge of biomedical statistics, and the principal focus of the booklet is not to explain biomedical statistics analyses, but instead to explain how to carry out these analyses using R.</p>
<p>The booklet examines:</p>
<ul>
<li>Calculating Relative Risks for a Cohort Study</li>
<li>Calculating Odds Ratios for a Cohort or Case-Control Study</li>
<li>Testing for an Association Between Disease and Exposure, in a Cohort or Case-Control Study</li>
<li>Calculating the (Mantel-Haenszel) Odds Ratio when there is a Stratifying Variable</li>
<li>Testing for an Association Between Exposure and Disease in a Matched Case-Control Study</li>
<li>Dose-response analysis</li>
<li>Calculating the Sample Size Required for a Randomised Control Trial</li>
<li>Calculating the Power of a Randomised Control Trial</li>
<li>Making a Forest Plot for a Meta-analysis of Several Different Randomised Control Trials</li>
</ul>
<p>The book is licensed under a Creative Commons Attribution 3.0 License.</td>
</tr>
<tr>
<td style="width: 200px;"><img data-attachment-id="2018" data-permalink="https://www.ossblog.org/practicalregressionanovar/" data-orig-file="https://i1.wp.com/www.ossblog.org/wp-content/uploads/2017/03/PracticalRegressionAnovaR.png?fit=200%2C267&amp;ssl=1" data-orig-size="200,267" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="PracticalRegressionAnovaR" data-image-description="" data-medium-file="https://i1.wp.com/www.ossblog.org/wp-content/uploads/2017/03/PracticalRegressionAnovaR.png?fit=200%2C267&amp;ssl=1" data-large-file="https://i1.wp.com/www.ossblog.org/wp-content/uploads/2017/03/PracticalRegressionAnovaR.png?fit=200%2C267&amp;ssl=1" class="alignnone wp-image-2018 size-full" src="https://i1.wp.com/www.ossblog.org/wp-content/uploads/2017/03/PracticalRegressionAnovaR.png?resize=200%2C267&#038;ssl=1" alt="Practical Regression and Anova in R" data-recalc-dims="1" /></td>
<td>
<h3><span style="color: #000080;"><a href="http://www.maths.bath.ac.uk/~jjf23/book/">Practical Regression and Anova in R</a></span></h3>
<p>By Julian J. Faraway (213 pages)</p>
<p>Practical Regression and Anova in R is an intermediate text on the practice of regression and analysis of variance. The objective is to learn what methods are available and more importantly, when they should be applied. The book is not an introduction to R.</p>
<p>Chapters cover:</p>
<ul>
<li>Estimation</li>
<li>Inference</li>
<li>Errors in Predictors</li>
<li>Generalized Least Squares</li>
<li>Testing for Lack of Fit</li>
<li>Diagnostics</li>
<li>Transformation</li>
<li>Scale Changes, Principal Components and Collinearity</li>
<li>Variable Selection</li>
<li>Statistical Strategy and Model Uncertainty</li>
<li>Chicago Insurance Redlining &#8211; a complete example</li>
<li>Robust and Resistant Regression</li>
<li>Missing Data</li>
<li>Analysis of Covariance</li>
<li>ANOVA (Analysis of Variance)</li>
</ul>
<p>Permission to reproduce individual copies of this book for personal use is granted.</td>
</tr>
</tbody>
</table>
<hr />
<p>Here are good free-to-download programming books.</p>
<ul>
<li><a href="http://health.adelaide.edu.au/psychology/ccs/teaching/lsr/">Learning Statistics with R</a> &#8211; covers the contents of an introductory statistics class, as typically taught to undergraduate psychology students, focusing on the use of the R statistical software.</li>
</ul>
<p>The license terms of these books are unclear.</p>
<ul>
<li><a href="https://bookdown.org/medepi/phds/">Population Health Data Science with R</a> &#8211; introduces R to public health epidemiologists and health care analysts conducting population health analyses.</li>
<li><a href="http://www.columbia.edu/~cjd11/charles_dimaggio/DIRE/resources/spatialEpiBook.pdf">Spatial Epidemiology Notes: Applications and Vignettes in R</a> &#8211; presents a relatively brief, non-jargony overview of how practicing epidemiologists can apply some of the extremely powerful spatial analytic tools that are easily available to them.</li>
</ul>
<hr />
<div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon sd-sharing"><h3 class="sd-title">Share this article:</h3><div class="sd-content"><ul><li class="share-twitter"><a href="https://www.ossblog.org/grasp-r-programming-open-source-books/?share=twitter" onclick="__gaTracker('send', 'event', 'outbound-article', 'https://www.ossblog.org/grasp-r-programming-open-source-books/?share=twitter', 'Click to share on Twitter (Opens in new window)');" rel="nofollow" data-shared="sharing-twitter-2001" class="share-twitter sd-button share-icon no-text"  target="_blank" title="Click to share on Twitter"><span></span><span class="sharing-screen-reader-text">Click to share on Twitter (Opens in new window)</span></a></li><li class="share-facebook"><a href="https://www.ossblog.org/grasp-r-programming-open-source-books/?share=facebook" onclick="__gaTracker('send', 'event', 'outbound-article', 'https://www.ossblog.org/grasp-r-programming-open-source-books/?share=facebook', 'Click to share on Facebook (Opens in new window)');" rel="nofollow" data-shared="sharing-facebook-2001" class="share-facebook sd-button share-icon no-text"  target="_blank" title="Click to share on Facebook"><span></span><span class="sharing-screen-reader-text">Click to share on Facebook (Opens in new window)</span></a></li><li class="share-google-plus-1"><a href="https://www.ossblog.org/grasp-r-programming-open-source-books/?share=google-plus-1" onclick="__gaTracker('send', 'event', 'outbound-article', 'https://www.ossblog.org/grasp-r-programming-open-source-books/?share=google-plus-1', 'Click to share on Google+ (Opens in new window)');" rel="nofollow" data-shared="sharing-google-2001" class="share-google-plus-1 sd-button share-icon no-text"  target="_blank" title="Click to share on Google+"><span></span><span class="sharing-screen-reader-text">Click to share on Google+ (Opens in new window)</span></a></li><li class="share-reddit"><a href="https://www.ossblog.org/grasp-r-programming-open-source-books/?share=reddit" onclick="__gaTracker('send', 'event', 'outbound-article', 'https://www.ossblog.org/grasp-r-programming-open-source-books/?share=reddit', 'Click to share on Reddit (Opens in new window)');" rel="nofollow" data-shared="" class="share-reddit sd-button share-icon no-text"  target="_blank" title="Click to share on Reddit"><span></span><span class="sharing-screen-reader-text">Click to share on Reddit (Opens in new window)</span></a></li><li class="share-pocket"><a href="https://www.ossblog.org/grasp-r-programming-open-source-books/?share=pocket" onclick="__gaTracker('send', 'event', 'outbound-article', 'https://www.ossblog.org/grasp-r-programming-open-source-books/?share=pocket', 'Click to share on Pocket (Opens in new window)');" rel="nofollow" data-shared="" class="share-pocket sd-button share-icon no-text"  target="_blank" title="Click to share on Pocket"><span></span><span class="sharing-screen-reader-text">Click to share on Pocket (Opens in new window)</span></a></li><li class="share-pinterest"><a href="https://www.ossblog.org/grasp-r-programming-open-source-books/?share=pinterest" onclick="__gaTracker('send', 'event', 'outbound-article', 'https://www.ossblog.org/grasp-r-programming-open-source-books/?share=pinterest', 'Click to share on Pinterest (Opens in new window)');" rel="nofollow" data-shared="sharing-pinterest-2001" class="share-pinterest sd-button share-icon no-text"  target="_blank" title="Click to share on Pinterest"><span></span><span class="sharing-screen-reader-text">Click to share on Pinterest (Opens in new window)</span></a></li><li class="share-tumblr"><a href="https://www.ossblog.org/grasp-r-programming-open-source-books/?share=tumblr" onclick="__gaTracker('send', 'event', 'outbound-article', 'https://www.ossblog.org/grasp-r-programming-open-source-books/?share=tumblr', 'Click to share on Tumblr (Opens in new window)');" rel="nofollow" data-shared="" class="share-tumblr sd-button share-icon no-text"  target="_blank" title="Click to share on Tumblr"><span></span><span class="sharing-screen-reader-text">Click to share on Tumblr (Opens in new window)</span></a></li><li class="share-linkedin"><a href="https://www.ossblog.org/grasp-r-programming-open-source-books/?share=linkedin" onclick="__gaTracker('send', 'event', 'outbound-article', 'https://www.ossblog.org/grasp-r-programming-open-source-books/?share=linkedin', 'Click to share on LinkedIn (Opens in new window)');" rel="nofollow" data-shared="sharing-linkedin-2001" class="share-linkedin sd-button share-icon no-text"  target="_blank" title="Click to share on LinkedIn"><span></span><span class="sharing-screen-reader-text">Click to share on LinkedIn (Opens in new window)</span></a></li><li class="share-email"><a href="https://www.ossblog.org/grasp-r-programming-open-source-books/?share=email" onclick="__gaTracker('send', 'event', 'outbound-article', 'https://www.ossblog.org/grasp-r-programming-open-source-books/?share=email', 'Click to email this to a friend (Opens in new window)');" rel="nofollow" data-shared="" class="share-email sd-button share-icon no-text"  target="_blank" title="Click to email this to a friend"><span></span><span class="sharing-screen-reader-text">Click to email this to a friend (Opens in new window)</span></a></li><li class="share-jetpack-whatsapp"><a rel="nofollow" data-shared="" class="share-jetpack-whatsapp sd-button share-icon no-text" href="whatsapp://send?text=Grasp%20R%20Programming%20with%20Open-Source%20Books https%3A%2F%2Fwww.ossblog.org%2Fgrasp-r-programming-open-source-books%2F" target="_blank" title="Click to share on WhatsApp"><span></span><span class="sharing-screen-reader-text">Click to share on WhatsApp (Opens in new window)</span></a></li><li class="share-end"></li></ul></div></div></div>
<div style="font-size:0px;height:0px;line-height:0px;margin:0;padding:0;clear:both"></div><div class='sharedaddy sd-block sd-like jetpack-likes-widget-wrapper jetpack-likes-widget-unloaded' id='like-post-wrapper-122191455-2001-58da86fcb866b' data-src='//widgets.wp.com/likes/#blog_id=122191455&amp;post_id=2001&amp;origin=www.ossblog.org&amp;obj_id=122191455-2001-58da86fcb866b' data-name='like-post-frame-122191455-2001-58da86fcb866b'><h3 class="sd-title">Like this:</h3><div class='likes-widget-placeholder post-likes-widget-placeholder' style='height: 55px;'><span class='button'><span>Like</span></span> <span class="loading">Loading...</span></div><span class='sd-text-color'></span><a class='sd-link-color'></a></div>
<div id='jp-relatedposts' class='jp-relatedposts' >
	<h3 class="jp-relatedposts-headline"><em>Related</em></h3>
</div>					</div>                        
					                                                        
						<p class="post-tags text-left">
		<span class="fa fa-tags"></span>
		<span>
			Tags: <a href="https://www.ossblog.org/tag/books/" rel="tag">books</a>, <a href="https://www.ossblog.org/tag/free/" rel="tag">free</a>, <a href="https://www.ossblog.org/tag/open-source/" rel="tag">open source</a>, <a href="https://www.ossblog.org/tag/programming/" rel="tag">programming</a>, <a href="https://www.ossblog.org/tag/r/" rel="tag">R</a>		</span>
	</p>
					                            
						<div class="post-navigation row">
							<div class="post-previous col-md-6"><a href="https://www.ossblog.org/asus-tinker-board-chromium-youtube-performance/" rel="prev"><span class="meta-nav">Previous:</span> Asus Tinker Board &#8211; Chromium YouTube Performance</a></div>
							<div class="post-next col-md-6"></div>
						</div>                      
					                            
											<!-- Start Related Posts -->
<div class="related-posts row"><div class="related-posts-content col-md-12"><div class="related-posts-title"><h3>Related posts</h3></div><ul class="row"> 
			<li class="rpost col-sm-6 hover-style">
				                               
					<div class="featured-thumbnail"><img width="394" height="221" src="https://i1.wp.com/www.ossblog.org/wp-content/uploads/2017/03/C-Montage.png?resize=394%2C221&amp;ssl=1" class="attachment-first-mag-home size-first-mag-home wp-post-image" alt="C# Books" data-attachment-id="1944" data-permalink="https://www.ossblog.org/c-montage-4/" data-orig-file="https://i1.wp.com/www.ossblog.org/wp-content/uploads/2017/03/C-Montage.png?fit=591%2C286&amp;ssl=1" data-orig-size="591,286" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="C#-Montage" data-image-description="" data-medium-file="https://i1.wp.com/www.ossblog.org/wp-content/uploads/2017/03/C-Montage.png?fit=300%2C145&amp;ssl=1" data-large-file="https://i1.wp.com/www.ossblog.org/wp-content/uploads/2017/03/C-Montage.png?fit=591%2C286&amp;ssl=1" /></div>                                                           
								<div class="home-header"> 
					<header>
						<h2 class="page-header">                                
			                <a href="https://www.ossblog.org/master-csharp-programming-open-source-books/" title="Master C# Programming with Open-Source Books" rel="bookmark">
								Master C# Programming with Open-Source Books			                </a>                            
						</h2> 
					</header>
					<div class="entry-summary hidden-xs">
						C# (pronounced "See Sharp") is a multi-purpose computer programming language suitable for a wide variety of development needs. C# combines the power and flexibility of... 
					</div><!-- .entry-summary -->                                                                                                                                                                                                                                          
				</div> 
			</li>
			 
			<li class="rpost col-sm-6 hover-style">
				                               
					<div class="featured-thumbnail"><img width="394" height="221" src="https://i0.wp.com/www.ossblog.org/wp-content/uploads/2017/03/ECMAScript-Montage.png?resize=394%2C221&amp;ssl=1" class="attachment-first-mag-home size-first-mag-home wp-post-image" alt="" data-attachment-id="1902" data-permalink="https://www.ossblog.org/ecmascript-montage/" data-orig-file="https://i0.wp.com/www.ossblog.org/wp-content/uploads/2017/03/ECMAScript-Montage.png?fit=580%2C277&amp;ssl=1" data-orig-size="580,277" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="ECMAScript-Montage" data-image-description="" data-medium-file="https://i0.wp.com/www.ossblog.org/wp-content/uploads/2017/03/ECMAScript-Montage.png?fit=300%2C143&amp;ssl=1" data-large-file="https://i0.wp.com/www.ossblog.org/wp-content/uploads/2017/03/ECMAScript-Montage.png?fit=580%2C277&amp;ssl=1" /></div>                                                           
								<div class="home-header"> 
					<header>
						<h2 class="page-header">                                
			                <a href="https://www.ossblog.org/learn-ecmascript-programming-with-open-source-books/" title="Learn ECMAScript Programming with Open-Source Books" rel="bookmark">
								Learn ECMAScript Programming with Open-Source Books			                </a>                            
						</h2> 
					</header>
					<div class="entry-summary hidden-xs">
						ECMAScript is an object‑oriented programming language for performing computations and manipulating computational objects within a host environment. The language was originally designed as a scripting... 
					</div><!-- .entry-summary -->                                                                                                                                                                                                                                          
				</div> 
			</li>
			</ul></div></div><!-- End Related Posts -->
										                               
						<div class="postauthor-container">
	<div class="postauthor-title">
		<h4>About The Author</h4>
	</div>
	<div class="postauthor-content">	
		<img alt='' src='https://secure.gravatar.com/avatar/0152d6eaa5447cfd8b2d57bab9ffff5f?s=100&#038;d=retro&#038;r=g' srcset='https://secure.gravatar.com/avatar/0152d6eaa5447cfd8b2d57bab9ffff5f?s=200&amp;d=retro&amp;r=g 2x' class='avatar avatar-100 photo' height='100' width='100' />		<h5 class="vcard"><span class="fn"><a href="https://www.ossblog.org/author/steve/" title="Posts by Steve Emms" rel="author">Steve Emms</a></span></h5>
		<p>Steve Emms is the main author of OSSBlog.org. This site aims to promote open source software and hardware. Steve has written thousands of articles about open source software. He is also the creator of LinuxLinks.com and SourceFiles.org.</p>
	</div>	
</div> 
					                              
						<div class="clear"></div>
	<div class="rsrc-comments">
		<a name="comments"></a>
						<div class="well">
		<div id="respond" class="comment-respond">
							<h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/grasp-r-programming-open-source-books/#respond" style="display:none;">Cancel reply</a></small></h3>
						<form id="commentform" class="comment-form">
				<iframe src="https://jetpack.wordpress.com/jetpack-comment/?blogid=122191455&#038;postid=2001&#038;comment_registration=0&#038;require_name_email=1&#038;stc_enabled=1&#038;stb_enabled=1&#038;show_avatars=1&#038;avatar_default=retro&#038;greeting=Leave+a+Reply&#038;greeting_reply=Leave+a+Reply+to+%25s&#038;color_scheme=light&#038;lang=en_US&#038;jetpack_version=4.7.1&#038;sig=5a5cd60d3ca29fa895034a829a126a048077dcaa#parent=https%3A%2F%2Fwww.ossblog.org%2Fgrasp-r-programming-open-source-books%2F" style="width:100%; height: 430px; border:0;" name="jetpack_remote_comment" class="jetpack_remote_comment" id="jetpack_remote_comment"></iframe>
				<!--[if !IE]><!-->
				<script>
					document.addEventListener( 'DOMContentLoaded', function () {
						var commentForms = document.getElementsByClassName( 'jetpack_remote_comment' );
						for ( var i = 0; i < commentForms.length; i++ ) {
							commentForms[i].allowTransparency = false;
							commentForms[i].scrolling = 'no';
						}
					} );
				</script>
				<!--<![endif]-->
			</form>
		</div>

		
		<input type="hidden" name="comment_parent" id="comment_parent" value="" />

		</div>
					</div>
                         
				</div>        
			        
		    
	</article>      
	    
		<aside id="sidebar" class="col-md-3 rsrc-right" role="complementary">
		
<!-- Quick Adsense Reloaded -->
<div id="adswidget1-quick-adsense-reloaded-4" class="widget quads-ad1_widget"><div id="quads-ad1_widget"><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- Response -->
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-6097899789476875"
     data-ad-slot="1669640918"
     data-ad-format="auto"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></div></div><div id="search-5" class="widget widget_search"><form role="search" method="get" id="searchform" class="searchform" action="https://www.ossblog.org/">
				<div>
					<label class="screen-reader-text" for="s">Search for:</label>
					<input type="text" value="" name="s" id="s" />
					<input type="submit" id="searchsubmit" value="Search" />
				</div>
			</form></div>		<div id="recent-posts-4" class="widget widget_recent_entries">		<h3 class="widget-title"><div class="title-text">Recent Posts</div><div class="widget-line"></div></h3>		<ul>
					<li>
				<a href="https://www.ossblog.org/grasp-r-programming-open-source-books/">Grasp R Programming with Open-Source Books</a>
						</li>
					<li>
				<a href="https://www.ossblog.org/asus-tinker-board-chromium-youtube-performance/">Asus Tinker Board &#8211; Chromium YouTube Performance</a>
						</li>
					<li>
				<a href="https://www.ossblog.org/master-csharp-programming-open-source-books/">Master C# Programming with Open-Source Books</a>
						</li>
					<li>
				<a href="https://www.ossblog.org/learn-ecmascript-programming-with-open-source-books/">Learn ECMAScript Programming with Open-Source Books</a>
						</li>
					<li>
				<a href="https://www.ossblog.org/master-php-programming-with-open-source-books/">Master PHP Programming with Open-Source Books</a>
						</li>
				</ul>
		</div>		<div id="categories-4" class="widget widget_categories"><h3 class="widget-title"><div class="title-text">Categories</div><div class="widget-line"></div></h3>		<ul>
	<li class="cat-item cat-item-52"><a href="https://www.ossblog.org/category/books/" >Books</a>
</li>
	<li class="cat-item cat-item-22"><a href="https://www.ossblog.org/category/distributions/" >Distributions</a>
</li>
	<li class="cat-item cat-item-6"><a href="https://www.ossblog.org/category/games/" >Games</a>
</li>
	<li class="cat-item cat-item-82"><a href="https://www.ossblog.org/category/hardware/" >Hardware</a>
</li>
	<li class="cat-item cat-item-27"><a href="https://www.ossblog.org/category/internet/" >Internet</a>
</li>
	<li class="cat-item cat-item-26"><a href="https://www.ossblog.org/category/multimedia/" >Multimedia</a>
</li>
	<li class="cat-item cat-item-2"><a href="https://www.ossblog.org/category/programming/" >Programming</a>
</li>
	<li class="cat-item cat-item-80"><a href="https://www.ossblog.org/category/reviews/" >Reviews</a>
</li>
	<li class="cat-item cat-item-65"><a href="https://www.ossblog.org/category/twtwtw/" >TWTWTW</a>
</li>
	<li class="cat-item cat-item-15"><a href="https://www.ossblog.org/category/utilities/" >Utilities</a>
</li>
		</ul>
</div><div id="meta-4" class="widget widget_meta"><h3 class="widget-title"><div class="title-text">Meta</div><div class="widget-line"></div></h3>			<ul>
						<li><a rel="nofollow" href="https://www.ossblog.org/wp-login.php">Log in</a></li>
			<li><a href="https://www.ossblog.org/feed/">Entries <abbr title="Really Simple Syndication">RSS</abbr></a></li>
			<li><a href="https://www.ossblog.org/comments/feed/">Comments <abbr title="Really Simple Syndication">RSS</abbr></a></li>
			<li><a href="https://wordpress.org/" title="Powered by WordPress, state-of-the-art semantic personal publishing platform.">WordPress.org</a></li>			</ul>
			</div>	</aside>
</div>
<!-- end content container --><!-- end content container -->

<footer id="colophon" class="rsrc-footer" role="contentinfo">
  <div class="row rsrc-author-credits">
    <p class="text-center">
			Proudly powered by <a href="https://wordpress.org/">WordPress</a>			<span class="sep"> | </span>
			Theme: <a href="http://themes4wp.com/theme/responsive-magazine">Responsive Magazine</a> by Themes4WP		</p>
  </div>
</footer> 
<p id="back-top">
  <a href="#top"><span></span></a>
</p>
<!-- end main container -->
</div>
	<div style="display:none">
	<div class="grofile-hash-map-0152d6eaa5447cfd8b2d57bab9ffff5f">
	</div>
	</div>

	<script type="text/javascript">
		window.WPCOM_sharing_counts = {"https:\/\/www.ossblog.org\/grasp-r-programming-open-source-books\/":2001};
	</script>
			<div id="sharing_email" style="display: none;">
		<form action="/grasp-r-programming-open-source-books/" method="post">
			<label for="target_email">Send to Email Address</label>
			<input type="email" name="target_email" id="target_email" value="" />

			
				<label for="source_name">Your Name</label>
				<input type="text" name="source_name" id="source_name" value="" />

				<label for="source_email">Your Email Address</label>
				<input type="email" name="source_email" id="source_email" value="" />

						<input type="text" id="jetpack-source_f_name" name="source_f_name" class="input" value="" size="25" autocomplete="off" title="This field is for validation and should not be changed" />
			<script>jQuery( document ).ready( function(){ document.getElementById('jetpack-source_f_name').value = '' });</script>
			
			<img style="float: right; display: none" class="loading" src="https://www.ossblog.org/wp-content/plugins/jetpack/modules/sharedaddy/images/loading.gif" alt="loading" width="16" height="16" />
			<input type="submit" value="Send Email" class="sharing_send" />
			<a rel="nofollow" href="#cancel" class="sharing_cancel">Cancel</a>

			<div class="errors errors-1" style="display: none;">
				Post was not sent - check your email addresses!			</div>

			<div class="errors errors-2" style="display: none;">
				Email check failed, please try again			</div>

			<div class="errors errors-3" style="display: none;">
				Sorry, your blog cannot share posts by email.			</div>
		</form>
	</div>
<script type='text/javascript' src='https://www.ossblog.org/wp-content/plugins/akismet/_inc/form.js?ver=3.3'></script>
<script type='text/javascript' src='https://www.ossblog.org/wp-content/plugins/jetpack/modules/photon/photon.js?ver=20130122'></script>
<script type='text/javascript' src='https://s0.wp.com/wp-content/js/devicepx-jetpack.js?ver=201713'></script>
<script type='text/javascript' src='https://secure.gravatar.com/js/gprofiles.js?ver=2017Maraa'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var WPGroHo = {"my_hash":""};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.ossblog.org/wp-content/plugins/jetpack/modules/wpgroho.js?ver=4.7.3'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var jetpackCarouselStrings = {"widths":[370,700,1000,1200,1400,2000],"is_logged_in":"","lang":"en","ajaxurl":"https:\/\/www.ossblog.org\/wp-admin\/admin-ajax.php","nonce":"c19cb9f3b1","display_exif":"1","display_geo":"1","single_image_gallery":"1","single_image_gallery_media_file":"","background_color":"black","comment":"Comment","post_comment":"Post Comment","write_comment":"Write a Comment...","loading_comments":"Loading Comments...","download_original":"View full size <span class=\"photo-size\">{0}<span class=\"photo-size-times\">\u00d7<\/span>{1}<\/span>","no_comment_text":"Please be sure to submit some text with your comment.","no_comment_email":"Please provide an email address to comment.","no_comment_author":"Please provide your name to comment.","comment_post_error":"Sorry, but there was an error posting your comment. Please try again later.","comment_approved":"Your comment was approved.","comment_unapproved":"Your comment is in moderation.","camera":"Camera","aperture":"Aperture","shutter_speed":"Shutter Speed","focal_length":"Focal Length","copyright":"Copyright","comment_registration":"0","require_name_email":"1","login_url":"https:\/\/www.ossblog.org\/wp-login.php?redirect_to=https%3A%2F%2Fwww.ossblog.org%2Fgrasp-r-programming-open-source-books%2F","blog_id":"1","meta_data":["camera","aperture","shutter_speed","focal_length","copyright"],"local_comments_commenting_as":"<fieldset><label for=\"email\">Email (Required)<\/label> <input type=\"text\" name=\"email\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-email-field\" \/><\/fieldset><fieldset><label for=\"author\">Name (Required)<\/label> <input type=\"text\" name=\"author\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-author-field\" \/><\/fieldset><fieldset><label for=\"url\">Website<\/label> <input type=\"text\" name=\"url\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-url-field\" \/><\/fieldset>"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.ossblog.org/wp-content/plugins/jetpack/modules/carousel/jetpack-carousel.js?ver=20170209'></script>
<script type='text/javascript' src='https://www.ossblog.org/wp-includes/js/wp-embed.min.js?ver=4.7.3'></script>
<script type='text/javascript' src='https://www.ossblog.org/wp-content/plugins/jetpack/_inc/postmessage.js?ver=4.7.1'></script>
<script type='text/javascript' src='https://www.ossblog.org/wp-content/plugins/jetpack/_inc/jquery.jetpack-resize.js?ver=4.7.1'></script>
<script type='text/javascript' src='https://www.ossblog.org/wp-content/plugins/jetpack/_inc/jquery.inview.js?ver=4.7.1'></script>
<script type='text/javascript' src='https://www.ossblog.org/wp-content/plugins/jetpack/modules/likes/queuehandler.js?ver=4.7.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var sharing_js_options = {"lang":"en","counts":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.ossblog.org/wp-content/plugins/jetpack/modules/sharedaddy/sharing.js?ver=4.7.1'></script>
<script type='text/javascript'>
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-twitter', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomtwitter', 'menubar=1,resizable=1,width=600,height=350' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-facebook', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomfacebook', 'menubar=1,resizable=1,width=600,height=400' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-google-plus-1', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomgoogle-plus-1', 'menubar=1,resizable=1,width=480,height=550' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-pocket', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcompocket', 'menubar=1,resizable=1,width=450,height=450' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-tumblr', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomtumblr', 'menubar=1,resizable=1,width=450,height=450' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-linkedin', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomlinkedin', 'menubar=1,resizable=1,width=580,height=450' );
				return false;
			});
</script>
		<iframe src='https://widgets.wp.com/likes/master.html?ver=20160429#ver=20160429' scrolling='no' id='likes-master' name='likes-master' style='display:none;'></iframe>
		<div id='likes-other-gravatars'><div class="likes-text"><span>%d</span> bloggers like this:</div><ul class="wpl-avatars sd-like-gravatars"></ul></div>
		
		<!--[if IE]>
		<script type="text/javascript">
		if ( 0 === window.location.hash.indexOf( '#comment-' ) ) {
			// window.location.reload() doesn't respect the Hash in IE
			window.location.hash = window.location.hash;
		}
		</script>
		<![endif]-->
		<script type="text/javascript">
			var comm_par_el = document.getElementById( 'comment_parent' ),
			    comm_par = (comm_par_el && comm_par_el.value) ? comm_par_el.value : '',
			    frame = document.getElementById( 'jetpack_remote_comment' ),
			    tellFrameNewParent;

			tellFrameNewParent = function() {
				if ( comm_par ) {
					frame.src = "https://jetpack.wordpress.com/jetpack-comment/?blogid=122191455&postid=2001&comment_registration=0&require_name_email=1&stc_enabled=1&stb_enabled=1&show_avatars=1&avatar_default=retro&greeting=Leave+a+Reply&greeting_reply=Leave+a+Reply+to+%25s&color_scheme=light&lang=en_US&jetpack_version=4.7.1&sig=5a5cd60d3ca29fa895034a829a126a048077dcaa#parent=https%3A%2F%2Fwww.ossblog.org%2Fgrasp-r-programming-open-source-books%2F" + '&replytocom=' + parseInt( comm_par, 10 ).toString();
				} else {
					frame.src = "https://jetpack.wordpress.com/jetpack-comment/?blogid=122191455&postid=2001&comment_registration=0&require_name_email=1&stc_enabled=1&stb_enabled=1&show_avatars=1&avatar_default=retro&greeting=Leave+a+Reply&greeting_reply=Leave+a+Reply+to+%25s&color_scheme=light&lang=en_US&jetpack_version=4.7.1&sig=5a5cd60d3ca29fa895034a829a126a048077dcaa#parent=https%3A%2F%2Fwww.ossblog.org%2Fgrasp-r-programming-open-source-books%2F";
				}
			};

	
			if ( 'undefined' !== typeof addComment ) {
				addComment._Jetpack_moveForm = addComment.moveForm;

				addComment.moveForm = function( commId, parentId, respondId, postId ) {
					var returnValue = addComment._Jetpack_moveForm( commId, parentId, respondId, postId ), cancelClick, cancel;

					if ( false === returnValue ) {
						cancel = document.getElementById( 'cancel-comment-reply-link' );
						cancelClick = cancel.onclick;
						cancel.onclick = function() {
							var cancelReturn = cancelClick.call( this );
							if ( false !== cancelReturn ) {
								return cancelReturn;
							}

							if ( !comm_par ) {
								return cancelReturn;
							}

							comm_par = 0;

							tellFrameNewParent();

							return cancelReturn;
						};
					}

					if ( comm_par == parentId ) {
						return returnValue;
					}

					comm_par = parentId;

					tellFrameNewParent();

					return returnValue;
				};
			}

	
			if ( window.postMessage ) {
				if ( document.addEventListener ) {
					window.addEventListener( 'message', function( event ) {
						if ( "https:\/\/jetpack.wordpress.com" !== event.origin ) {
							return;
						}

						jQuery( frame ).height( event.data );
					} );
				} else if ( document.attachEvent ) {
					window.attachEvent( 'message', function( event ) {
						if ( "https:\/\/jetpack.wordpress.com" !== event.origin ) {
							return;
						}

						jQuery( frame ).height( event.data );
					} );
				}
			}
		</script>

	<script type='text/javascript' src='https://stats.wp.com/e-201713.js' async defer></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:4.7.1',blog:'122191455',post:'2001',tz:'0',srv:'www.ossblog.org'} ]);
	_stq.push([ 'clickTrackerInit', '122191455', '2001' ]);
</script>
</body>
</html>