<!DOCTYPE html>
<html lang="en-US" prefix="og: http://ogp.me/ns#">
	<head>
		<meta http-equiv="content-type" content="text/html; charset=UTF-8" />
		<meta http-equiv="X-UA-Compatible" content="IE=edge">
		<meta name="viewport" content="width=device-width, initial-scale=1">
					<link rel="pingback" href="https://www.ossblog.org/xmlrpc.php">
				<title>Master Ada Programming with Free Books - OSS Blog</title>

<!-- This site is optimized with the Yoast SEO plugin v4.9 - https://yoast.com/wordpress/plugins/seo/ -->
<link rel="canonical" href="https://www.ossblog.org/master-ada-programming-free-books/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Master Ada Programming with Free Books - OSS Blog" />
<meta property="og:description" content="Ada Books Ada is a structured, statically typed, imperative, wide-spectrum, multi-paradigm, object-oriented high-level, ALGOL-like programming language, extended from Pascal and&hellip;" />
<meta property="og:url" content="https://www.ossblog.org/master-ada-programming-free-books/" />
<meta property="og:site_name" content="OSS Blog" />
<meta property="article:tag" content="Ada" />
<meta property="article:tag" content="Ada 95" />
<meta property="article:tag" content="imperative" />
<meta property="article:tag" content="object-oriented" />
<meta property="article:tag" content="statically typed" />
<meta property="article:tag" content="structured" />
<meta property="article:section" content="Books" />
<meta property="article:published_time" content="2017-06-29T09:49:59+00:00" />
<meta property="og:image" content="https://www.ossblog.org/wp-content/uploads/2017/06/Ada-Montage.png" />
<meta property="og:image:width" content="530" />
<meta property="og:image:height" content="237" />
<meta name="twitter:card" content="summary" />
<meta name="twitter:description" content="Ada Books Ada is a structured, statically typed, imperative, wide-spectrum, multi-paradigm, object-oriented high-level, ALGOL-like programming language, extended from Pascal and&hellip;" />
<meta name="twitter:title" content="Master Ada Programming with Free Books - OSS Blog" />
<meta name="twitter:image" content="https://i0.wp.com/www.ossblog.org/wp-content/uploads/2017/06/Ada-Montage.png?fit=530%2C237&#038;ssl=1" />
<!-- / Yoast SEO plugin. -->

<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//secure.gravatar.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="OSS Blog &raquo; Feed" href="https://www.ossblog.org/feed/" />
<link rel="alternate" type="application/rss+xml" title="OSS Blog &raquo; Comments Feed" href="https://www.ossblog.org/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="OSS Blog &raquo; Master Ada Programming with Free Books Comments Feed" href="https://www.ossblog.org/master-ada-programming-free-books/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.3\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.3\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.ossblog.org\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.8"}};
			!function(a,b,c){function d(a){var b,c,d,e,f=String.fromCharCode;if(!k||!k.fillText)return!1;switch(k.clearRect(0,0,j.width,j.height),k.textBaseline="top",k.font="600 32px Arial",a){case"flag":return k.fillText(f(55356,56826,55356,56819),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,56826,8203,55356,56819),0,0),c=j.toDataURL(),b===c&&(k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447),0,0),c=j.toDataURL(),b!==c);case"emoji4":return k.fillText(f(55358,56794,8205,9794,65039),0,0),d=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55358,56794,8203,9794,65039),0,0),e=j.toDataURL(),d!==e}return!1}function e(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var f,g,h,i,j=b.createElement("canvas"),k=j.getContext&&j.getContext("2d");for(i=Array("flag","emoji4"),c.supports={everything:!0,everythingExceptFlag:!0},h=0;h<i.length;h++)c.supports[i[h]]=d(i[h]),c.supports.everything=c.supports.everything&&c.supports[i[h]],"flag"!==i[h]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[i[h]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(g=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",g,!1),a.addEventListener("load",g,!1)):(a.attachEvent("onload",g),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),f=c.source||{},f.concatemoji?e(f.concatemoji):f.wpemoji&&f.twemoji&&(e(f.twemoji),e(f.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='wp-pagenavi-css'  href='https://www.ossblog.org/wp-content/plugins/wp-pagenavi/pagenavi-css.css?ver=2.70' type='text/css' media='all' />
<link rel='stylesheet' id='quads-styles-css'  href='https://www.ossblog.org/wp-content/plugins/quick-adsense-reloaded/assets/css/quads.css?ver=1.5.6' type='text/css' media='all' />
<link rel='stylesheet' id='bootstrap-css-css'  href='https://www.ossblog.org/wp-content/themes/first-mag/css/bootstrap.css?ver=1' type='text/css' media='all' />
<link rel='stylesheet' id='first-mag-stylesheet-css'  href='https://www.ossblog.org/wp-content/themes/responsive-magazine/style.css?ver=1' type='text/css' media='all' />
<link rel='stylesheet' id='font-awesome-css'  href='https://www.ossblog.org/wp-content/themes/first-mag/css/font-awesome.min.css?ver=4.8' type='text/css' media='all' />
<link rel='stylesheet' id='flexslider-css'  href='https://www.ossblog.org/wp-content/themes/first-mag/css/flexslider.css?ver=4.8' type='text/css' media='all' />
<link rel='stylesheet' id='tablepress-default-css'  href='https://www.ossblog.org/wp-content/plugins/tablepress/css/default.min.css?ver=1.8' type='text/css' media='all' />
<link rel='stylesheet' id='responsive-magazine-style-css'  href='https://www.ossblog.org/wp-content/themes/first-mag/style.css?ver=4.8' type='text/css' media='all' />
<!--[if lte IE 8]>
<link rel='stylesheet' id='jetpack-carousel-ie8fix-css'  href='https://www.ossblog.org/wp-content/plugins/jetpack/modules/carousel/jetpack-carousel-ie8fix.css?ver=20121024' type='text/css' media='all' />
<![endif]-->
<link rel='stylesheet' id='social-logos-css'  href='https://www.ossblog.org/wp-content/plugins/jetpack/_inc/social-logos/social-logos.min.css?ver=1' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='https://www.ossblog.org/wp-content/plugins/jetpack/css/jetpack.css?ver=5.0' type='text/css' media='all' />
<!-- This site uses the Google Analytics by MonsterInsights plugin v6.2.0 - Using Analytics tracking - https://www.monsterinsights.com/ -->
<script type="text/javascript" data-cfasync="false">
	/* Function to detect opted out users */
	function __gaTrackerIsOptedOut() {
		return document.cookie.indexOf(disableStr + '=true') > -1;
	}

	/* Disable tracking if the opt-out cookie exists. */
	var disableStr = 'ga-disable-UA-1447713-3';
	if ( __gaTrackerIsOptedOut() ) {
		window[disableStr] = true;
	}

	/* Opt-out function */
	function __gaTrackerOptout() {
	  document.cookie = disableStr + '=true; expires=Thu, 31 Dec 2099 23:59:59 UTC; path=/';
	  window[disableStr] = true;
	}

	(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
		(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
		m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
	})(window,document,'script','//www.google-analytics.com/analytics.js','__gaTracker');

	__gaTracker('create', 'UA-1447713-3', 'auto');
	__gaTracker('set', 'forceSSL', true);
	__gaTracker('send','pageview');
</script>
<!-- / Google Analytics by MonsterInsights -->
<script type='text/javascript' src='https://www.ossblog.org/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='https://www.ossblog.org/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var related_posts_js_options = {"post_heading":"h4"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.ossblog.org/wp-content/plugins/jetpack/modules/related-posts/related-posts.js?ver=20150408'></script>
<script type='text/javascript' src='https://www.ossblog.org/wp-content/themes/first-mag/js/bootstrap.min.js?ver=4.8'></script>
<script type='text/javascript' src='https://www.ossblog.org/wp-content/themes/first-mag/js/customscript.js?ver=4.8'></script>
<script type='text/javascript' src='https://www.ossblog.org/wp-content/themes/first-mag/js/jquery.flexslider-min.js?ver=4.8'></script>
<script type='text/javascript' src='https://www.ossblog.org/wp-content/themes/responsive-magazine/js/customscript-responsive-magazine.js?ver=1'></script>
<script type='text/javascript' src='https://www.ossblog.org/wp-content/plugins/jetpack/_inc/spin.js?ver=1.3'></script>
<script type='text/javascript' src='https://www.ossblog.org/wp-content/plugins/jetpack/_inc/jquery.spin.js?ver=1.3'></script>
<link rel='https://api.w.org/' href='https://www.ossblog.org/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.ossblog.org/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.ossblog.org/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 4.8" />
<link rel='shortlink' href='https://wp.me/p8gHzV-14B' />
<link rel="alternate" type="application/json+oembed" href="https://www.ossblog.org/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.ossblog.org%2Fmaster-ada-programming-free-books%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.ossblog.org/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.ossblog.org%2Fmaster-ada-programming-free-books%2F&#038;format=xml" />
<!-- <meta name="NextGEN" version="2.2.10" /> -->

<link rel='dns-prefetch' href='//v0.wordpress.com'>
<link rel='dns-prefetch' href='//i0.wp.com'>
<link rel='dns-prefetch' href='//i1.wp.com'>
<link rel='dns-prefetch' href='//i2.wp.com'>
<link rel='dns-prefetch' href='//jetpack.wordpress.com'>
<link rel='dns-prefetch' href='//s0.wp.com'>
<link rel='dns-prefetch' href='//s1.wp.com'>
<link rel='dns-prefetch' href='//s2.wp.com'>
<link rel='dns-prefetch' href='//public-api.wordpress.com'>
<link rel='dns-prefetch' href='//0.gravatar.com'>
<link rel='dns-prefetch' href='//1.gravatar.com'>
<link rel='dns-prefetch' href='//2.gravatar.com'>
<link rel='dns-prefetch' href='//widgets.wp.com'>
<style type='text/css'>img#wpstats{display:none}</style>		<style type="text/css">.recentcomments a{display:inline !important;padding:0 !important;margin:0 !important;}</style>
					<style type="text/css" id="wp-custom-css">
				/*
You can add your own CSS here.

Click the help icon above to learn more.
*/

a { color: black; }

a:hover { color: blue; }

			</style>
			</head>
	<body id="blog" class="post-template-default single single-post postid-4129 single-format-standard">


<div class="container rsrc-container" role="main">
	 
    <header id="site-header" class="row rsrc-header" role="banner">  
					<div class="rsrc-header-img col-md-4">
				<a href="https://www.ossblog.org/"><img src="https://www.ossblog.org/wp-content/uploads/2017/01/OSSBlog-header.png" title="OSS Blog" /></a>
			</div>
				<div class="header-ad col-md-8">
							<div id="header-ad-section" class="clearfix">
					<div id="text-4" class="widget widget_text">			<div class="textwidget"><A HREF="https://www.ossblog.org/top-software/">Free Software</A> - <A HREF="https://www.ossblog.org/opensourcebooks/">Free Books</A> -  <A HREF="https://www.ossblog.org/get-involved/">Get Involved</A> - <A HREF="https://www.ossblog.org/about/">About</A> - <A HREF="https://www.ossblog.org/chat/">Chat</A></div>
		</div>				</div>
					</div>
    </header> 




<!-- start content container -->
<!-- start content container -->
                                
	<div class="single-thumbnail row"><img width="530" height="237" src="https://i0.wp.com/www.ossblog.org/wp-content/uploads/2017/06/Ada-Montage.png?resize=530%2C237&amp;ssl=1" class="attachment-first-mag-single size-first-mag-single wp-post-image" alt="Ada Books" srcset="https://i0.wp.com/www.ossblog.org/wp-content/uploads/2017/06/Ada-Montage.png?w=530&amp;ssl=1 530w, https://i0.wp.com/www.ossblog.org/wp-content/uploads/2017/06/Ada-Montage.png?resize=300%2C134&amp;ssl=1 300w" sizes="(max-width: 530px) 100vw, 530px" data-attachment-id="4197" data-permalink="https://www.ossblog.org/ada-montage/" data-orig-file="https://i0.wp.com/www.ossblog.org/wp-content/uploads/2017/06/Ada-Montage.png?fit=530%2C237&amp;ssl=1" data-orig-size="530,237" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Ada-Montage" data-image-description="" data-medium-file="https://i0.wp.com/www.ossblog.org/wp-content/uploads/2017/06/Ada-Montage.png?fit=300%2C134&amp;ssl=1" data-large-file="https://i0.wp.com/www.ossblog.org/wp-content/uploads/2017/06/Ada-Montage.png?fit=530%2C237&amp;ssl=1" /></div>                                     
	<div class="clear"></div>                            
 
<div class="row rsrc-content">    
	    
	    
	<article class="col-md-9 rsrc-main">        
		         
				<div id="breadcrumbs" ><div class="breadcrumbs-inner text-right"><span><a href="https://www.ossblog.org"><i class="fa fa-home"></i><span>Home</span></a></span> &raquo;  <span><a href="https://www.ossblog.org/category/books/"><span>Books</span></a></span> &raquo;  <span><a href="https://www.ossblog.org/category/programming/"><span>Programming</span></a></span> &raquo;  Master Ada Programming with Free Books</div></div>                
				<div class="rsrc-post-content post-4129 post type-post status-publish format-standard has-post-thumbnail hentry category-books category-programming tag-ada tag-ada-95 tag-imperative tag-object-oriented tag-statically-typed tag-structured">                            
					<header>                              
						<h1 class="entry-title page-header">
							Master Ada Programming with Free Books						</h1>                              
						<p class="post-meta text-left"> 
	<span class="fa fa-clock-o"></span> <time class="posted-on published" datetime="2017-06-29">June 29, 2017</time>
	<span class="fa fa-user"></span> <span class="author-link"><a href="https://www.ossblog.org/author/steve/" title="Posts by Steve Emms" rel="author">Steve Emms</a></span>
	<span class="fa fa-comment"></span> <span class="comments-meta"><a href="https://www.ossblog.org/master-ada-programming-free-books/#respond" class="comments-link" >0</a></span>
	<span class="fa fa-folder-open meta-cat-icon"></span>
	<span class="meta-cat"><a href="https://www.ossblog.org/category/books/" title="View all posts in Books">Books</a>, </span><span class="meta-cat"><a href="https://www.ossblog.org/category/programming/" title="View all posts in Programming">Programming</a>, </span>	</p>                            
					</header>                                                                                     
					<div class="entry-content" >
						
<!-- WP QUADS Content Ad Plugin v. 1.5.6 -->
<div class="quads-location quads-ad1" id="quads-ad1" style="float:none;margin:0px;">
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- Response -->
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-6097899789476875"
     data-ad-slot="1669640918"
     data-ad-format="auto"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div>
<h3><strong>Ada Books</strong></h3>
<p>Ada is a structured, statically typed, imperative, wide-spectrum, multi-paradigm, object-oriented high-level, ALGOL-like programming language, extended from Pascal and other languages. The language was developed in the late 1970s and early 1980s. Ada is named after Augusta Ada Byron (often now known as Ada Lovelace), daughter of the poet Lord Byron.</p>
<p>Ada has built-in language support for explicit concurrency, offering tasks, synchronous message passing, protected objects, and non-determinism. Ada incorporates the benefits of object-oriented languages without incurring the pervasive overheads.</p>
<p>Other notable features of Ada include: strong typing, inherent reliability, modularity mechanisms (packages), run-time checking, parallel processing, exception handling, the ability to provide abstraction through the package and private type, and generics.</p>
<p>Ada is particularly strong in areas such as real-time applications, low-level hardware access, and safety-critical software, as it has specialized design features, and high reliability. Most errors are detected at compile time and of those remaining many are detected by runtime constraints. While Ada was originally targeted at embedded and real time systems, the Ada 95 revision added support for object-oriented (including dynamic dispatch), numerical, financial, and systems programming. With its readability, scalability, and being designed for development of very large software systems, Ada is a good choice for open source development.</p>
<p>We publish a series covering the best open source programming books for other popular languages. <b><a href="https://www.ossblog.org/opensourcebooks/">Read them here</a></b>.</p>
<table cellpadding="5">
<tbody>
<tr>
<td style="width: 200px;"><img data-attachment-id="4132" data-permalink="https://www.ossblog.org/ada95/" data-orig-file="https://i0.wp.com/www.ossblog.org/wp-content/uploads/2017/06/Ada95.jpg?fit=200%2C272&amp;ssl=1" data-orig-size="200,272" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Ada95" data-image-description="" data-medium-file="https://i0.wp.com/www.ossblog.org/wp-content/uploads/2017/06/Ada95.jpg?fit=200%2C272&amp;ssl=1" data-large-file="https://i0.wp.com/www.ossblog.org/wp-content/uploads/2017/06/Ada95.jpg?fit=200%2C272&amp;ssl=1" class="alignnone wp-image-4132 size-full" src="https://i0.wp.com/www.ossblog.org/wp-content/uploads/2017/06/Ada95.jpg?resize=200%2C272&#038;ssl=1" alt="Ada 95: The Craft of Object-Oriented Programming" data-recalc-dims="1" /></td>
<td>
<h3><span style="color: #000080;"><a href="http://www.adaic.org/resources/add_content/docs/craft/html/contents.htm">Ada 95: The Craft of Object-Oriented Programming</a></span></h3>
<p>By John English (486 pages)</p>
<p>Ada 95: The Craft of Object-Oriented Programming is an introduction to Ada 95. It uses an example-driven approach which gradually develops small trivial programs into large case-study type programs.</p>
<p>The main focus of this book is on maintenance problems, and using object-oriented technology to write maintainable, extensible programs. Program design is introduced throughout the book, with hypothetical maintenance scenarios used to show design shortcomings, and revise them to accommodate maintenance needs. Practical issues such as debugging programs are tackled, and important Ada features not found in other languages are dealt with practically and early on in the text. Each chapter ends with useful exercises.</p>
<p>Chapters cover:</p>
<ul>
<li>Programming concepts</li>
<li>Fundamentals of Ada &#8211; includes program layout, context clauses, strings, and the beginnings of a simple calculator which is extended in later chapters</li>
<li>Statements &#8211; covers If statements, assignment statements, compound conditions, the case statement, range tests, the null statement, loops, and exception handling</li>
<li>Procedures, functions and packages &#8211; Zeller&#8217;s Congruence, declaring procedures and functions. The chapter also examines packages including child packages</li>
<li>Defining new data types &#8211; define data types which can be tailored fairly closely to the type of information that a particular program is concerned with modelling. The chapter covers standard data types, integers, subtypes, modular integers, real types, numeric literals, constants, and enumerations. The chapter ends with the type Boolean, and the type Character</li>
<li>Composite data types &#8211; record types, strings, declaring array types, multidimensional arrays and more</li>
<li>Exceptions &#8211; shows a programmer how to declare and re-raise exceptions, and obtain information about exceptions</li>
<li>Program design and debugging</li>
</ul>
<p>Abstract Data Types</p>
<ul>
<li>Private types &#8211; examines full and partial views, deferred constants, overloaded operators, the Use type clauses, and more</li>
<li>Designing with abstract data types &#8211; separate out the user interface, design the mode, define the view package, implement the ADT packages and more</li>
<li>Dynamic memory allocation &#8211; access types, linked lists, doubly linked lists, iterators, and more</li>
<li>Generics &#8211; generic packages, generic parameters and more</li>
<li>Building a calculator</li>
</ul>
<p>Designing extensible software</p>
<ul>
<li>Tagged types &#8211; variant records, tagged types, inheriting primitive operations and more</li>
<li>Polymorphism and dispatching &#8211; class-wide types, dispatching, abstract types, and stream input/output</li>
<li>Controlled types &#8211; memory leaks, user-defined finalisation, smart pointers, user-designed assignment, and testing controlled types</li>
<li>An object-oriented calculator</li>
<li>Designing a spreadsheet</li>
<li>Multitasking &#8211; looks at active objects, task types, communicating with tasks, sharing data between tasks, and more</li>
<li>Loose ends</li>
</ul>
<p>Permission is given to redistribute this work for non-profit educational use only.</td>
</tr>
<tr>
<td style="width: 200px;"><img data-attachment-id="4133" data-permalink="https://www.ossblog.org/ada95lovelace/" data-orig-file="https://i2.wp.com/www.ossblog.org/wp-content/uploads/2017/06/Ada95Lovelace.jpg?fit=200%2C237&amp;ssl=1" data-orig-size="200,237" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Ada95Lovelace" data-image-description="" data-medium-file="https://i2.wp.com/www.ossblog.org/wp-content/uploads/2017/06/Ada95Lovelace.jpg?fit=200%2C237&amp;ssl=1" data-large-file="https://i2.wp.com/www.ossblog.org/wp-content/uploads/2017/06/Ada95Lovelace.jpg?fit=200%2C237&amp;ssl=1" class="alignnone wp-image-4133 size-full" src="https://i2.wp.com/www.ossblog.org/wp-content/uploads/2017/06/Ada95Lovelace.jpg?resize=200%2C237&#038;ssl=1" alt="Ada 95: The Lovelace Tutorial" data-recalc-dims="1" /></td>
<td>
<h3><span style="color: #000080;"><a href="http://www.adahome.com/Tutorials/Lovelace/book.htm">Ada 95: The Lovelace Tutorial</a></span></h3>
<p>By David A. Wheeler (293 pages)</p>
<p>Ada 95: The Lovelace Tutorial is an introduction to Ada 95. The book explains the basics of the Ada computer programming language and assumes that the reader has had some exposure to another algorithmic programming language (such as Pascal, C, C++, Fortran, or BASIC).</p>
<p>Lovelace is interactive and contains many short sections, most of which end with a question to help ensure the reader understands the material. Object-oriented facilities of Ada are covered in depth, and the essential features of Ada programming are given thorough treatment.</p>
<p>Lessons cover:</p>
<ul>
<li>Brief Introduction to Ada &#8211; What is Ada, simple program, use clauses, simple variable, integers, parameters and exceptions</li>
<li>Basic Ada Structure (Packages) &#8211; sections cover program units, declarations and bodies, packages, and compilation units</li>
<li>Ada Lexical Elements &#8211; looks at Ada from the bottom up</li>
<li>Procedures and Type Integer &#8211; the Ada type Integer is used to store integer values, declare a subprogram (procedure or function) declaration, subprogram Bodies and Local Variables</li>
<li>Statements (if, loop) &#8211; If statements, case statements, simple loops, and loop iteration schemes</li>
<li>Basic Types (Float, Boolean, subtypes, record) &#8211; type float, Boolean, creating types and subtypes, enumeration, arrays, records, and private and limited private types</li>
<li>Object-Oriented Programming &#8211; includes inheritance, dynamic dispatching, encapsulation, standard object-oriented format, abstract types and subprograms, and more</li>
<li>Introduction to String Types &#8211; examples types of strings, basics of type strings and more</li>
<li>Basic Input/Output &#8211; learn how to use more capabilities of Text_IO, especially how to read and write text files, line and file endings</li>
<li>Exceptions &#8211; learn how to define exceptions, how to raise exceptions, and how to handle exceptions</li>
<li>Generics &#8211; defining generics, generic formal parameters and more</li>
<li>Access Types &#8211; learn how to declare and use access types</li>
<li>Tasks and Protected Types</li>
<li>Ada-related Information</li>
<li>Ada Program Structure</li>
<li>Interfacing to Other Languages (including C and Java)</li>
<li>Miscellaneous Ada Subjects</li>
<li>Sample Ada Program &#8220;Small&#8221;</li>
</ul>
<p>The electronic version of the Lovelace tutorial is released under the terms of the GNU General Public License (GPL).</td>
</tr>
<tr>
<td style="width: 200px;"><img data-attachment-id="4137" data-permalink="https://www.ossblog.org/adaaction/" data-orig-file="https://i0.wp.com/www.ossblog.org/wp-content/uploads/2017/06/AdaAction.jpg?fit=200%2C303&amp;ssl=1" data-orig-size="200,303" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="AdaAction" data-image-description="" data-medium-file="https://i0.wp.com/www.ossblog.org/wp-content/uploads/2017/06/AdaAction.jpg?fit=198%2C300&amp;ssl=1" data-large-file="https://i0.wp.com/www.ossblog.org/wp-content/uploads/2017/06/AdaAction.jpg?fit=200%2C303&amp;ssl=1" class="alignnone wp-image-4137 size-full" src="https://i0.wp.com/www.ossblog.org/wp-content/uploads/2017/06/AdaAction.jpg?resize=200%2C303&#038;ssl=1" alt="Ada in Action" srcset="https://i0.wp.com/www.ossblog.org/wp-content/uploads/2017/06/AdaAction.jpg?w=200&amp;ssl=1 200w, https://i0.wp.com/www.ossblog.org/wp-content/uploads/2017/06/AdaAction.jpg?resize=198%2C300&amp;ssl=1 198w" sizes="(max-width: 200px) 100vw, 200px" data-recalc-dims="1" /></td>
<td>
<h3><span style="color: #000080;"><a href="https://people.cs.kuleuven.be/~dirk.craeynest/ada-belgium/aia/contents.html">Ada in Action</a></span></h3>
<p>By Do-While Jones (153 pages)</p>
<p>Ada in Action explores many selected advanced features and constructs of ADA and explains how to use them for the best results. It provides examples of how to write clear, correct, maintenance code and gives the reader re-usable components that can be used without modification in their own programs.</p>
<p>The book shows the reader to apply good software engineering principles and techniques to ADA programs through tested and proven methods. The text will be of benefit to military software and commercial software engineers and programmers, educational institutions and ADA programmers.</p>
<p>Chapters cover:</p>
<ul>
<li>Introduction</li>
<li>Numeric Considerations &#8211; examines the POOR_COORDINATES package, the STANDARD_INTEGERS package, the non-existent STANDARD_FLOATS package, DIM_INT_32 package, generic INTEGER_UNITS package, generic FLOAT_UNITS package, DIM_FLOAT package, and more</li>
<li>IO Utilities &#8211; ASCII_UTILITIES package, TEXT_IO package, VIRTUAL_TERMINAL package, SCROLL_TERMINAL package, FORM_TERMINAL package, and more</li>
<li>Programming isn&#8217;t software engineering &#8211; looks at the show tool, the more tool, the write tool, the line tool, the search tool, and more</li>
<li>Testing software components and programs</li>
</ul>
<p>The book is released under an open source license.</td>
</tr>
<tr>
<td style="width: 200px;"><img data-attachment-id="4140" data-permalink="https://www.ossblog.org/ada95rationale/" data-orig-file="https://i2.wp.com/www.ossblog.org/wp-content/uploads/2017/06/Ada95Rationale.png?fit=200%2C288&amp;ssl=1" data-orig-size="200,288" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Ada95Rationale" data-image-description="" data-medium-file="https://i2.wp.com/www.ossblog.org/wp-content/uploads/2017/06/Ada95Rationale.png?fit=200%2C288&amp;ssl=1" data-large-file="https://i2.wp.com/www.ossblog.org/wp-content/uploads/2017/06/Ada95Rationale.png?fit=200%2C288&amp;ssl=1" class="alignnone wp-image-4140 size-full" src="https://i2.wp.com/www.ossblog.org/wp-content/uploads/2017/06/Ada95Rationale.png?resize=200%2C288&#038;ssl=1" alt="Ada 95 Rationale: The Language - The Standard Libraries" data-recalc-dims="1" /></td>
<td>
<h3><span style="color: #000080;"><a href="http://www.adahome.com/LRM/95/Rationale/rat95html/rat95-contents.html">Ada 95 Rationale: The Language &#8211; The Standard Libraries</a></span></h3>
<p>By John Barnes (466 pages)</p>
<p>Ada 95 Rationale: The Language &#8211; The Standard Libraries describes the rationale for Ada 95, the revised International Standard. It introduces Ada 95 and its powerful new mechanisms, and explains the rationale behind them.</p>
<p>The first part is an Introduction to Ada 95; it presents a general discussion of the scope and objectives of Ada 95 and its major technical features. The second part contains a more detailed chapter by chapter account of the Core language. The third part covers the various Annexes which address the predefined environment and the needs of specialized application areas.</p>
<p>Chapters explore:</p>
<p>Introduction</p>
<ul>
<li>Evolution of Ada 95</li>
<li>Highlights of Ada 95 &#8211; works through the major new features of Ada 95 and the consequential benefits as seen by the general Ada user</li>
<li>Overview of the Ada Language &#8211; explores objects, types, classes and operations, statements, expressions and elaboration, system construction, multitasking, exception handling, low level programming, standard library, and application specific facilities</li>
</ul>
<p>The Core Language</p>
<ul>
<li>Introduction</li>
<li>Lexical Elements &#8211; reserved words and identifiers, program text, pragmas, and requirements summary</li>
<li>Types and Expressions &#8211; types, classes, objects, and views, character types, numeric types, composite types, array types, record types, access types, type conversion, staticness, and more</li>
<li>Object Oriented Programming &#8211; describes the various ways in which object oriented programming is achieved in Ada 95</li>
<li>Statements</li>
<li>Subprograms &#8211; covers other relatively minor improvements to subprograms</li>
<li>Packages &#8211; a number of important changes to the language are addressed in this chapter</li>
<li>Visibility Rules &#8211; visibility and scope rules are rewritten to make them consistent and clearer, the use type clause is introduced for operators, renaming is now allowed for subprogram bodies, generic units and library units, and a number of minor improvements</li>
<li>Tasking &#8211; protected types, the Requeue statement, timing and more</li>
<li>Program Structure and Compilation Issues &#8211; provides more examples of important changes in the overall structural area of the language, and discusses other topics of a structural nature</li>
<li>Exceptions</li>
<li>Generics</li>
<li>Representation Issues</li>
</ul>
<p>The Annexes</p>
<ul>
<li>A Predefined Language Environment</li>
<li>Interface to Other Languages</li>
<li>Systems Programming</li>
<li>Real-Time Systems</li>
<li>Distributed Systems</li>
<li>Information Systems</li>
<li>Numerics</li>
<li>Safety and Security</li>
</ul>
<p>This package may be freely copied and distributed, if accompanied by a statement, and provided that integral copies of all files are included (i.e. no change whatsoever is allowed).</td>
</tr>
<tr>
<td style="width: 200px;"><img data-attachment-id="4143" data-permalink="https://www.ossblog.org/ada95referencemanual/" data-orig-file="https://i0.wp.com/www.ossblog.org/wp-content/uploads/2017/06/Ada95ReferenceManual.jpeg?fit=200%2C277&amp;ssl=1" data-orig-size="200,277" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Ada95ReferenceManual" data-image-description="" data-medium-file="https://i0.wp.com/www.ossblog.org/wp-content/uploads/2017/06/Ada95ReferenceManual.jpeg?fit=200%2C277&amp;ssl=1" data-large-file="https://i0.wp.com/www.ossblog.org/wp-content/uploads/2017/06/Ada95ReferenceManual.jpeg?fit=200%2C277&amp;ssl=1" class="alignnone wp-image-4143 size-full" src="https://i0.wp.com/www.ossblog.org/wp-content/uploads/2017/06/Ada95ReferenceManual.jpeg?resize=200%2C277&#038;ssl=1" alt="Ada 95 Reference Manual" data-recalc-dims="1" /></td>
<td>
<h3><span style="color: #000080;"><a href="http://www.adahome.com/rm95/">Ada 95 Reference Manual</a></span></h3>
<p>By S. Tucker Taft, Robert A. Duff (533 pages)</p>
<p>This Ada 95 Reference Manual is essentially identical to the new International Standard ISO/IEC 8652:1995(E) for the Ada programming language.</p>
<p>The thorough technical revisions and extensions documented in this manual are built on broad participation from the international Ada community and generous support by leading institutions. Over 750 submitted revision requests were evaluated, and the resulting enhancements make Ada 95 an outstanding language. The flexibility of languages such as C++, modern features such as object orientation, and improved interfacing capabilities have been added to the reliable software engineering capabilities provided and proven for over a decade by the predecessor version Ada 83; furthermore, upward compatibility from Ada 83 to Ada 95 has been achieved.</p>
<p>Chapters cover:</p>
<p>Core Language</p>
<ul>
<li>General</li>
<li>Lexical Elements</li>
<li>Declarations and Types</li>
<li>Names and Expressions</li>
<li>Statements</li>
<li>Subprograms</li>
<li>Packages</li>
<li>Visibility Rules</li>
<li>Tasks and Synchronization</li>
<li>Program Structure and Compilation Issues</li>
<li>Exceptions</li>
<li>Generic Units</li>
<li>Representation Issues</li>
</ul>
<p>Annexes</p>
<ul>
<li>Predefined Language Environment</li>
<li>Interface to Other Languages</li>
<li>Systems Programming</li>
<li>Real-Time Systems</li>
<li>Distributed Systems</li>
<li>Information Systems</li>
<li>Numerics</li>
<li>Safety and Security</li>
<li>Obsolescent Features</li>
<li>Language-Defined Attributes</li>
<li>Language-Defined Pragmas</li>
<li>Implementation-Defined Characteristics</li>
<li>Glossary</li>
<li>Syntax Summary</li>
</ul>
<p>The whole package (wrapped in a compressed &#8220;tarfile&#8221; or &#8220;zip file&#8221;) may be freely copied and distributed, if accompanied by this statement, and provided that integral copies of all files are included (i.e. no change whatsoever is allowed).</td>
</tr>
<tr>
<td style="width: 200px;"><img data-attachment-id="4150" data-permalink="https://www.ossblog.org/adaprogramming/" data-orig-file="https://i1.wp.com/www.ossblog.org/wp-content/uploads/2017/06/AdaProgramming.jpg?fit=200%2C249&amp;ssl=1" data-orig-size="200,249" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="AdaProgramming" data-image-description="" data-medium-file="https://i1.wp.com/www.ossblog.org/wp-content/uploads/2017/06/AdaProgramming.jpg?fit=200%2C249&amp;ssl=1" data-large-file="https://i1.wp.com/www.ossblog.org/wp-content/uploads/2017/06/AdaProgramming.jpg?fit=200%2C249&amp;ssl=1" class="alignnone wp-image-4150 size-full" src="https://i1.wp.com/www.ossblog.org/wp-content/uploads/2017/06/AdaProgramming.jpg?resize=200%2C249&#038;ssl=1" alt="Ada Programming" data-recalc-dims="1" /></td>
<td>
<h3><span style="color: #000080;"><a href="https://en.wikibooks.org/wiki/Ada_Programming">Ada Programming</a></span></h3>
<p>By Wikibooks (HTML)</p>
<p>This book is an Ada tutorial covering the Ada 2005 and 2012 standards. If you&#8217;re a beginner you will learn the latest standard — if you are a seasoned Ada user you can see what&#8217;s new.</p>
<p>This book is intended for professional readers.</p>
<p>Text is available under the Creative Commons Attribution-ShareAlike License.</td>
</tr>
</tbody>
</table>

<table id="tablepress-89" class="tablepress tablepress-id-89">
<tbody class="row-hover">
<tr class="row-1 odd">
	<td class="column-1"><h4><strong>PROGRAMMING LANGUAGE PROFILES</strong><h4><a href="https://www.ossblog.org/ada-programming-language-profile/">Ada</a>, <a href="https://www.ossblog.org/bash-programming-language-profile/">Bash</a>, <a href="https://www.ossblog.org/assembly-language-programming-profile/">Assembly</a>, <a href="https://www.ossblog.org/c-programming-language-profile/">C</a>, <a href="https://www.ossblog.org/cplusplus-programming-language-profile/">C++</a>, <a href="https://www.ossblog.org/csharp-programming-language-profile/">C#</a>, <a href="https://www.ossblog.org/clojure-programming-language-profile/">Clojure</A>, <a href="https://www.ossblog.org/coffeescript-programming-language-profile/">CoffeeScript</a>, <a href="https://www.ossblog.org/ecmascript-programming-language-profile/">ECMAScript</A>, <a href="https://www.ossblog.org/erlang-programming-language-profile/">Erlang</a>, <a href="https://www.ossblog.org/forth-programming-language-profile/">Forth</a>, <a href="https://www.ossblog.org/go-programming-language-profile/">Go</a>, <a href="https://www.ossblog.org/haskell-programming-language-profile/">Haskell</a>, <a href="https://www.ossblog.org/html-programming-profile/">HTML</a>, <a href="https://www.ossblog.org/java-programming-language-profile/">Java</a>, <a href="https://www.ossblog.org/javascript-programming-language-profile/">JavaScript</a>, <a href="https://www.ossblog.org/lisp-programming-language-profile/">Lisp</a>, <a href="https://www.ossblog.org/logo-programming-language-profile/">Logo</a>, <a href="https://www.ossblog.org/lua-programming-language-profile/">Lua</a>, <a href="https://www.ossblog.org/ocaml-programming-language-profile/">OCaml</a>, <a href="https://www.ossblog.org/pascal-language-programming-profile/">Pascal</a>, <a href="https://www.ossblog.org/perl-programming-language-profile/">Perl</a>, <a href="https://www.ossblog.org/php-programming-language-profile/">PHP</a>, <a href="https://www.ossblog.org/prolog-programming-language-profile/">Prolog</a>, <a href="https://www.ossblog.org/python-programming-language-profile/">Python</A>, <a href="https://www.ossblog.org/r-programming-language-profile/">R</a>, <a href="https://www.ossblog.org/ruby-programming-language-profile/">Ruby</A>, <a href="https://www.ossblog.org/rust-programming-language-profile/">Rust</a>, <a href="https://www.ossblog.org/scala-programming-language-profile/">Scala</a>, <a href="https://www.ossblog.org/scratch-programming-language-profile/">Scratch</a>, <a href="https://www.ossblog.org/swift-programming-language-profile/">Swift</a>, <a href="https://www.ossblog.org/viml-programming-language-profile/">VimL</a></td>
</tr>
</tbody>
</table>
<!-- #tablepress-89 from cache -->
<div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon sd-sharing"><h3 class="sd-title">Share this article:</h3><div class="sd-content"><ul><li class="share-twitter"><a href="https://www.ossblog.org/master-ada-programming-free-books/?share=twitter" onclick="__gaTracker('send', 'event', 'outbound-article', 'https://www.ossblog.org/master-ada-programming-free-books/?share=twitter', 'Click to share on Twitter (Opens in new window)');" rel="nofollow" data-shared="sharing-twitter-4129" class="share-twitter sd-button share-icon no-text"  target="_blank" title="Click to share on Twitter"><span></span><span class="sharing-screen-reader-text">Click to share on Twitter (Opens in new window)</span></a></li><li class="share-facebook"><a href="https://www.ossblog.org/master-ada-programming-free-books/?share=facebook" onclick="__gaTracker('send', 'event', 'outbound-article', 'https://www.ossblog.org/master-ada-programming-free-books/?share=facebook', 'Click to share on Facebook (Opens in new window)');" rel="nofollow" data-shared="sharing-facebook-4129" class="share-facebook sd-button share-icon no-text"  target="_blank" title="Click to share on Facebook"><span></span><span class="sharing-screen-reader-text">Click to share on Facebook (Opens in new window)</span></a></li><li class="share-google-plus-1"><a href="https://www.ossblog.org/master-ada-programming-free-books/?share=google-plus-1" onclick="__gaTracker('send', 'event', 'outbound-article', 'https://www.ossblog.org/master-ada-programming-free-books/?share=google-plus-1', 'Click to share on Google+ (Opens in new window)');" rel="nofollow" data-shared="sharing-google-4129" class="share-google-plus-1 sd-button share-icon no-text"  target="_blank" title="Click to share on Google+"><span></span><span class="sharing-screen-reader-text">Click to share on Google+ (Opens in new window)</span></a></li><li class="share-reddit"><a href="https://www.ossblog.org/master-ada-programming-free-books/?share=reddit" onclick="__gaTracker('send', 'event', 'outbound-article', 'https://www.ossblog.org/master-ada-programming-free-books/?share=reddit', 'Click to share on Reddit (Opens in new window)');" rel="nofollow" data-shared="" class="share-reddit sd-button share-icon no-text"  target="_blank" title="Click to share on Reddit"><span></span><span class="sharing-screen-reader-text">Click to share on Reddit (Opens in new window)</span></a></li><li class="share-pocket"><a href="https://www.ossblog.org/master-ada-programming-free-books/?share=pocket" onclick="__gaTracker('send', 'event', 'outbound-article', 'https://www.ossblog.org/master-ada-programming-free-books/?share=pocket', 'Click to share on Pocket (Opens in new window)');" rel="nofollow" data-shared="" class="share-pocket sd-button share-icon no-text"  target="_blank" title="Click to share on Pocket"><span></span><span class="sharing-screen-reader-text">Click to share on Pocket (Opens in new window)</span></a></li><li class="share-pinterest"><a href="https://www.ossblog.org/master-ada-programming-free-books/?share=pinterest" onclick="__gaTracker('send', 'event', 'outbound-article', 'https://www.ossblog.org/master-ada-programming-free-books/?share=pinterest', 'Click to share on Pinterest (Opens in new window)');" rel="nofollow" data-shared="sharing-pinterest-4129" class="share-pinterest sd-button share-icon no-text"  target="_blank" title="Click to share on Pinterest"><span></span><span class="sharing-screen-reader-text">Click to share on Pinterest (Opens in new window)</span></a></li><li class="share-tumblr"><a href="https://www.ossblog.org/master-ada-programming-free-books/?share=tumblr" onclick="__gaTracker('send', 'event', 'outbound-article', 'https://www.ossblog.org/master-ada-programming-free-books/?share=tumblr', 'Click to share on Tumblr (Opens in new window)');" rel="nofollow" data-shared="" class="share-tumblr sd-button share-icon no-text"  target="_blank" title="Click to share on Tumblr"><span></span><span class="sharing-screen-reader-text">Click to share on Tumblr (Opens in new window)</span></a></li><li class="share-linkedin"><a href="https://www.ossblog.org/master-ada-programming-free-books/?share=linkedin" onclick="__gaTracker('send', 'event', 'outbound-article', 'https://www.ossblog.org/master-ada-programming-free-books/?share=linkedin', 'Click to share on LinkedIn (Opens in new window)');" rel="nofollow" data-shared="sharing-linkedin-4129" class="share-linkedin sd-button share-icon no-text"  target="_blank" title="Click to share on LinkedIn"><span></span><span class="sharing-screen-reader-text">Click to share on LinkedIn (Opens in new window)</span></a></li><li class="share-email"><a href="https://www.ossblog.org/master-ada-programming-free-books/?share=email" onclick="__gaTracker('send', 'event', 'outbound-article', 'https://www.ossblog.org/master-ada-programming-free-books/?share=email', 'Click to email this to a friend (Opens in new window)');" rel="nofollow" data-shared="" class="share-email sd-button share-icon no-text"  target="_blank" title="Click to email this to a friend"><span></span><span class="sharing-screen-reader-text">Click to email this to a friend (Opens in new window)</span></a></li><li class="share-jetpack-whatsapp"><a rel="nofollow" data-shared="" class="share-jetpack-whatsapp sd-button share-icon no-text" href="whatsapp://send?text=Master%20Ada%20Programming%20with%20Free%20Books https%3A%2F%2Fwww.ossblog.org%2Fmaster-ada-programming-free-books%2F" target="_blank" title="Click to share on WhatsApp"><span></span><span class="sharing-screen-reader-text">Click to share on WhatsApp (Opens in new window)</span></a></li><li class="share-telegram"><a href="https://www.ossblog.org/master-ada-programming-free-books/?share=telegram" onclick="__gaTracker('send', 'event', 'outbound-article', 'https://www.ossblog.org/master-ada-programming-free-books/?share=telegram', 'Click to share on Telegram (Opens in new window)');" rel="nofollow" data-shared="" class="share-telegram sd-button share-icon no-text"  target="_blank" title="Click to share on Telegram"><span></span><span class="sharing-screen-reader-text">Click to share on Telegram (Opens in new window)</span></a></li><li class="share-print"><a href="https://www.ossblog.org/master-ada-programming-free-books/#print" onclick="__gaTracker('send', 'event', 'outbound-article', 'https://www.ossblog.org/master-ada-programming-free-books/#print', 'Click to print (Opens in new window)');" rel="nofollow" data-shared="" class="share-print sd-button share-icon no-text"  target="_blank" title="Click to print"><span></span><span class="sharing-screen-reader-text">Click to print (Opens in new window)</span></a></li><li class="share-end"></li></ul></div></div></div>
<div style="font-size:0px;height:0px;line-height:0px;margin:0;padding:0;clear:both"></div><div class='sharedaddy sd-block sd-like jetpack-likes-widget-wrapper jetpack-likes-widget-unloaded' id='like-post-wrapper-122191455-4129-5954e8ed4dd56' data-src='//widgets.wp.com/likes/#blog_id=122191455&amp;post_id=4129&amp;origin=www.ossblog.org&amp;obj_id=122191455-4129-5954e8ed4dd56' data-name='like-post-frame-122191455-4129-5954e8ed4dd56'><h3 class="sd-title">Like this:</h3><div class='likes-widget-placeholder post-likes-widget-placeholder' style='height: 55px;'><span class='button'><span>Like</span></span> <span class="loading">Loading...</span></div><span class='sd-text-color'></span><a class='sd-link-color'></a></div>
<div id='jp-relatedposts' class='jp-relatedposts' >
	<h3 class="jp-relatedposts-headline"><em>Related</em></h3>
</div>					</div>                        
					                                                        
						<p class="post-tags text-left">
		<span class="fa fa-tags"></span>
		<span>
			Tags: <a href="https://www.ossblog.org/tag/ada/" rel="tag">Ada</a>, <a href="https://www.ossblog.org/tag/ada-95/" rel="tag">Ada 95</a>, <a href="https://www.ossblog.org/tag/imperative/" rel="tag">imperative</a>, <a href="https://www.ossblog.org/tag/object-oriented/" rel="tag">object-oriented</a>, <a href="https://www.ossblog.org/tag/statically-typed/" rel="tag">statically typed</a>, <a href="https://www.ossblog.org/tag/structured/" rel="tag">structured</a>		</span>
	</p>
					                            
						<div class="post-navigation row">
							<div class="post-previous col-md-6"><a href="https://www.ossblog.org/master-bash-programming-with-free-books/" rel="prev"><span class="meta-nav">Previous:</span> Master Bash Programming with Free Books</a></div>
							<div class="post-next col-md-6"></div>
						</div>                      
					                            
											<!-- Start Related Posts -->
<!-- End Related Posts -->
										                               
						<div class="postauthor-container">
	<div class="postauthor-title">
		<h4>About The Author</h4>
	</div>
	<div class="postauthor-content">	
		<img alt='' src='https://secure.gravatar.com/avatar/0152d6eaa5447cfd8b2d57bab9ffff5f?s=100&#038;d=retro&#038;r=g' srcset='https://secure.gravatar.com/avatar/0152d6eaa5447cfd8b2d57bab9ffff5f?s=200&amp;d=retro&amp;r=g 2x' class='avatar avatar-100 photo' height='100' width='100' />		<h5 class="vcard"><span class="fn"><a href="https://www.ossblog.org/author/steve/" title="Posts by Steve Emms" rel="author">Steve Emms</a></span></h5>
		<p>Steve Emms is the main author of OSSBlog.org. This site aims to promote open source software and hardware. Steve has written thousands of articles about open source software. He is also the creator of LinuxLinks.com and SourceFiles.org.</p>
	</div>	
</div> 
					                              
						<div class="clear"></div>
	<div class="rsrc-comments">
		<a name="comments"></a>
						<div class="well">
		<div id="respond" class="comment-respond">
							<h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/master-ada-programming-free-books/#respond" style="display:none;">Cancel reply</a></small></h3>
						<form id="commentform" class="comment-form">
				<iframe src="https://jetpack.wordpress.com/jetpack-comment/?blogid=122191455&#038;postid=4129&#038;comment_registration=0&#038;require_name_email=1&#038;stc_enabled=1&#038;stb_enabled=1&#038;show_avatars=1&#038;avatar_default=retro&#038;greeting=Leave+a+Reply&#038;greeting_reply=Leave+a+Reply+to+%25s&#038;color_scheme=light&#038;lang=en_US&#038;jetpack_version=5.0&#038;sig=ccbff38d086b86e435a1d65c837dc9780e478e5a#parent=https%3A%2F%2Fwww.ossblog.org%2Fmaster-ada-programming-free-books%2F" style="width:100%; height: 430px; border:0;" name="jetpack_remote_comment" class="jetpack_remote_comment" id="jetpack_remote_comment"></iframe>
				<!--[if !IE]><!-->
				<script>
					document.addEventListener( 'DOMContentLoaded', function () {
						var commentForms = document.getElementsByClassName( 'jetpack_remote_comment' );
						for ( var i = 0; i < commentForms.length; i++ ) {
							commentForms[i].allowTransparency = false;
							commentForms[i].scrolling = 'no';
						}
					} );
				</script>
				<!--<![endif]-->
			</form>
		</div>

		
		<input type="hidden" name="comment_parent" id="comment_parent" value="" />

		</div>
					</div>
                         
				</div>        
			        
		    
	</article>      
	    
		<aside id="sidebar" class="col-md-3 rsrc-right" role="complementary">
		
<!-- Quick Adsense Reloaded -->
<div id="adswidget1-quick-adsense-reloaded-4" class="widget quads-ad1_widget"><div id="quads-ad1_widget"><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- Response -->
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-6097899789476875"
     data-ad-slot="1669640918"
     data-ad-format="auto"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></div></div><div id="search-5" class="widget widget_search"><form role="search" method="get" id="searchform" class="searchform" action="https://www.ossblog.org/">
				<div>
					<label class="screen-reader-text" for="s">Search for:</label>
					<input type="text" value="" name="s" id="s" />
					<input type="submit" id="searchsubmit" value="Search" />
				</div>
			</form></div>		<div id="recent-posts-4" class="widget widget_recent_entries">		<h3 class="widget-title"><div class="title-text">Recent Posts</div><div class="widget-line"></div></h3>		<ul>
					<li>
				<a href="https://www.ossblog.org/master-ada-programming-free-books/">Master Ada Programming with Free Books</a>
						</li>
					<li>
				<a href="https://www.ossblog.org/master-bash-programming-with-free-books/">Master Bash Programming with Free Books</a>
						</li>
					<li>
				<a href="https://www.ossblog.org/learn-lisp-programming-free-books/">Learn Lisp Programming with Free Books</a>
						</li>
					<li>
				<a href="https://www.ossblog.org/learn-develop-lua-applications-free-books/">Learn to Develop Lua Applications with Free Books</a>
						</li>
					<li>
				<a href="https://www.ossblog.org/become-proficient-forth-free-books/">Become Proficient in Forth with Free Books</a>
						</li>
				</ul>
		</div>		<div id="archives-3" class="widget widget_archive"><h3 class="widget-title"><div class="title-text">Archives</div><div class="widget-line"></div></h3>		<ul>
			<li><a href='https://www.ossblog.org/2017/06/'>June 2017</a></li>
	<li><a href='https://www.ossblog.org/2017/05/'>May 2017</a></li>
	<li><a href='https://www.ossblog.org/2017/04/'>April 2017</a></li>
	<li><a href='https://www.ossblog.org/2017/03/'>March 2017</a></li>
	<li><a href='https://www.ossblog.org/2017/02/'>February 2017</a></li>
	<li><a href='https://www.ossblog.org/2017/01/'>January 2017</a></li>
	<li><a href='https://www.ossblog.org/2016/12/'>December 2016</a></li>
	<li><a href='https://www.ossblog.org/2016/11/'>November 2016</a></li>
		</ul>
		</div>
<!-- Quick Adsense Reloaded -->
<div id="adswidget1-quick-adsense-reloaded-8" class="widget quads-ad1_widget"><div id="quads-ad1_widget"><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- Response -->
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-6097899789476875"
     data-ad-slot="1669640918"
     data-ad-format="auto"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></div></div><div id="categories-4" class="widget widget_categories"><h3 class="widget-title"><div class="title-text">Categories</div><div class="widget-line"></div></h3>		<ul>
	<li class="cat-item cat-item-52"><a href="https://www.ossblog.org/category/books/" >Books</a>
</li>
	<li class="cat-item cat-item-22"><a href="https://www.ossblog.org/category/distributions/" >Distributions</a>
</li>
	<li class="cat-item cat-item-146"><a href="https://www.ossblog.org/category/education/" >Education</a>
</li>
	<li class="cat-item cat-item-6"><a href="https://www.ossblog.org/category/games/" >Games</a>
</li>
	<li class="cat-item cat-item-82"><a href="https://www.ossblog.org/category/hardware/" >Hardware</a>
</li>
	<li class="cat-item cat-item-27"><a href="https://www.ossblog.org/category/internet/" >Internet</a>
</li>
	<li class="cat-item cat-item-26"><a href="https://www.ossblog.org/category/multimedia/" >Multimedia</a>
</li>
	<li class="cat-item cat-item-2"><a href="https://www.ossblog.org/category/programming/" >Programming</a>
</li>
	<li class="cat-item cat-item-168"><a href="https://www.ossblog.org/category/rants-raves/" >Rants &amp; Raves</a>
</li>
	<li class="cat-item cat-item-80"><a href="https://www.ossblog.org/category/reviews/" >Reviews</a>
</li>
	<li class="cat-item cat-item-113"><a href="https://www.ossblog.org/category/science/" >Science</a>
</li>
	<li class="cat-item cat-item-114"><a href="https://www.ossblog.org/category/software/" >Software</a>
</li>
	<li class="cat-item cat-item-135"><a href="https://www.ossblog.org/category/tutorial/" >Tutorial</a>
</li>
	<li class="cat-item cat-item-65"><a href="https://www.ossblog.org/category/twtwtw/" >TWTWTW</a>
</li>
	<li class="cat-item cat-item-15"><a href="https://www.ossblog.org/category/utilities/" >Utilities</a>
</li>
		</ul>
</div><div id="recent-comments-4" class="widget widget_recent_comments"><h3 class="widget-title"><div class="title-text">Recent Comments</div><div class="widget-line"></div></h3><ul id="recentcomments"><li class="recentcomments"><span class="comment-author-link">Yngve</span> on <a href="https://www.ossblog.org/android-6-0-1-released-asus-tinker-board/#comment-406">Android 6.0.1 Released for Asus Tinker Board</a></li><li class="recentcomments"><span class="comment-author-link">puck</span> on <a href="https://www.ossblog.org/tinkeros-android-13-11-0-4-released/#comment-398">TinkerOS Android 13.11.0.4 Released</a></li><li class="recentcomments"><span class="comment-author-link">ema</span> on <a href="https://www.ossblog.org/master-c-programming-with-open-source-books/#comment-394">Master C++ Programming with Open-Source Books</a></li><li class="recentcomments"><span class="comment-author-link">Ryno P Brand</span> on <a href="https://www.ossblog.org/asus-tinker-board-review-first-impressions/#comment-389">Asus Tinker Board Review: First Impressions</a></li><li class="recentcomments"><span class="comment-author-link"><a href='http://www.linuxlinks.com' rel='external nofollow' class='url'>Steve Emms</a></span> on <a href="https://www.ossblog.org/installing-google-play-store-asus-tinker-board/#comment-385">Installing Google Play Store on the Asus Tinker Board</a></li></ul></div><div id="meta-4" class="widget widget_meta"><h3 class="widget-title"><div class="title-text">Meta</div><div class="widget-line"></div></h3>			<ul>
						<li><a rel="nofollow" href="https://www.ossblog.org/wp-login.php">Log in</a></li>
			<li><a href="https://www.ossblog.org/feed/">Entries <abbr title="Really Simple Syndication">RSS</abbr></a></li>
			<li><a href="https://www.ossblog.org/comments/feed/">Comments <abbr title="Really Simple Syndication">RSS</abbr></a></li>
			<li><a href="https://wordpress.org/" title="Powered by WordPress, state-of-the-art semantic personal publishing platform.">WordPress.org</a></li>			</ul>
			</div>	</aside>
</div>
<!-- end content container --><!-- end content container -->

<footer id="colophon" class="rsrc-footer" role="contentinfo">
  <div class="row rsrc-author-credits">
    <p class="text-center">
			Proudly powered by <a href="https://wordpress.org/">WordPress</a>			<span class="sep"> | </span>
			Theme: <a href="http://themes4wp.com/theme/responsive-magazine">Responsive Magazine</a> by Themes4WP		</p>
  </div>
</footer> 
<p id="back-top">
  <a href="#top"><span></span></a>
</p>
<!-- end main container -->
</div>
<!-- ngg_resource_manager_marker --><script type='text/javascript' src='https://www.ossblog.org/wp-content/plugins/jetpack/modules/photon/photon.js?ver=20130122'></script>
<script type='text/javascript' src='https://s0.wp.com/wp-content/js/devicepx-jetpack.js?ver=201726'></script>
<script type='text/javascript' src='https://secure.gravatar.com/js/gprofiles.js?ver=2017Junaa'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var WPGroHo = {"my_hash":""};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.ossblog.org/wp-content/plugins/jetpack/modules/wpgroho.js?ver=4.8'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var jetpackCarouselStrings = {"widths":[370,700,1000,1200,1400,2000],"is_logged_in":"","lang":"en","ajaxurl":"https:\/\/www.ossblog.org\/wp-admin\/admin-ajax.php","nonce":"8afd099694","display_exif":"1","display_geo":"1","single_image_gallery":"1","single_image_gallery_media_file":"","background_color":"black","comment":"Comment","post_comment":"Post Comment","write_comment":"Write a Comment...","loading_comments":"Loading Comments...","download_original":"View full size <span class=\"photo-size\">{0}<span class=\"photo-size-times\">\u00d7<\/span>{1}<\/span>","no_comment_text":"Please be sure to submit some text with your comment.","no_comment_email":"Please provide an email address to comment.","no_comment_author":"Please provide your name to comment.","comment_post_error":"Sorry, but there was an error posting your comment. Please try again later.","comment_approved":"Your comment was approved.","comment_unapproved":"Your comment is in moderation.","camera":"Camera","aperture":"Aperture","shutter_speed":"Shutter Speed","focal_length":"Focal Length","copyright":"Copyright","comment_registration":"0","require_name_email":"1","login_url":"https:\/\/www.ossblog.org\/wp-login.php?redirect_to=https%3A%2F%2Fwww.ossblog.org%2Fmaster-ada-programming-free-books%2F","blog_id":"1","meta_data":["camera","aperture","shutter_speed","focal_length","copyright"],"local_comments_commenting_as":"<fieldset><label for=\"email\">Email (Required)<\/label> <input type=\"text\" name=\"email\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-email-field\" \/><\/fieldset><fieldset><label for=\"author\">Name (Required)<\/label> <input type=\"text\" name=\"author\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-author-field\" \/><\/fieldset><fieldset><label for=\"url\">Website<\/label> <input type=\"text\" name=\"url\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-url-field\" \/><\/fieldset>"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.ossblog.org/wp-content/plugins/jetpack/modules/carousel/jetpack-carousel.js?ver=20170209'></script>
<script type='text/javascript' src='https://www.ossblog.org/wp-includes/js/wp-embed.min.js?ver=4.8'></script>
<script type='text/javascript' src='https://www.ossblog.org/wp-content/plugins/jetpack/_inc/postmessage.js?ver=5.0'></script>
<script type='text/javascript' src='https://www.ossblog.org/wp-content/plugins/jetpack/_inc/jquery.jetpack-resize.js?ver=5.0'></script>
<script type='text/javascript' src='https://www.ossblog.org/wp-content/plugins/jetpack/_inc/jquery.inview.js?ver=5.0'></script>
<script type='text/javascript' src='https://www.ossblog.org/wp-content/plugins/jetpack/modules/likes/queuehandler.js?ver=5.0'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var sharing_js_options = {"lang":"en","counts":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.ossblog.org/wp-content/plugins/jetpack/modules/sharedaddy/sharing.js?ver=5.0'></script>
<script type='text/javascript'>
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-twitter', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomtwitter', 'menubar=1,resizable=1,width=600,height=350' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-facebook', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomfacebook', 'menubar=1,resizable=1,width=600,height=400' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-google-plus-1', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomgoogle-plus-1', 'menubar=1,resizable=1,width=480,height=550' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-pocket', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcompocket', 'menubar=1,resizable=1,width=450,height=450' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-tumblr', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomtumblr', 'menubar=1,resizable=1,width=450,height=450' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-linkedin', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomlinkedin', 'menubar=1,resizable=1,width=580,height=450' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-telegram', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomtelegram', 'menubar=1,resizable=1,width=450,height=450' );
				return false;
			});
</script>
	<div style="display:none">
	<div class="grofile-hash-map-0152d6eaa5447cfd8b2d57bab9ffff5f">
	</div>
	</div>

	<script type="text/javascript">
		window.WPCOM_sharing_counts = {"https:\/\/www.ossblog.org\/master-ada-programming-free-books\/":4129};
	</script>
			<div id="sharing_email" style="display: none;">
		<form action="/master-ada-programming-free-books/" method="post">
			<label for="target_email">Send to Email Address</label>
			<input type="email" name="target_email" id="target_email" value="" />

			
				<label for="source_name">Your Name</label>
				<input type="text" name="source_name" id="source_name" value="" />

				<label for="source_email">Your Email Address</label>
				<input type="email" name="source_email" id="source_email" value="" />

						<input type="text" id="jetpack-source_f_name" name="source_f_name" class="input" value="" size="25" autocomplete="off" title="This field is for validation and should not be changed" />
			<script>jQuery( document ).ready( function(){ document.getElementById('jetpack-source_f_name').value = '' });</script>
			
			<img style="float: right; display: none" class="loading" src="https://www.ossblog.org/wp-content/plugins/jetpack/modules/sharedaddy/images/loading.gif" alt="loading" width="16" height="16" />
			<input type="submit" value="Send Email" class="sharing_send" />
			<a rel="nofollow" href="#cancel" class="sharing_cancel">Cancel</a>

			<div class="errors errors-1" style="display: none;">
				Post was not sent - check your email addresses!			</div>

			<div class="errors errors-2" style="display: none;">
				Email check failed, please try again			</div>

			<div class="errors errors-3" style="display: none;">
				Sorry, your blog cannot share posts by email.			</div>
		</form>
	</div>
<script type='text/javascript' src='https://www.ossblog.org/wp-content/plugins/akismet/_inc/form.js?ver=3.3.2'></script>
		<iframe src='https://widgets.wp.com/likes/master.html?ver=20160429#ver=20160429' scrolling='no' id='likes-master' name='likes-master' style='display:none;'></iframe>
		<div id='likes-other-gravatars'><div class="likes-text"><span>%d</span> bloggers like this:</div><ul class="wpl-avatars sd-like-gravatars"></ul></div>
		
		<!--[if IE]>
		<script type="text/javascript">
		if ( 0 === window.location.hash.indexOf( '#comment-' ) ) {
			// window.location.reload() doesn't respect the Hash in IE
			window.location.hash = window.location.hash;
		}
		</script>
		<![endif]-->
		<script type="text/javascript">
			var comm_par_el = document.getElementById( 'comment_parent' ),
			    comm_par = (comm_par_el && comm_par_el.value) ? comm_par_el.value : '',
			    frame = document.getElementById( 'jetpack_remote_comment' ),
			    tellFrameNewParent;

			tellFrameNewParent = function() {
				if ( comm_par ) {
					frame.src = "https://jetpack.wordpress.com/jetpack-comment/?blogid=122191455&postid=4129&comment_registration=0&require_name_email=1&stc_enabled=1&stb_enabled=1&show_avatars=1&avatar_default=retro&greeting=Leave+a+Reply&greeting_reply=Leave+a+Reply+to+%25s&color_scheme=light&lang=en_US&jetpack_version=5.0&sig=ccbff38d086b86e435a1d65c837dc9780e478e5a#parent=https%3A%2F%2Fwww.ossblog.org%2Fmaster-ada-programming-free-books%2F" + '&replytocom=' + parseInt( comm_par, 10 ).toString();
				} else {
					frame.src = "https://jetpack.wordpress.com/jetpack-comment/?blogid=122191455&postid=4129&comment_registration=0&require_name_email=1&stc_enabled=1&stb_enabled=1&show_avatars=1&avatar_default=retro&greeting=Leave+a+Reply&greeting_reply=Leave+a+Reply+to+%25s&color_scheme=light&lang=en_US&jetpack_version=5.0&sig=ccbff38d086b86e435a1d65c837dc9780e478e5a#parent=https%3A%2F%2Fwww.ossblog.org%2Fmaster-ada-programming-free-books%2F";
				}
			};

	
			if ( 'undefined' !== typeof addComment ) {
				addComment._Jetpack_moveForm = addComment.moveForm;

				addComment.moveForm = function( commId, parentId, respondId, postId ) {
					var returnValue = addComment._Jetpack_moveForm( commId, parentId, respondId, postId ), cancelClick, cancel;

					if ( false === returnValue ) {
						cancel = document.getElementById( 'cancel-comment-reply-link' );
						cancelClick = cancel.onclick;
						cancel.onclick = function() {
							var cancelReturn = cancelClick.call( this );
							if ( false !== cancelReturn ) {
								return cancelReturn;
							}

							if ( !comm_par ) {
								return cancelReturn;
							}

							comm_par = 0;

							tellFrameNewParent();

							return cancelReturn;
						};
					}

					if ( comm_par == parentId ) {
						return returnValue;
					}

					comm_par = parentId;

					tellFrameNewParent();

					return returnValue;
				};
			}

	
			if ( window.postMessage ) {
				if ( document.addEventListener ) {
					window.addEventListener( 'message', function( event ) {
						if ( "https:\/\/jetpack.wordpress.com" !== event.origin ) {
							return;
						}

						jQuery( frame ).height( event.data );
					} );
				} else if ( document.attachEvent ) {
					window.attachEvent( 'message', function( event ) {
						if ( "https:\/\/jetpack.wordpress.com" !== event.origin ) {
							return;
						}

						jQuery( frame ).height( event.data );
					} );
				}
			}
		</script>

	<script type='text/javascript' src='https://stats.wp.com/e-201726.js' async defer></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:5.0',blog:'122191455',post:'4129',tz:'0',srv:'www.ossblog.org'} ]);
	_stq.push([ 'clickTrackerInit', '122191455', '4129' ]);
</script>
</body>
</html>